expertenaustausch > linux.debian.user.german

Andreas Tille (09.03.2020, 10:00)
Hallo,

eben habe ich eine alte "Creative Live! Cam Vista IM" in meiner Schublade
gefunden und könnte sie vielleicht sinnvoll an meinem Desktop einsetzen.
Beim Einstecken in USB bekomme ich:

# dmesg | tail
[249518.155983] usb 1-5.2: new full-speed USB device number 8 using xhci_hcd
[249518.256994] usb 1-5.2: config 1 interface 0 altsetting 0 endpoint 0x81 has wMaxPacketSize 0, skipping
[249518.257866] usb 1-5.2: New USB device found, idVendor=041e, idProduct=4052, bcdDevice= 1.00
[249518.257873] usb 1-5.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[249518.257877] usb 1-5.2: Product: Creative Live! Cam Vista IM
[249518.257880] usb 1-5.2: Manufacturer:
[249518.258690] gspca_main: ov519-2.14.0 probing 041e:4052
[249520.312499] input: ov519 as /devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5.2/input/input19

# lsmod | grep gspca
gspca_ov519 57344 0
gspca_main 28672 1 gspca_ov519
videobuf2_vmalloc 20480 1 gspca_main
videobuf2_v4l2 28672 1 gspca_main
videobuf2_common 57344 2 gspca_main,videobuf2_v4l2
videodev 249856 4 gspca_main,gspca_ov519,videobuf2_v4l2,videobuf2_co mmon
usbcore 307200 10 gspca_main,gspca_ov519,xhci_hcd,usbnet,snd_usb_aud io,usbhid,snd_usbmidi_lib,xhci_pci,cdc_ether,r8152

was für mich so aussieht, als sei die Kamera erkannt und die nötigen Module
geladen. Ich mache meine Kameratests immer mit cheese. Das sagt leider:

$ cheese
** Message: 08:31:02.438: cheese-application.vala:211: Error during camera setup: Kein Gerät gefunden

(cheese:634487): cheese-CRITICAL **: 08:31:02.444: cheese_camera_device_get_name: assertion 'CHEESE_IS_CAMERA_DEVICE (device)' failed
(cheese:634487): GLib-CRITICAL **: 08:31:02.444: g_variant_new_string: assertion 'string != NULL' failed
(cheese:634487): GLib-CRITICAL **: 08:31:02.444: g_variant_ref_sink: assertion 'value != NULL' failed
(cheese:634487): GLib-GIO-CRITICAL **: 08:31:02.444: g_settings_schema_key_type_check: assertion 'value != NULL' failed
(cheese:634487): GLib-CRITICAL **: 08:31:02.444: g_variant_get_type_string: assertion 'value != NULL' failed
(cheese:634487): GLib-GIO-CRITICAL **: 08:31:02.444: g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given
(cheese:634487): GLib-CRITICAL **: 08:31:02.444: g_variant_unref: assertion 'value != NULL' failed
** (cheese:634487): CRITICAL **: 08:31:02.444: cheese_preferences_dialog_setup_resolutions_for_de vice: assertion 'device != NULL' failed

Das ganze unter einem recht frischen Debian 10 und Xfce (! letzteres mag
relevant sein, weil cheese ja irgendwie ein Gnome-Program ist.)

Hat jemand eine Idee, wie ich die alte Hardware noch irgendwie zum
Laufen kriege, bevor sie in den Müll geht?

Viele Grüße,
Andreas.
Christoph Schmees (09.03.2020, 14:00)
Hi Andreas,

Am 09.03.20 um 08:51 schrieb Andreas Tille:
[..]
> usbcore 307200 10 gspca_main,gspca_ov519,xhci_hcd,usbnet,snd_usb_aud io,usbhid,snd_usbmidi_lib,xhci_pci,cdc_ether,r8152
> was für mich so aussieht, als sei die Kamera erkannt und die nötigen Module
> geladen. Ich mache meine Kameratests immer mit cheese. Das sagt leider: ...


dein dmesg sieht doch gut aus.

Ich teste immer mit VLC oder, wenn installiert, mit Wire.
In VLC "Medien", "Aufnahmegerät öffnen", entsprechend auswählen.

hth,
Christoph
Andreas Tille (09.03.2020, 16:40)
On Mon, Mar 09, 2020 at 12:54:55PM +0100, Christoph Schmees wrote:
> dein dmesg sieht doch gut aus.


Eben. Ich dachte dann müsse *jedes* Programm die Kamera finden.

> Ich teste immer mit VLC oder, wenn installiert, mit Wire.
> In VLC "Medien", "Aufnahmegerät öffnen", entsprechend auswählen.


Ich kann bestätigen, daß VLC funktioniert.

Na egal, cheese brauche ich nicht - war halt der einfachste Test,
den ich kannte.

Vielen Dank

Andreas.
Ähnliche Themen