expertenaustausch > comp.os.* > comp.os.unix.linux.hardware

Peter Schütt (09.06.2008, 10:45)
Hallo,
ich habe hier noch einen funktionierenden Star-NL-10 (9-Nadeldrucker)
herumstehen, den ich jetzt an meinem Debian-Rechner angeschlossen habe.
Es gibt dafür sogar den passenden Treiber, aber er funktioniert nicht.
Wenn ich Star-NL-10 als Treiber auswähle, dann druckt er bei Testseite nur
irgendwelche wilden Zeichen, und nach jeder Zeile einen Formfeed.
Habt ihr eine Idee, was ich da machen muß?

Ciao
Peter Schütt
Bernd Stolle (09.06.2008, 10:57)
Peter Schütt wrote:

> Wenn ich Star-NL-10 als Treiber auswähle, dann druckt er bei Testseite nur
> irgendwelche wilden Zeichen, und nach jeder Zeile einen Formfeed.


Wenn ich mich recht erinnere, gibt es da nen Satz an Dip-Schaltern, die
natürlich sinnvoll eingestellt sein müssen. Emulation, Zeichensatz, CR/LF
usw. Tschulljung daß ich so diffus bleibe, ist halt schon ein Viertel
Jahrhundert her. Am Besten währe wohl ein Blick ins Handbuch, evtl findet
sich ja auch relevante Info im Netz.

B
Goetz Hoffart (09.06.2008, 11:34)
Peter Schütt <peter_remove_this_> wrote:

> Wenn ich Star-NL-10 als Treiber auswähle, dann druckt er bei Testseite nur
> irgendwelche wilden Zeichen, und nach jeder Zeile einen Formfeed.


Du hast ihn parallel oder seriell angeschlossen? Wenn seriell: stimmen
die Parameter?

Wenn parallel: DIP-Switch-Einstellungen geprüft? Und: was genau druckst
du denn? Einfach einen ASCII-Text? Oder etwas grafisches, etwa ein PDF?

Grüße
Götz
Peter Schütt (09.06.2008, 12:08)
Hallo,

>> Wenn ich Star-NL-10 als Treiber auswähle, dann druckt er bei Testseite
>> nur irgendwelche wilden Zeichen, und nach jeder Zeile einen Formfeed.

> Du hast ihn parallel oder seriell angeschlossen? Wenn seriell: stimmen
> die Parameter?
> Wenn parallel: DIP-Switch-Einstellungen geprüft? Und: was genau druckst
> du denn? Einfach einen ASCII-Text? Oder etwas grafisches, etwa ein PDF?


Die Testseite ist grafisch.
Ich hatte jetzt erwartet, daß der Linux-Treiber sich so wie der
Windows-Treiber.
Da hat der Drucker schon grafisch wie alle anderen Drucker gedruckt.

Bei den Dip-Einstellungen gibt es folgende:

1 Ignore Download characters
2 Paper-out detected
3 LF must be from host
4 No bottom margin
5 11"/12" Paper length (hier muß bei mir 12" hin)
6-8 Verschiedene Character Sets

Erinnert sich noch einer, was hier hin muß?

Ciao
Peter Schütt
Bernd Mayer (09.06.2008, 12:19)
Peter Schütt schrieb:
[..]
> 5 11"/12" Paper length (hier muß bei mir 12" hin)
> 6-8 Verschiedene Character Sets
> Erinnert sich noch einer, was hier hin muß?


Hallo,

hier gibts Infos und das Manual:



Bernd Mayer
Henning Paul (09.06.2008, 15:22)
Peter Schütt wrote:

>> Du hast ihn parallel oder seriell angeschlossen? Wenn seriell:
>> stimmen die Parameter?
>> Wenn parallel: DIP-Switch-Einstellungen geprüft? Und: was genau
>> druckst du denn? Einfach einen ASCII-Text? Oder etwas grafisches,
>> etwa ein PDF?

> Die Testseite ist grafisch.


Und ist er jetzt seriell oder parallel angeschlossen? Neulich hatte
jemand einen Effekt der Deinem sehr ähnlich war, weil er einen
seriellen Drucker an der Parallelport angeschlossen hatte.

Wenn Du Dir sicher bist, kannst Du ja mal versuchen, "roh" auf den
Drucker zu gehen, im Falle eines Parallelportdruckers z.B. mit
"ls -l > /dev/lp0", seriell mit "ls -l > /dev/ttyS0" (Ports bitte
anpassen).

Gruß
Henning
Volker Englisch (09.06.2008, 16:16)
Peter Schütt schrieb:
> Die Testseite ist grafisch.
> Ich hatte jetzt erwartet, daß der Linux-Treiber sich so wie der
> Windows-Treiber.
> Da hat der Drucker schon grafisch wie alle anderen Drucker gedruckt.


Wie druckst Du? Über LPD?

V.
Ansgar Strickerschmidt (09.06.2008, 17:26)
Am 09.06.2008, 15:22 Uhr, schrieb Henning Paul <henningpaul>:

> Peter Schütt wrote:
> Und ist er jetzt seriell oder parallel angeschlossen? Neulich hatte
> jemand einen Effekt der Deinem sehr ähnlich war, weil er einen
> seriellen Drucker an der Parallelport angeschlossen hatte.


Da hat er aber Glück, wenn das der Parallelport überlebt. Gerade die -12V
der RS232 sind nicht jedermanns, äh, -ports Sache, aber auch die +12V
können einen Parallelport töten...

Ansgar
Goetz Hoffart (09.06.2008, 17:34)
Henning Paul <henningpaul> wrote:

> Neulich hatte jemand einen Effekt der Deinem sehr ähnlich war, weil er
> einen seriellen Drucker an der Parallelport angeschlossen hatte.


Ich bin über Schnittstellenrobustheit immer wieder erstaunt. Ein Freund
hatte mal seinen HP DeskJet am SCSI-Port des Macs angeschlossen ...
beides tat hinterher noch.

Grüße
Götz
Peter Schütt (09.06.2008, 17:50)
Hallo,

> Und ist er jetzt seriell oder parallel angeschlossen? Neulich hatte
> jemand einen Effekt der Deinem sehr ähnlich war, weil er einen
> seriellen Drucker an der Parallelport angeschlossen hatte.
> Wenn Du Dir sicher bist, kannst Du ja mal versuchen, "roh" auf den
> Drucker zu gehen, im Falle eines Parallelportdruckers z.B. mit
> "ls -l > /dev/lp0", seriell mit "ls -l > /dev/ttyS0" (Ports bitte
> anpassen).


Er ist parallel angeschlossen und man kann ihn auch nur parallel
anschließen.

Bei ls -l > /dev/lp0
sieht es so aus, als würde er nur jeden zweiten Buchstaben drucken.
Sehr eigenartig.

Hat da noch jemand eine Idee?

Ciao
Peter Schütt
Peter Schütt (09.06.2008, 17:52)
Hallo,

> Wie druckst Du? Über LPD?


Ich habe es mal ganz naiv über Cups probiert.

Ciao
Peter Schütt
Ansgar Strickerschmidt (09.06.2008, 17:57)
Am 09.06.2008, 17:50 Uhr, schrieb Peter Schütt
<peter_remove_this_>:

> Bei ls -l > /dev/lp0
> sieht es so aus, als würde er nur jeden zweiten Buchstaben drucken.
> Sehr eigenartig.


Defektes Kabel, "BUSY"-Leitung ab?
Port mal auf Standard oder Bidirektional im BIOS umgestellt? Kommt mit
EPP/ECP vielleicht nicht klar...

Ansgar
Henning Paul (09.06.2008, 19:14)
Goetz Hoffart schrieb:

> Henning Paul <henningpaul> wrote:
>> Neulich hatte jemand einen Effekt der Deinem sehr ähnlich war, weil
>> er einen seriellen Drucker an der Parallelport angeschlossen hatte.

> Ich bin über Schnittstellenrobustheit immer wieder erstaunt. Ein
> Freund hatte mal seinen HP DeskJet am SCSI-Port des Macs angeschlossen
> ... beides tat hinterher noch.


Pegel sind dieselben, allerdings dürften ein paar Datenleitungen gegen
Masse geschlossen worden sein.

Gruß
Henning
Volker Englisch (10.06.2008, 09:42)
Peter Schütt schrieb:
> Ich habe es mal ganz naiv über Cups probiert.


Ich hab' leider keine Erfahrung mit Cups. Ich hab' hier LPD (ich habe
auch ein paar "Nadler"). Dort braucht's im printcap einen zum Drucker
passenden "Input Filter", bei mir ist magicfilter installiert, welches
dann auf ghostscript bzw. auf entsprechende Umwandlungsprogramme
zugreift.

Hast Du nur einen parallelen Port? Hast Du es nochmal mit einem anderen
parallelen Kabel versucht? Die in Deinem anderen Posting genannten
fehlenden Zeichen weisen eigentlich auf ein Synchronisationsproblem hin.
Dein paralleler Port ist in Ordnung, d.h. mit anderen Druckern
funktioniert es?

V.
Volker Englisch (10.06.2008, 09:43)
Peter Schütt schrieb:
> Bei den Dip-Einstellungen gibt es folgende:
> 1 Ignore Download characters -> würde ich erstmal auf on stellen
> 2 Paper-out detected -> on
> 3 LF must be from host -> off
> 4 No bottom margin -> on
> 5 11"/12" Paper length (hier muß bei mir 12" hin)
> 6-8 Verschiedene Character Sets


Welche gibt es da so? Womit fährt Dein Linux, mit UTF-8 oder mit
ISO-8859-x? Wenn letzteres, stelle das Charset auf etwas möglichst
passendes ein. Dann sollte wenigstens der Textausdruck eine Chance
haben. Wenn UTF-8, wirst Du den Zeichensatz für Texte umsetzen müssen.

V.

Ähnliche Themen