expertenaustausch > microsoft.* > microsoft.excel

Joe Neubacher (01.09.2004, 22:06)
Hallo an alle,

ich verwende nachstehende Formel, welche auch
funktioniert wenn in Spalte I keine Formeln stehen. In
meinem Fall brauch ich aber in Spalte I unbedingt Formeln.

{=SUMME((Jan!$F$5:$F$500=$A53)*ISTZAHL(SUCHEN("Tes t";Jan!
$D$5:$D$500))*(Jan!$I$5:$I$500))}

Kann mir bitte jemand eine Lösung anbieten. Ich hab schon
sehr viel Zeit aufgewendet und schaffs nicht...

Lg, Joe
Frank Kabel (01.09.2004, 22:48)
Hi
was für Formeln stehen denn in Spalte I?. Versuche mal folgende nicht
Matrix Formel:
=SUMMENPRODUKT(--(Jan!$F$5:$F$500=$A53);--(ISTZAHL(SUCHEN("Test";Jan!$D
$5:$D$500)));Jan!$I$5:$I$500)
Joe Neubacher (02.09.2004, 06:42)
Hallo Frank,

die Summenproduktformel konnte ich nicht eingeben, bekam
Fehler in der Formelzeile. Stimmt die Formel genau so wie
nachstehend?

Ich hab mittlerweile die Lösung. In Spalte I stand =WENN
(G56<>"";G56-H56;""). Das hab ich geändert auf =WENN
(G56<>0;G56-H56;0). Jetzt funktionierts.

Hätte aber noch eine Frage. Kann ich die untenstehende
Matrixformel waagrecht ziehen, dass überall wo {=SUMME
((Jan!... steht {=SUMME((Feb!... usw. steht. Bei mir
sieht das so aus:
Jänner Februar März April Mai Juni

A1 B1 C1 D1 E1 F1
A2 B2 C2 D2 E2 F2
usw.

Lg, Joe
[..]
Frank Kabel (02.09.2004, 10:32)
Hi
Formel funktioniert bei mir einwandfrei. Nutzt du evtl das Semikolon
als Trennsymbol?

Zu Deiner zweiten Frage. Das würde unter Hilfe von INDIREKT gehen. Also
z.B.:

=SUMMENPRODUKT(--(INDIREKT("'" & TEXT(DATUM(2004;SPALTE(A:A);1);"MMM")
& "'!F5:F500)=$A53);--(ISTZAHL(SUCHEN(INDIREKT("'" &
TEXT(DATUM(2004;SPALTE(A:A);1);"MMM") & "'!D5:D500))));INDIREKT("'" &
TEXT(DATUM(2004;SPALTE(A:A);1);"MMM") & "'!I5:I500))
Melanie Breden (02.09.2004, 11:25)
Hallo Joe,

Joe Neubacher schrieb:
> Hätte aber noch eine Frage. Kann ich die untenstehende
> Matrixformel waagrecht ziehen, dass überall wo {=SUMME
> ((Jan!... steht {=SUMME((Feb!... usw. steht. Bei mir
> sieht das so aus:
> Jänner Februar März April Mai Juni


ich habe nur eine Lösung mit einer Hilfszeile gefunden.
Dazu muss im Menü Einfügen | Namen | Definieren' der Name
"Blatt" mit folgender Formel (alles in eine Zeile) definiert werden:

=WENN(SPALTE()>VERGLEICH("";ARBEITSMAPPE.ZUORDNEN( 1+0*JETZT());-1);"";
TEIL(INDEX(ARBEITSMAPPE.ZUORDNEN(1+0*JETZT());SPAL TE());FINDEN("]";
INDEX(ARBEITSMAPPE.ZUORDNEN(1+0*JETZT());SPALTE()) )+1;31)&"!")

Verwende die Zeile 1 als Hilfszeile, diese kannst du auch ausblenden.
Schreibe folgende Formel in die Zelle A1 und ziehe sie soweit nach rechts
wie Tabellenblätter da sind:
=Blatt

Ich gehe davon aus, dass deine Summenformel ab Spalte A steht.
Verwende folgende Formel und ziehe sie nach rechts:
=SUMME((INDIREKT(A1&"$F$5:$F$500")=$A55)*ISTZAHL(
SUCHEN("Test";INDIREKT(A1&"$D$5:$D$500")))*(INDIRE KT(A1&"$I$5:$I$500")))

(Eingabe als Matrixformel mit 'Strg+Shift+Enter' abschliesssen)
Melanie Breden (02.09.2004, 11:44)
Hallo Joe,

> Joe Neubacher schrieb:


falls die Blattnamen Leerzeichen enthalten, ändern die Formel für
den definierten Namen wie folgt:

=WENN(SPALTE()>VERGLEICH("";ARBEITSMAPPE.ZUORDNEN( 1);-
1);"";"'"&TEIL(INDEX(ARBEITSMAPPE.ZUORDNEN(1);SPAL TE());FINDEN
("]";INDEX(ARBEITSMAPPE.ZUORDNEN(1+0*JETZT());SPALTE( )))+1;31)&"'!")
Ähnliche Themen