expertenaustausch > linux.debian.user.german

Elimar Riesebieter (20.05.2020, 23:20)
* Klaus Becker <colonius47> [2020-05-20 23:01 +0200]:

> Ja:
> /lib/modules/5.6.0-1-amd64/kernel/drivers/gpu/drm/nouveau
> /lib/modules/5.6.0-1-amd64/kernel/drivers/gpu/drm/nouveau/nouveau.ko


Dann sollte

# modprobe -v nouveau.ko

funtionieren?

Wenn nicht kontrolliere:

# dmesg | grep nouv

Elimar
Dirk Paul Finkeldey (21.05.2020, 09:10)
Am 20.05.20 um 21:03 schrieb Klaus Becker:
> In /usr/share/X11/xorg.conf.d/ befinden sich:
> 10-quirks.conf, 40-libinput.conf, .70-wacom.conf.
> Müsste da nicht 'ne Datei für nouveau drin sein? Auf dem Lappi, den
> ich im Moment benutze, ist eine Ati-Karte, und in obigem Ordner
> befindet sich eine Datei für Ati.


Nicht unbedingt.

Normalerweise werden beim Systemstart Grafikkarte und Monitor
automatisch erkannt und konfiguriert.

Da sind in den meisten Fällen keine festen Konfigurationen für Xserver
und Monitor mehr erforderlich.

Wenn man die Konfigurationen vor ungewollten Änderungen im Rahmen eines
Upgrade schützen möchte, sollte man diese unter /usr/local/X11 ablegen.

Das steht auch irgendwo in den Mann zu X11, weiß jetzt nur nicht so
genau wo ich das mal gelesen habe.

Gruß

Dirk
Christian Knoke (21.05.2020, 11:10)
Klaus Becker schriebst am 20. Mai um 22:12 Uhr:
> "lsmod grep nouv" zeigt nichts an, "# modprobe nouveau" geht auch nicht;
> "Invalid argument".


sieh' noch mal Elimars Post von 23:13 Uhr
Elimar Riesebieter (21.05.2020, 12:30)
* Klaus Becker <colonius47> [2020-05-20 22:12 +0200]:

> "lsmod grep nouv" zeigt nichts an, "# modprobe nouveau" geht auch nicht;
> "Invalid argument".


Das muss heissen:

lsmod | grep nouv

Die Pipe war verschluckt, sorry :-)

Elimar
Klaus Becker (22.05.2020, 20:40)
Le 21/05/2020 à 09:07, Dirk Paul Finkeldey a écrit :
> Am 20.05.20 um 21:03 schrieb Klaus Becker:


....

Ich habe versuchsweise den Kernel aus experimental (5.7.0-rc5-amd64)
installiert, und damit läuft unstable wieder!

Auch kann ich wieder Emails über meinen Provider schicken.

Ich bedanke mich bei allen, die versucht haben, mir zu helfen und die
mich dabei schließlich auf die richtige Idee gebracht haben.

Ich bin heilfroh, mein gewohntes und an meine Wünsche angepasstes System
wiederzu finden. Das ist so, als wäre ich wieder zuhause :-)

Vielleicht komme ich nochmal mit Detailfragen zum Thema zurück.

Ich wundere mich nur, dass ich offensichtlich der einzige bin, der ein
Problem mit dem Kernel unter unstable hatte.

Gruß

Klaus
Christian Knoke (23.05.2020, 12:30)
Klaus Becker schriebst am 22. Mai um 20:38 Uhr:

> Ich habe versuchsweise den Kernel aus experimental (5.7.0-rc5-amd64)
> installiert, und damit läuft unstable wieder!


> Ich wundere mich nur, dass ich offensichtlich der einzige bin, der ein
> Problem mit dem Kernel unter unstable hatte.


Ich vermute, du hast einfach den falschen Kernel gebootet. Mir ist das auch
schon passiert. Wenn du grub von verschiedenen Systemen aus updatest,
rutscht da schon mal ein alter Kernel nach oben ins Menü.

Auf einem Laptop habe ich ein heilloses durcheinander, weil dort mehrere
Grub-Installationen sind, die dem UEFI-Boot über Refind nachgeordnet sind.
Ich hoffe ich bekomme es mal hin, den Kernel dort von UEFI direkt zu booten.

Gruß
Christian
Marc Haber (Gestern, 10:10)
On Sat, 23 May 2020 12:22:04 +0200, Christian Knoke <chrisk>
wrote:
>Ich hoffe ich bekomme es mal hin, den Kernel dort von UEFI direkt zu booten.


Bist Du Dir sicher, das geht, wen man ein initramfs benutzt?

Grüße
Marc
Richard Kraut (Gestern, 19:20)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Am Mittwoch, den 27.05.2020, 10:05 +0200 schrieb Marc Haber:

> Bist Du Dir sicher, das geht, wen man ein initramfs benutzt?


Theoretisch geht das. Habe es selber noch nicht versucht.

Siehe mal hier [1] und vor allem den darin verlinkten Blogeintrag von Greg.

1: <

- --

Ähnliche Themen