expertenaustausch > linux.debian.user.german

anthropos (19.04.2020, 21:10)
Hallo Debian-Gemeinschaft,

Ich schreibe an die Liste mit Hoffnung auf Hilfe bei der Installation von Debian auf meinem Laptop.

Ich habe ein Problem mit einem Acer Aspire VN7-592G, in dass Ich nachträglicheine WD Gen3x4 NVMeSSD verbaut habe.
Die Installation mit USB-Stick der aktuellen version läuft ohne Probleme, allerdings funktioniert beim Neustart der Boot nicht.
[1] schreibt:
Acer hat anscheinend bei derEFI-Implementierung geschlampt. Es wird nur aus dem Ordner EFI/Microsoft/Boot gebootet. Das bedeutet, man muss seine EFI-Bootpartition mit Live-USB mounten und den im Ordner EFI/ubuntu vorhandenen Bootloader in dieses Verzeichnis (vorher anlegen) kopieren und die entsprechende Datei auch noch umbenennen. (bootmgfw.efi)

Ich habe mir also eine Live-Betriebssystem besorgt und auf der erstellten 30GB Partition der ganzen Systemordner den vormals leeren /boot/efi mit Microsoft/Boot/bootmgfw.efi gefüllt. Die Datei habe Ich aus boot/grub/x86_64-efi/grub.efi genommen.

Desweiteren wurde an anderer Stelle darauf hingewiesen, im UEFI-Menü vor der Installation Secure-Boot zu aktivieren, nach der Installation diegrub*.efi Datei als vertraut eingestellt. Diese Datei wurde aber an der Stelle Platte/EFI/BOOT/ angezeigt und manuell von mir nicht gefunden.

[2] ist keine wirkliche Hilfestellung, da Ich die originale Festplatteweiterhin für einen Dual-Boot nutzen mchte und gerade abgeklemmt habe.

Als Anmerkung habe Ich bis vor einiger Zeit Ubuntu auf der SSD mit 'boot-repair' zum Laufen bekommen, keine logs oä. wie.
Jetzt will Ich zu Debian wechseln und das Bootproblem manuell lösen, komme aber nicht weiter.

Ich freue mich über jede Anregung und Hilfe &Eine schöne Bastelzeit

[1] ()
[2] ()
Richard Kraut (20.04.2020, 21:00)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Am Sonntag, den 19.04.2020, 18:52 +0000 schrieb anthropos:

> Ich habe ein Problem mit einem Acer Aspire VN7-592G, in dass Ich
> nachträglich eine WD Gen3x4 NVMeSSD verbaut habe.


Evtl. hilft Dir die folgende Seite weiter [1].
Hinweis: Das dort genannte Acer Aspire-Modell könnte von Deinem abweichen.

> Die Installation mit USB-Stick der aktuellen version läuft ohne Probleme,
> allerdings funktioniert beim Neustart der Boot nicht.
> [1] schreibt:
> Acer hat anscheinend bei der EFI-Implementierung geschlampt. Es wird nur aus
> dem Ordner EFI/Microsoft/Boot gebootet. Das bedeutet, man muss seine EFI-
> Bootpartition mit Live-USB mounten und den im Ordner EFI/ubuntu vorhandenen
> Bootloader in dieses Verzeichnis (vorher anlegen) kopieren und die
> entsprechende Datei auch noch umbenennen. (bootmgfw.efi)


Hast Du es auch schon mit einem BIOS-Update versucht? Vielleicht hat Acer ja
etwas nachgebessert.

> Ich habe mir also eine Live-Betriebssystem besorgt und auf der erstellten
> 30GB Partition der ganzen Systemordner den vormals leeren /boot/efi mit
> Microsoft/Boot/bootmgfw.efi gefüllt. Die Datei habe Ich aus
> boot/grub/x86_64-efi/grub.efi genommen.


/boot/efi/ ist bei einer Installation von Debian im UEFI-Modus nicht leer bzw.
darf nicht leer sein.

Unterhalb von /boot/efi gibt es einen weiteren Ordner "EFI" (Groß-
/Kleinschreibung beachten) und hier drin befindet sich der Unterordner
"debian". In diesem Verzeichnis befinden sich nötigen Dateien, um mit UEFI
starten zu können. Bspw. der UEFI-Grub, den Shim-Bootloader für das starten
des Systems mit aktiviertem Secure Boot, ...

Die korrekte Grub-Datei für den UEFI-Start, welche dann auch getriggert wird,
heißt "grubx64.efi". Und für selbige wird auch eine "grub.cfg" angelegt (alles
im Pfad /boot/efi/EFI/debian/).

Was noch ein wichtiger Punkt ist - die ESP-Partition _muss_ mit FAT32
formatiert sein und _muss_ nach /boot/efi gemountet werden.

> Desweiteren wurde an anderer Stelle darauf hingewiesen, im UEFI-Menü vor der
> Installation Secure-Boot zu aktivieren, nach der Installation die grub*.efi
> Datei als vertraut eingestellt. Diese Datei wurde aber an der Stelle
> Platte/EFI/BOOT/ angezeigt und manuell von mir nicht gefunden.


Meist ist es umgekehrt. SecureBoot deaktivieren.
Auch würde ich den BIOS Kompatibilitätsmodus (CSM) deaktivieren. Dann muss
sich das System im UEFI-Modus installieren und kann nicht still und heimlich
in den BIOS-Modus wechseln.

1: "

"

- --
Ähnliche Themen