expertenaustausch > comp.hardware.* > comp.hardware.misc

Rusty Ruwes (25.02.2019, 21:45)
Hallo allerseits,

hoffentlich bin ich in dieser Gruppe richtig.

Ich habe hier noch ein altes Schätzchen (Dell Optiplex 755, 4GB/128GB
SSD), das mit debian Linux noch richtig flott läuft. Nur leider dauert
der Bootvorgang sehr lange und zwar bevor das OS gestartet wird.
Direkt nach dem Einschalten sieht man das Dell-Logo und es wird
angezeigt, dass man nun F2 drücken kann, um ins Setup zu gelangen und F12
für ein Bootmenü.
Drücke ich dann F2, dann kann man ungefähr 15 Sekunden lang einen
blinkenden Cursor auf dem schwarzen Bildschirm bewundern bis dann endlich
die BIOS-Einstellungen angezeigt werden (kein Passwort gesetzt).
Meine Frage ist nun, was dauert so lange bis ich ins BIOS gelange? Wenn
ich keine Taste drücke, dann blinkt der Cursor auch und dann erst kommt
der Bootloader von Linux ins Spiel.
Da ich außer der SSD und einem CD-ROM-Laufwerk sonst nichts angeschlossen
bzw. eingebaut habe, kann ich auch nichts abstöpseln, um zu sehen, ob
sich das Verhalten nun geändert hat. Das BIOS hat sogar eine Logfunktion,
aber dort gibt es auch keine Meldungen (außer ein paar alten Meldungen
wegen einer leeren CMOS-Batterie, die inzwischen ausgewechselt worden
ist).

Ich hoffe, man kann mit meinen Angaben etwas anfangen. Für sachdienliche
Hinweise wäre ich äußerst dankbar.

RR
Marcel Mueller (26.02.2019, 00:42)
Am 25.02.19 um 20:45 schrieb Rusty Ruwes:
[...]
> Drücke ich dann F2, dann kann man ungefähr 15 Sekunden lang einen
> blinkenden Cursor auf dem schwarzen Bildschirm bewundern bis dann endlich
> die BIOS-Einstellungen angezeigt werden (kein Passwort gesetzt).
> Meine Frage ist nun, was dauert so lange bis ich ins BIOS gelange? Wenn
> ich keine Taste drücke, dann blinkt der Cursor auch und dann erst kommt
> der Bootloader von Linux ins Spiel.


Der wartet auf irgendeine Hardware.
- Ein nicht angeschlossenes SATA-Device, das im BIOS eingetragen ist.
- Eingeschalteter Netzwerkboot.
- etc.

Mal BIOS Reset gemacht?

Marcel
Kay Martinen (26.02.2019, 02:05)
Am 25.02.2019 um 20:45 schrieb Rusty Ruwes:
> Ich habe hier noch ein altes Schätzchen (Dell Optiplex 755, 4GB/128GB


> Direkt nach dem Einschalten sieht man das Dell-Logo und es wird
> angezeigt, dass man nun F2 drücken kann, um ins Setup zu gelangen und F12
> für ein Bootmenü.
> Drücke ich dann F2, dann kann man ungefähr 15 Sekunden lang einen
> blinkenden Cursor auf dem schwarzen Bildschirm bewundern bis dann endlich
> die BIOS-Einstellungen angezeigt werden (kein Passwort gesetzt).
> Meine Frage ist nun, was dauert so lange bis ich ins BIOS gelange? Wenn
> ich keine Taste drücke, dann blinkt der Cursor auch und dann erst kommt
> der Bootloader von Linux ins Spiel.


Und wie lange dauert es da zwischen der F2 Meldung (wenn du sie nicht
drücktest) und dem Bootloader von Linux. Auch 15 sekunden?

Es könnte sein das der
- einen Speichertest macht ihn aber nicht zeigt.
- den speicher löscht und dann erst weiter macht.
- Eine Wartungs oder Diagnose-Partition sucht und evtl. nicht findet.

oder schlicht auf etwas anderes wartet. Bei manchen Geräten kann man
einige dieser Funktionen oder Wartezeiten darauf konfigurieren. Hast du
im BIOS schon mal danach gesucht?

Hat der eigentlich schon immer so lange gebraucht oder ist das jetzt neu
und du fragst deshalb? In dem Fall, hast du mal geschaut ob der
CPU-Lüfter dreht und wie die CPU-Temperatur ist?

Wenn die nicht völlig antiquiert ist drosselt die ihren Takt automatisch
wenn ihr zu warm wird, was an einem Festsitzenden, Verdreckten oder
versperrten Lüfter, Kühlkörper oder Kühllufttunnel liegen kann.

Kay
Rusty Ruwes (26.02.2019, 10:42)
Am Mon, 25 Feb 2019 23:42:37 +0100 schrieb Marcel Mueller:

> Am 25.02.19 um 20:45 schrieb Rusty Ruwes:
> [...]
> Der wartet auf irgendeine Hardware.
> - Ein nicht angeschlossenes SATA-Device, das im BIOS eingetragen ist.
> - Eingeschalteter Netzwerkboot.
> - etc.
> Mal BIOS Reset gemacht?


Danke für den Tipp! Nach dem Laden der Factory Defaults hat der Rechner
beim ersten Start die IDE-Konfiguration erkannt und beim zweiten Start
ging es dann sofort zum Linux-Bootscreen.
Ein Reset durchzuführen habe ich mich bisher nicht getraut. Aber ganz
offenbar geht noch alles und die Wartezeit ist weg.

Noch mal Danke, auch an Kay, obwohl ich seinen Vorschlag noch gar
ausprobiert habe.

Usenet ist cool ...
;-)
Andreas Bockelmann (26.02.2019, 15:08)
Rusty Ruwes schrieb:

> Danke für den Tipp! Nach dem Laden der Factory Defaults hat der Rechner
> beim ersten Start die IDE-Konfiguration erkannt und beim zweiten Start
> ging es dann sofort zum Linux-Bootscreen.
> Ein Reset durchzuführen habe ich mich bisher nicht getraut. Aber ganz
> offenbar geht noch alles und die Wartezeit ist weg.


Danke für Deine positive Rückmeldung, aber:
Das Laden der factory-defaults IST der Reset Deiner BIOS-Einstellungen. Von
daher: alles richtig gemacht.
Jens Kallup (03.03.2019, 14:20)
Am 26.02.19 um 01:05 schrieb Kay Martinen:
> - Eine Wartungs oder Diagnose-Partition sucht und evtl. nicht findet.


in diesen Zusammenhang könnte es auch daran liegen, daß das Bios
fehlerhafte Sektoren erkennt, und erstmal einen HD Scan macht.
In einen Älteren PC, der hier bei mir rumsteht kommt sogar eine
Nachricht vor dem Boot, das Festplatte X, und Y ausgetauscht werden
sollten - sogar mit den Kabel-Farb-Code, also diese Dinger, womit
die HD am MB angestöpselt ist

Gruß, Jens
Kay Martinen (03.03.2019, 16:43)
Am 03.03.2019 um 13:20 schrieb Jens Kallup:
> Am 26.02.19 um 01:05 schrieb Kay Martinen:
> in diesen Zusammenhang könnte es auch daran liegen, daß das Bios
> fehlerhafte Sektoren erkennt, und erstmal einen HD Scan macht.
> In einen Älteren PC, der hier bei mir rumsteht kommt sogar eine
> Nachricht vor dem Boot, das Festplatte X, und Y ausgetauscht werden
> sollten - sogar mit den Kabel-Farb-Code, also diese Dinger, womit


Das wird wohl meist vom "SMART" Schalter kommen den man oft Generell
oder pro Disk aktivieren kann. Da wird dann aber m.E. nur vom BIOS der
SMART-Zustand der Platte(n) abgefragt und dir diese Meldung gebracht.
Da wird sicher nichts gescannt, da wird das BIOS den Microcontroller der
Platte fragen "Bist du Gesund?" und diese Antwortet mit Ja oder Nein.

Ein Scan nach Sektoren macht das BIOS bestimmt nicht. Bestenfalls für
die Bootsektoren aber wenn dort ein Fehler drin steckt scheitert das
Booten ja meist eh schon.

Das eine Platte die sich per SMART als Nicht gesund ausweist
Sektorenfehler haben kann und das auch in den Bootsektoren bleibt
dadurch nach wie vor möglich.

Ich erinnere mich da an eine IDE-Platte (~ 40 GB) die beim Booten auch
sehr lange brauchte und vernehmlich klackerte. Die lief eine Weile gut,
bis zu diesem Punkt. IMHO hatte die einen Serienfehler der das bewirkt
haben sollte.

Kay
Bastian Lutz (04.03.2019, 13:35)
Hallo Jens!

Am 03.03.2019 um 13:20 schrieb Jens Kallup:
> Am 26.02.19 um 01:05 schrieb Kay Martinen:
> in diesen Zusammenhang könnte es auch daran liegen, daß das Bios
> fehlerhafte Sektoren erkennt, und erstmal einen HD Scan macht.
> In einen Älteren PC, der hier bei mir rumsteht kommt sogar eine
> Nachricht vor dem Boot, das Festplatte X, und Y ausgetauscht werden
> sollten - sogar mit den Kabel-Farb-Code, also diese Dinger, womit
> die HD am MB angestöpselt ist


Das waere mir neu, dass ein BIOS/UEFI irgendwie einen HD-Scan machen
kann. SMART-Fehlerausgabe ja (wo bei mir bei defekten Platten nie was
gemeldet wurde :-(). Glaube eher dass die Platte da mehrere Versuche
macht zu lesen. Dann haengt ggf. sogar das komplette gebootete OS. Hatte
ich schon...

Bastian Lutz
Ähnliche Themen