expertenaustausch > comp.* > comp.office-pakete.staroffice.misc

Erik Harren (01.01.2008, 18:29)
Moin zusammen!

Ich habe zwölf zweispaltige Bereiche definiert (AB_01, AB_02...AB_12)
über die ich (evtl. mit SUMMEWENN oder SVERWEIS) versuchen möchte, eine
Summe zu bilden.

In der ersten Spalte der Bereiche ist das Vergleichsmedium positioniert
(nicht unbedingt sortiert) und in der zweiten Spalte eine Zahl.

Bleistift für einen Bereich:

1;K;15
2;e;24
3;S;12

Die Summe von 'e' über alle Bereiche müsste also wenigstens 24 ergeben.

Irgend eine Idee - oder soll ich den Kram in eine Hilfstabelle schieben?

Gruß,
Erik.
Joerg Spoettl (08.01.2008, 15:52)
Am Tue, 01 Jan 2008 17:29:58 +0100 schrieb Erik Harren:

[..]
> 2;e;24
> 3;S;12
> Die Summe von 'e' über alle Bereiche müsste also wenigstens 24 ergeben.


Hallo Erik,

wie auch schon in anderen Themen so ist auch hier IMO eien Matrixformel das
Mittel zum Zweck. Der Vorteil gegenüber SUMMEWENN ist die beliebige
Erweiterbarkeit der Kriterien.

Ich habe hier z.B. eine Plotliste im Betrieb, bei der drei Kriterien
ausgewertet werden:
{=SUMME(($F$11:$F$1002="X")*($E$11:$E$1002="SW")*( $B$11:$B$1002=P15)*$K$11:$K$1002)}
Diese Formel steht in der Summenspalte (projektweise Auswertungsspalte) für
Farbdrucke unseres Plotters.
Zuerst wird geprüft ob beim jeweiligen Druckauftrag dieser Plotter
ausgewählt wurde ("X" für angekreuzt).
Als zweites wird die Art des Plots ermittelt (F für Farbe; SW für
Schwarz/weiss).
Dann wird geprüft ob das Projektkürzel der einzelnen Druckaufträge stimmt.
Und am Schluß steht der Bereich der summiert werden soll.

Sind die drei Kriterien positiv (=1) wird summiert, ist nur ein Kriterium
negativ (=0) ergibt das eine Multiplikation mit 0 => 0.

Zur Veranschaulichung würde ich dir gern die kleine Liste zukommen lassen,
wenn du willst (meine angegebene Adresse wird gelesen).

HTH
joerg
claudiadrechsle (23.01.2008, 08:30)
> > Ich habe zwölf zweispaltige Bereiche definiert (AB_01, AB_02...AB_12)
> > über die ich (evtl. mit SUMMEWENN oder SVERWEIS) versuchen möchte, eine
> > Summe zu bilden.

Die Funktion SUMMENPRODUKT() kennst Du?

mfG
Erik Harren (25.01.2008, 08:08)
Tachchen!

claudiadrechsle wrote:
>>> Ich habe zwölf zweispaltige Bereiche definiert (AB_01, AB_02...AB_12)
>>> über die ich (evtl. mit SUMMEWENN oder SVERWEIS) versuchen möchte, eine
>>> Summe zu bilden.

> Die Funktion SUMMENPRODUKT() kennst Du?
>


Ja, habe ich auch versucht, aber irgendwie klappt das nicht mit den
Bereichen, die als Zwei/Vier-Matrizen jeweils auf einem anderen
Tabellenblatt angelegt sind - oder ich bin zu doof dazu.

Gruß,
Erik.
Ähnliche Themen