expertenaustausch > linux.debian.user.german

Heimo Ponnath (29.03.2020, 12:50)
Hallo,

ich bin mir nicht sicher, ob das hier ausschliesslich ein Debian oder
Samba-Problem ist, sorry.

Seit einigen Tagen kann ich vom Windows 10 Rechner aus nicht mehr die
Shares auf meinem Debian-Rechner verwenden. Wenn ich versuche, Zugriff
darauf zu bekommen, meldet Windows 10 immer:
Das angegebene Netzwerkkennwort ist falsch

Es hat den Anschein als hätte MS bei der letzten Aktualisierung etwas
verändert, das mir den Zugriff verweigert. Möglicherweise muss ich
daraufhin etwas in der samba.conf ändern? Hier die Ausgabe von
testparm:

# Global parameters
[global]
bind interfaces only = Yes
interfaces = 192.168.1.0/24 enp0s9
log file = /var/log/samba/log.%m
logging = file
map to guest = Bad User
max log size = 1000
obey pam restrictions = Yes
pam password change = Yes
panic action = /usr/share/samba/panic-action %d
passwd chat = *Enter\snew\s*\spassword:* %n\n
*Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
passwd program = /usr/bin/passwd %u
server min protocol = SMB2
server role = standalone server
unix password sync = Yes
workgroup = HEIMO
idmap config * : backend = tdb

[homes]
comment = Home Directories
create mask = 0775
directory mask = 0775
read only = No

[printers]
browseable = No
comment = All Printers
create mask = 0700
path = /var/spool/samba
printable = Yes

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers

[ponnath]
admin users = ponnath
force user = root
guest ok = Yes
path = /home/ponnath
read only = No
valid users = ponnath

Ich habe mir inzwischen schon den Wolf gegoogelt und wundere mich, dass
offenbar nicht viele andere mein Problem haben - habe kaum etwas
relevantes gefunden. Hat von Euch jemand eine Idee?

Liebe Grüße von Heimo
A. Söldner (29.03.2020, 13:40)
Hallo Heimo,

spontan fällt mir dazu nur ein wie die Passwörter verschlüsselt werden.
Vor grauer Vorzeit hatte ich mal ein ähnliches Problem.

Gruß
A.

Am 29.03.2020 um 12:41 schrieb Heimo Ponnath:
[..]
Christoph Schmees (29.03.2020, 16:40)
Am 29.03.20 um 12:41 schrieb Heimo Ponnath:
> Hallo,
> ich bin mir nicht sicher, ob das hier ausschliesslich ein Debian oder
> Samba-Problem ist, sorry.
> Seit einigen Tagen kann ich vom Windows 10 Rechner aus nicht mehr die
> Shares auf meinem Debian-Rechner verwenden. Wenn ich versuche, Zugriff
> darauf zu bekommen, meldet Windows 10 immer:
> Das angegebene Netzwerkkennwort ist falsch


das ist IMHO weder ein debian-, noch ein Samba-Problem. Das Problem hat einen Namen, der heißt MS oder W-X. MS fummelt gerne mal an W-X Systemeigenschaften herum, um die Interoperabilität mit älteren Systemen zu behindern.

((Ich setze mal voraus, dass du die aktuelle Samba installiert hast, dieseSeite <https://www.samba.org/samba/docs/current/man-html/smb.conf.5.html>kennst und nicht mit '[[server] max] protocol' gespielt hast))

> Es hat den Anschein als hätte MS bei der letzten Aktualisierung etwas
> verändert, das mir den Zugriff verweigert. Möglicherweise mussich
> daraufhin etwas in der samba.conf ändern? ....
> Ich habe mir inzwischen schon den Wolf gegoogelt und wundere mich, dass
> offenbar nicht viele andere mein Problem haben - habe kaum etwas
> relevantes gefunden. Hat von Euch jemand eine Idee?


Gurgel ist grundsätzlich eine schlechte Adresse für Suchen (wg. Manipulation + Zensur). Hier meine Ideen:
<https://www.startpage.com/do/dsearch?query=windows+10+shares&cat=web&pl=opensea rch&language=deutsch>
<https://duckduckgo.com/?t=lm&q=windows+10+smb2+freischalten&atb=v116-1&ia=web>
Einige herausragende Einzelfunde:
<https://support.microsoft.com/en-us/help/4092694/windows-10-file-sharing-over-a-network>
<https://docs.microsoft.com/de-de/windows-server/storage/file-server/troubleshoot/detect-enable-and-disable-smbv1-v2-v3>
<https://community.spiceworks.com/topic/1162811-windows-10-can-t-access-network-shares>
<https://lifehacker.com/why-cant-windows-10-find-my-shared-network-folders-1841669387>

Ich weiß schon, weshalb ich W-X ablehne ...

hth, Christoph
Heimo Ponnath (29.03.2020, 19:40)
Sorry Christian,

das bringt leider alles keine Lösung.

Dank für Deine Mühe und liebe Grüße von

Heimo

Am Sonntag, den 29.03.2020, 16:29 +0200 schrieb Christoph Schmees:
[..]
Heimo Ponnath (31.03.2020, 13:50)
Hallo Liste,

das Problem war nach tagelanger Suche schließlich noch zu lösen:
In den [global]-Teil der smb.conf habe ich eingetragen:
ntlm auth = yes
Restart von Samba - und siehe da, alle Shares sind wieder problemlos
zugreifbar!

Liebe Grüße von Heimo

Am Sonntag, den 29.03.2020, 13:37 +0200 schrieb A. Söldner:
[..]
Marc Haber (01.04.2020, 14:10)
On Sun, 29 Mar 2020 12:41:13 +0200, Heimo Ponnath <ponnath>
wrote:
>Seit einigen Tagen kann ich vom Windows 10 Rechner aus nicht mehr die
>Shares auf meinem Debian-Rechner verwenden. Wenn ich versuche, Zugriff
>darauf zu bekommen, meldet Windows 10 immer:
>Das angegebene Netzwerkkennwort ist falsch


Was hat sich denn auf welchem System seit dem letzten erfolgreichen
Zugriff verändert?

Grüße
Marc
Heimo Ponnath (01.04.2020, 17:00)
Hallo Marc,

Das muß an einem Windows 10 Update gelegen haben, das ich kurz zuvor
erhalten habe. Das Problem konnte ich gottlob gestern lösen indem ich
in die smb.conf in der [global]-Sektion noch eingetragen habe:
ntlm auth = yes
Ich weiss noch nicht genau, was das bewirkt, es schein aber etwas mit
der Authentifizierung (lanman, und Win NT) zu tun zu haben.

Eine Notlösung habe ich zuerst durchgeführt: Das Windows 10 Notebook
meiner Frau hatte tatsächlich noch Verbindung mit dem Debian-Rechner.
Das habe ich dann die 8 GByte draufgeschoben - und von da aus auf
meinen Windwos 10 Rechner. Als das fertig war, hatte ich aber das
Problem schon gelöst - war also für die Katz :-)

Liebe Grüße sendet Dir

Heimo

Am Mittwoch, den 01.04.2020, 13:59 +0200 schrieb Marc Haber:
[..]
Ulf Volmer (01.04.2020, 17:10)
On 31.03.20 13:42, Heimo Ponnath wrote:

> das Problem war nach tagelanger Suche schließlich noch zu lösen:
> In den [global]-Teil der smb.conf habe ich eingetragen:
> ntlm auth = yes
> Restart von Samba - und siehe da, alle Shares sind wieder problemlos
> zugreifbar!


Aus

In order to improve security we have changed
the default value for the "ntlm auth" option from
"yes" to "no". This may have impact on very old
clients which doesn't support NTLMv2 yet.

Ich bin mir eigentlich ziemlich sicher, dass meine Windows 10 VM den
Parameter nicht benötigt.

Viele Grüße
Ulf
Heimo Ponnath (01.04.2020, 18:20)
Hallo Ulf,

sehr interessant, der Link. Dann war es also nicht ein Windows 10
upgrade, sondern eine der häufigen Debian-Upgrades, die ich mache. Denn
bei mir läuft samba 4.5.

Meine Hardware ist schon ein paar Jahre alt, aber die Software darauf
ist ganz aktuell: buster und Windows 10.

Dann sollte ich wohl auf ntlm2 umschalten können - aber "never touch a
running system" - da werde ich mich erstmal möglichst schlau machen.

Liebe Grüße von Heimo

Am Mittwoch, den 01.04.2020, 17:02 +0200 schrieb Ulf Volmer:
[..]
Ulf Volmer (01.04.2020, 18:50)
On 01.04.20 18:19, Heimo Ponnath wrote:

> sehr interessant, der Link. Dann war es also nicht ein Windows 10
> upgrade, sondern eine der häufigen Debian-Upgrades, die ich mache. Denn
> bei mir läuft samba 4.5.


Dann bist Du noch auf oldstable, korrekt? Da solltest Du auch mal dran
arbeiten.

> Meine Hardware ist schon ein paar Jahre alt, aber die Software darauf
> ist ganz aktuell: buster und Windows 10.


Buster sollte eigentlich 4.9.irgendwas haben.

> Dann sollte ich wohl auf ntlm2 umschalten können - aber "never touch a
> running system" - da werde ich mich erstmal möglichst schlau machen.


ntlmv2-only ist Default.

Ich habe hier schlicht gar nicht in der Richtung, meine [global] Sektion
beschränkt sich auf

max protocol = SMB3
workgroup = U-V
server string = %h server
dns proxy = no
bind interfaces only = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = no

Und meinem Windows 10 geht es wunderbar.

Viele Grüße
Ulf
Marc Haber (02.04.2020, 12:50)
On Wed, 01 Apr 2020 18:19:06 +0200, Heimo Ponnath <ponnath>
wrote:
>sehr interessant, der Link. Dann war es also nicht ein Windows 10
>upgrade, sondern eine der häufigen Debian-Upgrades, die ich mache. Denn
>bei mir läuft samba 4.5.


Ja, das ist Stand in Debian seit stretch. Also sollte es nicht erst
"letzte Woche" kaputtgegangen sein.

>Meine Hardware ist schon ein paar Jahre alt, aber die Software darauf
>ist ganz aktuell: buster und Windows 10.


samba in Buster ist 4.9.

Grüße
Marc
Ähnliche Themen