expertenaustausch > linux.debian.user.german

E. Struck (24.09.2005, 17:40)
Hallo NG: Ich bin relativ neu im Geschäft und habe jetzt Debian neue
version als eiziges OS installiert. Das klappte schon sehr gut, nur
startet der rechner immer nur bis zur Konsole, auf der ich mich als root
oder user anmelden kann. Ich habe schon alles mögliche versucht, um auf
den Anmeldebildschrim, also letztlich auf KDE zu kommen. Habe je nach
Ratschlag versucht: "dpkg-reconfigure xserver-xfree86" oder
"/etc/init.d/gdm start". Entweder es passiert gar nichts oder die bash
meldet "Datei oder Verzeichnis nicht gefunden". Was kann ich noch
versuchen, ich würde sehr bei Debian bleiben und nicht z.B. zu SuSe
abwandern. Danke im voraus sagt Egon.
Weinzierl Stefan (24.09.2005, 18:10)
E. Struck schrieb:
> Hallo NG: Ich bin relativ neu im Geschäft und habe jetzt Debian neue
> version als eiziges OS installiert. Das klappte schon sehr gut, nur
> startet der rechner immer nur bis zur Konsole, auf der ich mich als root
> oder user anmelden kann. Ich habe schon alles mögliche versucht, um auf
> den Anmeldebildschrim, also letztlich auf KDE zu kommen. Habe je nach
> Ratschlag versucht: "dpkg-reconfigure xserver-xfree86" oder
> "/etc/init.d/gdm start". Entweder es passiert gar nichts oder die bash
> meldet "Datei oder Verzeichnis nicht gefunden". Was kann ich noch
> versuchen, ich würde sehr bei Debian bleiben und nicht z.B. zu SuSe
> abwandern. Danke im voraus sagt Egon.


Wenn dann /etc/init.d/kdm start
Aber auch nur wenn kde installiert ist (vor allem kdm).

Stefan
Richard Mittendorfer (24.09.2005, 18:10)
Also sprach "E. Struck" <egon.struck> (Sat, 24 Sep 2005
17:18:32 +0200):
> Hallo NG: Ich bin relativ neu im Geschäft und habe jetzt Debian neue


Hallo, wir sind eine ML :)

> version als eiziges OS installiert. Das klappte schon sehr gut, nur


Ich geh' mal von Sarge aus.

> startet der rechner immer nur bis zur Konsole, auf der ich mich als
> root oder user anmelden kann. Ich habe schon alles mögliche versucht,
> um auf


Das ist ja schon mal was. Klappt ein simples "$ startx" - dann fehlt dir
scheinbar ein [xgk]dm.

> den Anmeldebildschrim, also letztlich auf KDE zu kommen. Habe je nach
> Ratschlag versucht: "dpkg-reconfigure xserver-xfree86" oder


Was ergibt das reconfigure? Hast du hier den richtigen Treiber fuer
deine Hardware eingetragen?

> "/etc/init.d/gdm start". Entweder es passiert gar nichts oder die bash
> meldet "Datei oder Verzeichnis nicht gefunden". Was kann ich noch


Vermutlich bist du bei der Installation gefragt worden, welchen dm du
beim Login verwenden willst. Schau mal nach /etc/init.d und versuch den
gdm, kdm, xdm mit "restart". Das "Datei oder Verzeichnis nicht gefunden"
deutet aber darauf hin, dass du den dm nicht installiert hast. Ein
installierter dm sollte, wenn im entsprechenden rcX.d vorhanden nach dem
hochfahren in runlevel 2 gestartet werden.

Ich wuerd' mal sicherstellen, dass du einen [gkx]dm installiert hast:
apt, aptitude, dselect...

"$ apt-cache show gdm"
"$ apt-cache show xfree86-common"

Und versuchen den Xserver (ohne wm) als root und als user zu starten:
"$ X" auf der console.

> versuchen, ich würde sehr bei Debian bleiben und nicht z.B. zu SuSe
> abwandern. Danke im voraus sagt Egon.


sl ritch
Holger Wansing (24.09.2005, 18:50)
Hi,

> Das klappte schon sehr gut, nur
> startet der rechner immer nur bis zur Konsole, auf der ich mich als
> root oder user anmelden kann. Ich habe schon alles mögliche versucht,
> um auf den Anmeldebildschrim, also letztlich auf KDE zu kommen. Habe
> je nach Ratschlag versucht: "dpkg-reconfigure xserver-xfree86" oder
> "/etc/init.d/gdm start". Entweder es passiert gar nichts oder die bash
> meldet "Datei oder Verzeichnis nicht gefunden".


Sind die benötigten Pakete überhaupt installiert? Es ist auch
möglich, Debian zu installieren, ohne X. Ich würde sagen, sie fehlen.

Also: x-window-system-core
kdebase (wenn du KDE willst; es gibt auch noch viele andere
Möglichkeiten)
kdm

wäre schon mal ein guter Ansatz, denke ich (möge mich jemand
korrigieren, falls ich was wichtiges vergaß)

Ein "dpkg -l <programmname> als root zeigt dir, ob es installiert
(fängt die Zeile mit ""ii"" an, ist es installiert).
Fehlt was, mit "apt-get install <programmname>" als root installieren.

Bei Fragen fragen.

Holger
E. Struck (25.09.2005, 11:20)
Hallo ML:

danke für die bisherigen Tips. Es war in der tat einiges nicht
installiert. Dies habe ich mit apt-get nachgeholt. Dennoch komme ich nur
bis zur Meldung, das kdm gestartet ist. Alle weiteren Versuche wie
startx oder start x11 scheitern. Auch wenn ich Synaptic öffnen will,
kommt die Meldung: "Can't open display." Ich fummele einstweilen weiter
und melde mich wieder, wenn konkrete Fragen anstehen. Egon
Werner Zacherl (25.09.2005, 13:30)
Am Sonntag, 25. September 2005 10:57 schrieb E. Struck:
> Hallo ML:
> danke für die bisherigen Tips. Es war in der tat einiges nicht
> installiert. Dies habe ich mit apt-get nachgeholt. Dennoch komme ich
> nur bis zur Meldung, das kdm gestartet ist. Alle weiteren Versuche
> wie startx oder start x11 scheitern. Auch wenn ich Synaptic öffnen
> will, kommt die Meldung: "Can't open display." Ich fummele
> einstweilen weiter und melde mich wieder, wenn konkrete Fragen
> anstehen. Egon ich habs nach folgendem Schema gemacht, dann hat alles funktioniert.


apt-get install localeconf language-env fonty manpages_de doc-linux-de

Während der Installation konfiguriert man localeconf und locales und
fonty.

Jetzt startet man als root set-language-env -E. Anschließend wechselt
man auf den Standardbenutzer (bei der Installation von Debian erstellt)
und gibt dort set-language-env ein. Bei zukünftig erstellten Usern ist
das nicht mehr nötig, daher sollte man mögliche User erst nach den
Spracheinstellungen erstellen.

Anschließend überprüft man ob die /etc/environment so aussieht:
LANGUAGE=de_DE@euro
LC_ALL=de_DE@euro
LANG=de_DE@euro

Jetzt schreibt man in die .bashrc des Standardbenutzers (nicht root)
folgendes zu dem bereits bestehenden Eintrag LANG=de_DE@euro. Wenn man
die Datei /etc/skel/.bashrc bearbeitet, muss man diesen Schritt bei
allen zukünftigen Usern nicht mehr machen.

source /etc/environment
export LANG LANGUAGE LC_ALL

3.5) Installation vom X-Server

Benötigte Programme downloaden.

apt-get install xserver-xfree86 xfonts-100dpi-transcoded
xfonts-75dpi-transcoded xfonts-base-transcoded xfonts-base
msttcorefonts xbase-clients xutils x-ttcidfont-conf

Hoffe das hilft auch Dir

cu
werner
Wolf Wiegand (25.09.2005, 15:00)
Hallo!

On Sun, Sep 25, 2005 at 10:57:55AM +0200, E. Struck wrote:

> Dennoch komme ich
> nur bis zur Meldung, das kdm gestartet ist.


Ich schätze mal, dass kdm zwar startet, aber sich wieder beendet, da es
Probleme mit dem X-Server gibt.

> Alle weiteren Versuche wie
> startx oder start x11 scheitern.


Schau mal in /var/log/XFree86.0.log, ob Du da was auffälliges findest
und poste ggf. die Zeilen, die mit (EE) anfangen, hier.

Viel Erfolg,

Wolf
Holger Wansing (25.09.2005, 19:10)
Hi,

> Dennoch komme ich
> nur bis zur Meldung, das kdm gestartet ist. Alle weiteren Versuche
> wie startx oder start x11 scheitern. Auch wenn ich Synaptic öffnen


Wenn im Rahmen des Boot-Vorgangs der kdm gestartet wird, brauchst du
kein startx mehr, da der Xserver schon läuft (wird durch kdm start
erledigt). Du kommst auf ein grafisches Bild, in dem du dich anmelden
kannst.
Wenn du trotzdem wieder auf der Konsole landest, ist was
mit der Konfiguration des Xservers faul, aber dazu wurde ja bereits
was gesagt.

Holger
Gebhard Dettmar (26.09.2005, 12:00)
On Sunday 25 September 2005 13:26, Werner Zacherl wrote:
> Am Sonntag, 25. September 2005 10:57 schrieb E. Struck:
> > [...]

> Anschließend überprüft man ob die /etc/environment so aussieht:
> LANGUAGE=de_DE@euro
> LC_ALL=de_DE@euro
> LANG=de_DE@euro

Na ja. Wenn er ein deutsches System will. Real Niggaz
benutzen LANG=C ;-)
> [...]
> 3.5) Installation vom X-Server
> Benötigte Programme downloaden.
> apt-get install xserver-xfree86 xfonts-100dpi-transcoded
> xfonts-75dpi-transcoded xfonts-base-transcoded xfonts-base
> msttcorefonts xbase-clients xutils x-ttcidfont-conf

Vielleicht nützt auch gpm zur Mauskonfiguration noch. Jedenfalls müssten,
wenn du (OP) schon soweit bist, die Fehlermeldungen von startx schon
einigermaßen aussagekräftig sein. Wenn du z.B. Vesa für deine GraKa
gewählt hast, ist oft eine zu hohe Auflösung Schuld an der Meldung:
Screens found but none of them have a useable configuration o.s.ä.
Ähnliche Themen