expertenaustausch > linux.debian.user.german

Hartmut Niemann (09.02.2020, 08:10)
Hallo!

Ich habe auf einem PC erst Debian 10, dann Windows 10 installiert, das
(natürlich) Debian beim Booten verdrängt hat.

Windows 10 *müsste* die Debianpartitionen eigentlich in Ruhe gelassenhaben.

Was ist der beste Weg, um zu einem Bootmenü zu kommen, um beim
Einschalten die Wahl zu haben?

Viele Grüße

Hartmut
Stefan Klein (09.02.2020, 08:30)
Morsche,

Am So., 9. Feb. 2020 um 07:00 Uhr schrieb Hartmut Niemann
<Hartmut.Niemann>:
> Hallo!
> Ich habe auf einem PC erst Debian 10, dann Windows 10 installiert, das
> (natürlich) Debian beim Booten verdrängt hat.
> Windows 10 *müsste* die Debianpartitionen eigentlich in Ruhe gelassen haben.
> Was ist der beste Weg, um zu einem Bootmenü zu kommen, um beim
> Einschalten die Wahl zu haben?


Wenn es sich um ein EFI System handelt sollte das "Bios" Debian noch
kennen und booten können.
Welche Taste beim booten zu drücken ist und wie du Debian wieder zum
Default machen kannst hängt vom Mainboard ab.

'update-grub' sollte die grub config so anpassen das auch Windows im
grub Menü erscheint. Imho ist das die bequemste Variante des
Dual-Boot.

Grüße,
Stefan
Anton Blau (09.02.2020, 16:20)
Am 09.02.2020 um 07:00 schrieb Hartmut Niemann:
> Was ist der beste Weg, um zu einem Bootmenü zu kommen, um beim
> Einschalten die Wahl zu haben?


Hier findest Du eine Beschreibung:



oder



Ansonsten verwende eine Suchmaschine Deiner Wahl mit dem Suchbegriff
"Dualboot".

VG

Tony
Hartmut Niemann (09.02.2020, 21:00)
On 09.02.20 07:23, Stefan Klein wrote:
[..]
> Dual-Boot.
> Grüße,
> Stefan Hallo Stefan!


Danke für die Tips.

Es wurde dann doch noch etwas komplizierter. Ich habe anscheinend das
"alte" Partitionierungsschema, kein EFI, oder mein ASRock-Mobo kann
sowas nicht. Egal.

Ich habe

* das System von der Debian-Netinstall-CD in den "Rescue mode" gebootet

(erste Schleife: nur die Root-Partion auf "active" gesetzt -> "Missing
Operating System" -> nochmal von der CD gebootet)

* grub auf der Platte /dev/nvme0n1 (also nicht auf der Root-Partition
/dev/nvme0n1p1 , das ging irgendwie nicht) neu installiert

Dann konnte ich Linux wieder starten (aber nicht Windows auswählen)

Dann im Linux deinen Tip von oben probiert:

* update-grub

und dann wurde auch Windows gefunden und ich kann jetzt beim Booten in
Grub auswählen.

Viele Grüße

Hartmut
Ähnliche Themen