expertenaustausch > comp.os.* > comp.os.unix.networking.misc

Michael Schütz (14.05.2020, 19:02)
Hallo Gruppe,

ich habe hier ein Problem mit meinem Netzwerk und weiß nicht so recht,
woran das liegen kann. Ich bitte also um Hinweise.

In meinem Netz läuft ein kleiner armbasierter Rechner als
Netzwerkserver. Dieser hat zwei Netzwerkinterfaces und trennt mein Netz
vom Kabelrouter (KDG).
Aus einem anderen Grund habe ich diesen heute einmal neu gestartet.

Seit dem Neustart kann ich von keinem Rechner aus dem Netzwerk nach
draußen. Kein Ping, keine Website, komme nichtmal bis zum Kabelrouter.
Daher vermute ich, dass mit dem Routing etwas nicht stimmt, finde aber
keinen Fehler.

ip r gibt folgendes aus:

default via 192.168.41.1 dev eth1 proto dhcp src 192.168.41.2 metric 203
169.254.0.0/16 dev eth0 scope link src 169.254.55.250 metric 202
192.168.41.0/24 dev eth1 proto dhcp scope link src 192.168.41.2 metric 203
192.168.42.0/24 dev eth0 proto kernel scope link src 192.168.42.3

Die *.*.41.1 ist der Kabelrouter, mein internes Netz hängt an eth0
*.*.42.0/24
IP-Forwarding ist aktiviert

Hat jemand eine Idee?

Danke,
Schultze
Sven Hartge (14.05.2020, 19:09)
Michael Schütz <der.schultze> wrote:

> Seit dem Neustart kann ich von keinem Rechner aus dem Netzwerk nach
> draußen. Kein Ping, keine Website, komme nichtmal bis zum Kabelrouter.
> Daher vermute ich, dass mit dem Routing etwas nicht stimmt, finde aber
> keinen Fehler.


> ip r gibt folgendes aus:


> default via 192.168.41.1 dev eth1 proto dhcp src 192.168.41.2 metric 203
> 169.254.0.0/16 dev eth0 scope link src 169.254.55.250 metric 202
> 192.168.41.0/24 dev eth1 proto dhcp scope link src 192.168.41.2 metric 203
> 192.168.42.0/24 dev eth0 proto kernel scope link src 192.168.42.3


> Die *.*.41.1 ist der Kabelrouter, mein internes Netz hängt an eth0
> *.*.42.0/24
> IP-Forwarding ist aktiviert


> Hat jemand eine Idee?


Sind die nötigen NAT-Regeln noch da?

S!
Michael Schütz (14.05.2020, 19:11)
Michael Schütz <der.schultze> schrieb:
> In meinem Netz läuft ein kleiner armbasierter Rechner als
> Netzwerkserver. Dieser hat zwei Netzwerkinterfaces und trennt mein Netz
> vom Kabelrouter (KDG).

Ergänzung:
Von dem Router/Server aus komme ich problemlos ins Internet.
Kay Martinen (14.05.2020, 19:31)
Am 14.05.20 um 19:02 schrieb Michael Schütz:
> Hallo Gruppe,
> ich habe hier ein Problem mit meinem Netzwerk und weiß nicht so recht,
> woran das liegen kann. Ich bitte also um Hinweise.
> In meinem Netz läuft ein kleiner armbasierter Rechner als
> Netzwerkserver. Dieser hat zwei Netzwerkinterfaces und trennt mein Netz
> vom Kabelrouter (KDG).
> Aus einem anderen Grund habe ich diesen heute einmal neu gestartet.


Nur mal so, was war das für ein "anderer Grund"? Vielleicht der Auslöser
auch wenn du es nicht glaubst.

> Seit dem Neustart kann ich von keinem Rechner aus dem Netzwerk nach
> draußen. Kein Ping, keine Website, komme nichtmal bis zum Kabelrouter.
> Daher vermute ich, dass mit dem Routing etwas nicht stimmt, finde aber
> keinen Fehler.
> ip r gibt folgendes aus:
> default via 192.168.41.1 dev eth1 proto dhcp src 192.168.41.2 metric 203
> 169.254.0.0/16 dev eth0 scope link src 169.254.55.250 metric 202
> 192.168.41.0/24 dev eth1 proto dhcp scope link src 192.168.41.2 metric 203
> 192.168.42.0/24 dev eth0 proto kernel scope link src 192.168.42.3


Mir fällt da nur auf das du da komische Metriken hast. Die niedrigere
hat da doch vorrang meine ich. Und dein Internes LAN hat keine. Hast du
mal trafficcounter befragt ob das evtl. alles über 169.254.0.0 gehen
soll und evtl. im orkus landet?

> Die *.*.41.1 ist der Kabelrouter, mein internes Netz hängt an eth0
> *.*.42.0/24
> IP-Forwarding ist aktiviert


Für IPv4 UND IPv6?

> Hat jemand eine Idee?


S.O. NAT-regeln; und deren Abfolge (deny all vor accept irgenwas)
kontrollieren wurde schon geraten. Auch die Forward-regeln?

Ist das ein piHole oder etwas mit einer webUI zur konfiguration?
Vielleicht kannst du da ein Konfig-Backup zurück spielen.

Wenn das ein rpi o.a. mit start von einer SD ist: Hat die Defekte?

Kay
Sven Hartge (14.05.2020, 19:32)
Michael Schütz <der.schultze> wrote:
> Michael Schütz <der.schultze> schrieb:


>> In meinem Netz läuft ein kleiner armbasierter Rechner als
>> Netzwerkserver. Dieser hat zwei Netzwerkinterfaces und trennt mein
>> Netz vom Kabelrouter (KDG).


> Ergänzung: Von dem Router/Server aus komme ich problemlos ins
> Internet.


Das deutet darauf hin, dass die NAT-Regeln weg oder falsch sind.

S!
Michael Schütz (14.05.2020, 19:37)
Sven Hartge <sh-205> schrieb:
> Sind die nötigen NAT-Regeln noch da?
> S!


Danke für den Wink mit dem Zeupfahl.
Schultze
Michael Schütz (14.05.2020, 19:40)
Kay Martinen <kay> schrieb:
[..]
Andreas Kohlbach (14.05.2020, 20:00)
On Thu, 14 May 2020 19:37:24 +0200, Michael Schütz wrote:
> Danke für den Wink mit dem Zeupfahl.


Zaunpfahl?
Kay Martinen (14.05.2020, 20:07)
Am 14.05.20 um 19:40 schrieb Michael Schütz:
> Kay Martinen <kay> schrieb:
>> S.O. NAT-regeln; und deren Abfolge (deny all vor accept irgenwas)
>> kontrollieren wurde schon geraten. Auch die Forward-regeln?

> Es fehlten die NAT-Regeln.


Und forward-default war Deny? Denn sonst hätte es ja klappen müssen.

Kay
Kay Martinen (14.05.2020, 20:08)
Am 14.05.20 um 20:00 schrieb Andreas Kohlbach:
> On Thu, 14 May 2020 19:37:24 +0200, Michael Schütz wrote:
>> Danke für den Wink mit dem Zeupfahl.

> Zaunpfahl?


Vielleicht hängt man bei ihm sein Zeug über einen Pfahl = Zeugpfahl
verteppfuhlert.

Kay
Ralph Aichinger (14.05.2020, 20:10)
Michael Schütz <der.schultze> wrote:
> default via 192.168.41.1 dev eth1 proto dhcp src 192.168.41.2 metric 203


Da steht dhcp. Hat eth1 die richtige IP?
Kann dein Kabelmodem diese 192.168.41.2 pingen?

> 169.254.0.0/16 dev eth0 scope link src 169.254.55.250 metric 202
> 192.168.41.0/24 dev eth1 proto dhcp scope link src 192.168.41.2 metric 203
> 192.168.42.0/24 dev eth0 proto kernel scope link src 192.168.42.3
> Die *.*.41.1 ist der Kabelrouter, mein internes Netz hängt an eth0


Oben steht was anderes, da steht eth1.

> *.*.42.0/24
> IP-Forwarding ist aktiviert
> Hat jemand eine Idee?


Kontrollier mal ob die Interfaces den Namen getauscht haben.

/ralph
Ralph Aichinger (14.05.2020, 20:11)
Ralph Aichinger <ra> wrote:

> Oben steht was anderes, da steht eth1.


Sorry schlsmpig gelesen. Stimmt eh,

/ralph
Sven Hartge (14.05.2020, 20:18)
Kay Martinen <kay> wrote:
> Am 14.05.20 um 19:40 schrieb Michael Schütz:
>> Kay Martinen <kay> schrieb:
>>> S.O. NAT-regeln; und deren Abfolge (deny all vor accept irgenwas)
>>> kontrollieren wurde schon geraten. Auch die Forward-regeln?

>> Es fehlten die NAT-Regeln.


> Und forward-default war Deny? Denn sonst hätte es ja klappen müssen.


Nö, weil dann immer noch die Netzroute auf 192.168.41.1 für
192.168.42.0/24 hinter 192.168.42.2 fehlt.

S!
Kay Martinen (14.05.2020, 22:04)
Am 14.05.20 um 20:18 schrieb Sven Hartge:
> Kay Martinen <kay> wrote:
> Nö, weil dann immer noch die Netzroute auf 192.168.41.1 für
> 192.168.42.0/24 hinter 192.168.42.2 fehlt.


Der Host ist doch direkt verbunden und dual-homed und hat eine
Defaultroute auf den Kabelrouter. Wo siehst du da noch eine netzroute
nötig? Wenn forwarding aktiv und forward-default allow ist sollten
pakete einfach durch gehen. Nur wenn der forward-default auf deny stünde
nicht.

Oder Mistverstehen wir uns hier?

Kay
Ralph Aichinger (14.05.2020, 22:09)
Kay Martinen <kay> wrote:
> Der Host ist doch direkt verbunden und dual-homed und hat eine
> Defaultroute auf den Kabelrouter. Wo siehst du da noch eine netzroute
> nötig? Wenn forwarding aktiv und forward-default allow ist sollten
> pakete einfach durch gehen. Nur wenn der forward-default auf deny stünde
> nicht.


In die Gegenrichtung: Die Kabelbox braucht die Netzroute.

/ralph

Ähnliche Themen