expertenaustausch > comp.* > comp.text.tex

Andreas Barth (15.04.2019, 00:55)
Hallo zusammen,

bei mir führt "' zu einem Ersatz der Umlaute mit einer anderen Schrift
(mit xelatex), Minimalbeispiel

\documentclass{scrartcl}
\usepackage{german}
\usepackage{fontspec}
\setmainfont{FreeSans}
\begin{document}

?

"'

\end{document}
mit der Warnung
LaTeX Font Warning: Font shape `OT1/FreeSans(0)/m/n' undefined
(Font) using `OT1/cmr/m/n' instead
(Font) for symbol `grqq' on input line 9.

Wenn ich hingegen ? verwende, dann passt es.

Noch interessanter: Wenn ich das ersetzte Zeichen in die Datei
reinkopiere, dann ergibt dies ein ? und funktioniert im nächsten
Durchlauf.

Mache ich da etwas falsch, oder ist das einfach so (und ich sollte ?
direkt verwenden)?

Viele Grüße,
Andi
Ulrike Fischer (15.04.2019, 09:13)
Am Sun, 14 Apr 2019 22:55:15 +0000 (UTC) schrieb Andreas Barth:

> Hallo zusammen,
> bei mir führt "' zu einem Ersatz der Umlaute mit einer anderen Schrift
> (mit xelatex), Minimalbeispiel
> \documentclass{scrartcl}
> \usepackage{german}


Verwende nicht das Paket german. Das ist von 1998 und aus vielen
Gründen nicht empfehlenswert, für xelatex schon gar nicht.

Benutze

\usepackage[german]{babel} oder \usepackage[ngerman]{babel}
Andreas Barth (15.04.2019, 10:18)
Ulrike Fischer wrote:
> Am Sun, 14 Apr 2019 22:55:15 +0000 (UTC) schrieb Andreas Barth:
> Verwende nicht das Paket german. Das ist von 1998 und aus vielen
> Gründen nicht empfehlenswert, für xelatex schon gar nicht.
> Benutze
> \usepackage[german]{babel} oder \usepackage[ngerman]{babel}


Gerne, aber führt auch zu keinem anderen Verhalten.

Viele Grüße,
Andi
Ulrike Fischer (15.04.2019, 10:33)
Am Mon, 15 Apr 2019 08:18:39 +0000 (UTC) schrieb Andreas Barth:

>> Benutze
>> \usepackage[german]{babel} oder \usepackage[ngerman]{babel}

> Gerne, aber führt auch zu keinem anderen Verhalten.


Nicht in einem aktuellen TeX-System.
Ähnliche Themen