expertenaustausch > linux.debian.user.german

Klaus Wacker (22.09.2005, 14:30)
Liebe Zielgruppe,

ich habe ein Problem mit vboxgetty: Es findet sein Device File nicht.
Ich starte es mit
I6:2345:respawn:/usr/sbin/vboxgetty -d /dev/ttyI6
in inittab. Tatsächlich existiert /dev/ttyI6 nicht. Wenn ich ttyI6 per
Hand erzeuge (mit mknod, chmod, chown), geht es bis zum nächsten
Neustart. In /dev `MAKEDEV isdn-tty' aufzurufen scheint dagegen nichts
zu bewirken.

Nach einigem Suchen ergibt sich ein etwas verwirrendes Bild. df /dev
sagt:

Filesystem 1K-blocks Used Available Use% Mounted on
tmpfs 10240 776 9464 8% /dev

/dev liegt also in einer Ramdisk - kein Wunder, dass Änderungen beim
Neustart verschwinden. Es gibt dann noch /dev/.static/dev, da gibt es
die ttyI* alle und es liegt auch im Rootfilesystem. In /dev/MAKEDEV
gibt es eine mir nicht verständliche Logik, die dafür sorgt, dass bei
mir die ttyI* in /dev/.static/dev angelegt werden.

Es scheint eine Verbindung mit Bug 297539 zu geben
(). Da ist
allerdings nicht von /dev/.static/dev, sondern nur von /.dev/ die
Rede, was es bei mir nicht gibt.

Kann mir jemand erklären, was der Hintergrund dieser Verwirrung ist
und was ich jetzt machen soll? Workarounds kann ich mir selbst
ausdenken. Ich möchte gern verstehen, was da passiert. Der
Zusammenhang mit udev ist mir auch ziemlich unklar.

Mein System ist ein neu installiertes Debian 3.1 mit aktuellen
Updates. Die isdnutils-Version ist 3.6.2005-01-03-5.
Christoph Fritz (22.09.2005, 19:10)
On Thursday 22 September 2005 11:53, Klaus Wacker wrote:

> /dev liegt also in einer Ramdisk - kein Wunder, dass Änderungen beim
> Neustart verschwinden.


Du hast 'udev' am Laufen

> Kann mir jemand erklären, was der Hintergrund dieser Verwirrung ist
> und was ich jetzt machen soll?


man udev
/etc/udev konfigurieren

> Workarounds kann ich mir selbst
> ausdenken. Ich möchte gern verstehen, was da passiert. Der
> Zusammenhang mit udev ist mir auch ziemlich unklar.


Wieso?