expertenaustausch > linux.debian.user.german

Klaus Becker (21.09.2005, 20:30)
nAbend,

unter Sarge ist mir folgendes passiert:

--------------------------------------
apt-get upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages have been kept back:
kdebase kdebase-kio-plugins realplayer
The following packages will be upgraded:
libice6 libsm6 libx11-6 libxaw7 libxext6 libxft1 libxi6 libxmu6 libxmuu1
libxp6 libxrandr2 libxt6
libxtrap6 libxtst6 xlibmesa-gl
15 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 3700kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue? [Y/n]
koeln:~# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages have been kept back:
kdebase kdebase-kio-plugins realplayer
The following packages will be upgraded:
libice6 libsm6 libx11-6 libxaw7 libxext6 libxft1 libxi6 libxmu6 libxmuu1
libxp6 libxrandr2 libxt6
libxtrap6 libxtst6 xlibmesa-gl
15 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 3700kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 stable/updates/main libice6
4.3.0.dfsg.1-14sarge1 [203kB]
Get:2 stable/updates/main libsm6
4.3.0.dfsg.1-14sarge1 [181kB]
Get:3 stable/updates/main libx11-6
4.3.0.dfsg.1-14sarge1 [725kB]
Get:4 stable/updates/main libxext6
4.3.0.dfsg.1-14sarge1 [188kB]
Get:5 stable/updates/main libxt6
4.3.0.dfsg.1-14sarge1 [329kB]
Get:6 stable/updates/main libxmu6
4.3.0.dfsg.1-14sarge1 [209kB]
Get:7 stable/updates/main libxaw7
4.3.0.dfsg.1-14sarge1 [338kB]
Get:8 stable/updates/main libxft1
4.3.0.dfsg.1-14sarge1 [190kB]
Get:9 stable/updates/main libxi6
4.3.0.dfsg.1-14sarge1 [179kB]
Get:10 stable/updates/main libxmuu1
4.3.0.dfsg.1-14sarge1 [171kB]
Get:11 stable/updates/main libxp6
4.3.0.dfsg.1-14sarge1 [178kB]
Get:12 stable/updates/main libxrandr2
4.3.0.dfsg.1-14sarge1 [171kB]
Get:13 stable/updates/main libxtrap6
4.3.0.dfsg.1-14sarge1 [180kB]
Get:14 stable/updates/main libxtst6
4.3.0.dfsg.1-14sarge1 [174kB]
Get:15 stable/updates/main xlibmesa-gl
4.3.0.dfsg.1-14sarge1 [283kB]
Fetched 3700kB in 2m46s (22.3kB/s)
Reading package fields... Done
Reading package status... Done
Retrieving bug reports... Done
Preconfiguring packages ...
(Reading database ... 136847 files and directories currently installed.)
Preparing to replace libice6 4.3.0.dfsg.1-14
(using .../libice6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libice6 ...
dpkg: error
processing /var/cache/apt/archives/libice6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libICE.so.6', which is also in package
libxorg-x11
Preparing to replace libsm6 4.3.0.dfsg.1-14
(using .../libsm6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libsm6 ...
dpkg: error
processing /var/cache/apt/archives/libsm6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libSM.so.6.0', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libx11-6 4.3.0.dfsg.1-14
(using .../libx11-6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libx11-6 ...
dpkg: error
processing /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2', which
is also in package libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxext6 4.3.0.dfsg.1-14
(using .../libxext6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxext6 ...
dpkg: error
processing /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXext.so.6.4', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxt6 4.3.0.dfsg.1-14
(using .../libxt6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxt6 ...
dpkg: error
processing /var/cache/apt/archives/libxt6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXt.so.6.0', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxmu6 4.3.0.dfsg.1-14
(using .../libxmu6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxmu6 ...
dpkg: error
processing /var/cache/apt/archives/libxmu6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXmu.so.6.2', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxaw7 4.3.0.dfsg.1-14
(using .../libxaw7_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxaw7 ...
dpkg: error
processing /var/cache/apt/archives/libxaw7_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXaw.so.7.0', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxft1 4.3.0.dfsg.1-14
(using .../libxft1_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxft1 ...
dpkg: error
processing /var/cache/apt/archives/libxft1_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXft.so.1.1', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxi6 4.3.0.dfsg.1-14
(using .../libxi6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxi6 ...
dpkg: error
processing /var/cache/apt/archives/libxi6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXi.so.6.0', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxmuu1 4.3.0.dfsg.1-14
(using .../libxmuu1_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxmuu1 ...
dpkg: error
processing /var/cache/apt/archives/libxmuu1_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXmuu.so.1.0', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxp6 4.3.0.dfsg.1-14
(using .../libxp6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxp6 ...
dpkg: error
processing /var/cache/apt/archives/libxp6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXp.so.6.2', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxrandr2 4.3.0.dfsg.1-14
(using .../libxrandr2_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxrandr2 ...
dpkg: error
processing /var/cache/apt/archives/libxrandr2_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXrandr.so.2.0', which is also in
package libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxtrap6 4.3.0.dfsg.1-14
(using .../libxtrap6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxtrap6 ...
dpkg: error
processing /var/cache/apt/archives/libxtrap6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXTrap.so.6.4', which is also in
package libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxtst6 4.3.0.dfsg.1-14
(using .../libxtst6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxtst6 ...
dpkg: error
processing /var/cache/apt/archives/libxtst6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXtst.so.6.1', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace xlibmesa-gl 4.3.0.dfsg.1-14
(using .../xlibmesa-gl_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement xlibmesa-gl ...
dpkg: error
processing /var/cache/apt/archives/xlibmesa-gl_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libGL.so.1.2', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libice6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libsm6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxext6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxt6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxmu6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxaw7_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxft1_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxi6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxmuu1_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxp6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxrandr2_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxtrap6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxtst6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/xlibmesa-gl_4.3.0.dfsg.1-14sarge1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
koeln:~# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages have been kept back:
kdebase kdebase-kio-plugins realplayer
The following packages will be upgraded:
libice6 libsm6 libx11-6 libxaw7 libxext6 libxft1 libxi6 libxmu6 libxmuu1
libxp6 libxrandr2 libxt6
libxtrap6 libxtst6 xlibmesa-gl
15 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 0B/3700kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue? [Y/n]
Reading package fields... Done
Reading package status... Done
Retrieving bug reports... Done
Preconfiguring packages ...
(Reading database ... 136847 files and directories currently installed.)
Preparing to replace libice6 4.3.0.dfsg.1-14
(using .../libice6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libice6 ...
dpkg: error
processing /var/cache/apt/archives/libice6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libICE.so.6', which is also in package
libxorg-x11
Preparing to replace libsm6 4.3.0.dfsg.1-14
(using .../libsm6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libsm6 ...
dpkg: error
processing /var/cache/apt/archives/libsm6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libSM.so.6.0', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libx11-6 4.3.0.dfsg.1-14
(using .../libx11-6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libx11-6 ...
dpkg: error
processing /var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2', which
is also in package libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxext6 4.3.0.dfsg.1-14
(using .../libxext6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxext6 ...
dpkg: error
processing /var/cache/apt/archives/libxext6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXext.so.6.4', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxt6 4.3.0.dfsg.1-14
(using .../libxt6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxt6 ...
dpkg: error
processing /var/cache/apt/archives/libxt6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXt.so.6.0', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxmu6 4.3.0.dfsg.1-14
(using .../libxmu6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxmu6 ...
dpkg: error
processing /var/cache/apt/archives/libxmu6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXmu.so.6.2', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxaw7 4.3.0.dfsg.1-14
(using .../libxaw7_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxaw7 ...
dpkg: error
processing /var/cache/apt/archives/libxaw7_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXaw.so.7.0', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxft1 4.3.0.dfsg.1-14
(using .../libxft1_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxft1 ...
dpkg: error
processing /var/cache/apt/archives/libxft1_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXft.so.1.1', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxi6 4.3.0.dfsg.1-14
(using .../libxi6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxi6 ...
dpkg: error
processing /var/cache/apt/archives/libxi6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXi.so.6.0', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxmuu1 4.3.0.dfsg.1-14
(using .../libxmuu1_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxmuu1 ...
dpkg: error
processing /var/cache/apt/archives/libxmuu1_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXmuu.so.1.0', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxp6 4.3.0.dfsg.1-14
(using .../libxp6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxp6 ...
dpkg: error
processing /var/cache/apt/archives/libxp6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXp.so.6.2', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxrandr2 4.3.0.dfsg.1-14
(using .../libxrandr2_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxrandr2 ...
dpkg: error
processing /var/cache/apt/archives/libxrandr2_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXrandr.so.2.0', which is also in
package libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxtrap6 4.3.0.dfsg.1-14
(using .../libxtrap6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxtrap6 ...
dpkg: error
processing /var/cache/apt/archives/libxtrap6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXTrap.so.6.4', which is also in
package libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libxtst6 4.3.0.dfsg.1-14
(using .../libxtst6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement libxtst6 ...
dpkg: error
processing /var/cache/apt/archives/libxtst6_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libXtst.so.6.1', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace xlibmesa-gl 4.3.0.dfsg.1-14
(using .../xlibmesa-gl_4.3.0.dfsg.1-14sarge1_i386.deb) ...
Unpacking replacement xlibmesa-gl ...
dpkg: error
processing /var/cache/apt/archives/xlibmesa-gl_4.3.0.dfsg.1-14sarge1_i386.deb
(--unpack):
trying to overwrite `/usr/X11R6/lib/libGL.so.1.2', which is also in package
libxorg-x11
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libice6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libsm6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libx11-6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxext6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxt6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxmu6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxaw7_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxft1_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxi6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxmuu1_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxp6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxrandr2_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxtrap6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/libxtst6_4.3.0.dfsg.1-14sarge1_i386.deb
/var/cache/apt/archives/xlibmesa-gl_4.3.0.dfsg.1-14sarge1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
--------------------------------------

Nun kann ich die Option "--force overwrite" benutzen, was in einzelnen Fällen
schon mal gemacht habe, ohne nachfolgende Probleme. Aber so massiv ist mir
das noch nie passiert.

Das Ganze ging los, als ich versuchte, Opera zu installieren. Ich habe
verschiedene Versionen von der Website runtergeholt und versucht, mit dpkg zu
installieren, wobei ich jedesmal Fehlermeldungen bekam.

apt-get -f install behebt das Problem nicht. Mir wird ein Update etlicher
Pakete vorgeschlagen und wenn ich es akzeptiere, tauchen die gleichen
Fehlermeldungen wieder auf.

Zuerst dachte ich, ich habe Mist gebaut, aber inzwischen frage ich mich, obda
nicht etwas anderes dahinter steckt, das nicht an mir liegt.

Folgendes ist auch keine akzeptable Lösung:

apt-get remove libxorg-x11
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
adobereader-enu libxorg-x11 openoffice.org-core02 openoffice.org-core04
openoffice.org-core04u openoffice.org-core05 openoffice.org-pyuno
openoffice.org-testtool vmwareworkstation

Ich habe zwar ein Backup meines Systems mit partimage und kann es damit wieder
herstellen, aber es gibt sicher eine einfachere Lösung.

Gruss
Klaus
Frank Dietrich (21.09.2005, 21:10)
Hallo Klaus,

Klaus Becker <colonius> wrote:
> unter Sarge ist mir folgendes passiert:
> --------------------------------------
> installed.) Preparing to replace libice6 4.3.0.dfsg.1-14
> (using .../libice6_4.3.0.dfsg.1-14sarge1_i386.deb) ...
> Unpacking replacement libice6 ...
> dpkg: error
> processing /var/cache/apt/archives/
> libice6_4.3.0.dfsg.1-14sarge1_i386.deb (--unpack):
> trying to overwrite `/usr/X11R6/lib/libICE.so.6', which is also in
> package libxorg-x11


Wo kommt denn Paket libxorg-x11 her? Im Debian Sarge Zweig ist es
zumindest nicht.

Gruß
Frank
Klaus Becker (21.09.2005, 21:20)
Le Mercredi 21 Septembre 2005 21:05, Frank Dietrich a écrit :
> Hallo Klaus,
> Klaus Becker <colonius> wrote:
> Wo kommt denn Paket libxorg-x11 her? Im Debian Sarge Zweig ist es
> zumindest nicht.


Hallo Frank,

das weiss ich nicht mehr, wahrscheinlich durch die Installierung von vmware,
OpenOffice oder oder Acroread. da sind jedenfalls die Pakete, die
desinstalliert werden, wenn ich libxorg-x11 lösche.

Klaus
Frank Dietrich (21.09.2005, 21:30)
Hallo Klaus,

Klaus Becker <colonius> wrote:
> Le Mercredi 21 Septembre 2005 21:05, Frank Dietrich a écrit :
> das weiss ich nicht mehr, wahrscheinlich durch die Installierung
> von vmware, OpenOffice oder oder Acroread. da sind jedenfalls die
> Pakete, die desinstalliert werden, wenn ich libxorg-x11 lösche.


Vermutlich weil sie von eine Lib abhängen die in dem Paket steckt. Du
könntest aber folgendes tun, ohne die 3 Pakte zu deinstallieren.

apt-get install libxorg-x11- libice6

Wichtig ist das "-" hinter libxorg-x11, damit tauscht apt-get in
diesem Fall das Paket libxorg-x11 gegen libice6. Dann sollten sich
auch die anderen Pakete installieren lassen.

Frank
Hans-Georg Bork (21.09.2005, 21:40)
Moin,

eine Beschreibung des Fehlers waere sicherlich kuerzer gewesen als die
Ausgabe von dreimal apt-get (dist-)upgrade ... wieso machst Du eigentlich
dist-upgrade? Willst Du tatsaechlich ein Upgrade von Sarge zu Sarge?

On Wed, Sep 21, 2005 at 08:19:53PM +0200, Klaus Becker wrote:
> [...]
> Nun kann ich die Option "--force overwrite" benutzen, was in einzelnen Fällen
> schon mal gemacht habe, ohne nachfolgende Probleme. Aber so massiv ist mir
> das noch nie passiert.


kann es sein, dass Du libxorg-x11 mittels --force-overwrite oder anderen
"forces" installiert hast? Welche Version ist das eigentlich?

> [...]
> apt-get remove libxorg-x11
> Reading Package Lists... Done
> Building Dependency Tree... Done
> The following packages will be REMOVED:
> adobereader-enu libxorg-x11 openoffice.org-core02 openoffice.org-core04
> openoffice.org-core04u openoffice.org-core05 openoffice.org-pyuno
> openoffice.org-testtool vmwareworkstation


Evtl. hilft ein (temporaeres) dpkg -r libxorg-x11 ...

> Ich habe zwar ein Backup meines Systems mit partimage und kann es damit wieder
> herstellen, aber es gibt sicher eine einfachere Lösung.


.... nur bist Du danach auf demselben Stand wie jetzt (oder aelter)

Gruss
-- hgb
Klaus Becker (21.09.2005, 21:40)
Le Mercredi 21 Septembre 2005 21:24, Frank Dietrich a écrit :
> Hallo Klaus,
> Klaus Becker <colonius> wrote:
> Vermutlich weil sie von eine Lib abhängen die in dem Paket steckt. Du
> könntest aber folgendes tun, ohne die 3 Pakte zu deinstallieren.
> apt-get install libxorg-x11- libice6
> Wichtig ist das "-" hinter libxorg-x11, damit tauscht apt-get in
> diesem Fall das Paket libxorg-x11 gegen libice6. Dann sollten sich
> auch die anderen Pakete installieren lassen.


geht leider nicht:

apt-get install libxorg-x11- libice6
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
adobereader-enu libxorg-x11 openoffice.org-core02 openoffice.org-core04
openoffice.org-core04u openoffice.org-core05 openoffice.org-pyuno
openoffice.org-testtool vmwareworkstation
The following packages will be upgraded:
libice6

Klaus
Klaus Becker (21.09.2005, 21:50)
Le Mercredi 21 Septembre 2005 20:56, Hans-Georg Bork a écrit :
> Moin,
> eine Beschreibung des Fehlers waere sicherlich kuerzer gewesen als die
> Ausgabe von dreimal apt-get (dist-)upgrade ... wieso machst Du eigentlich
> dist-upgrade? Willst Du tatsaechlich ein Upgrade von Sarge zu Sarge?
> On Wed, Sep 21, 2005 at 08:19:53PM +0200, Klaus Becker wrote:
> kann es sein, dass Du libxorg-x11 mittels --force-overwrite oder anderen
> "forces" installiert hast?


Nicht dass ich wüsste. ich hab' "--force-overwrite" zwar schon mal benutzt,
aber das ist schon eine Weile her. Ganz sicher bin ich mir aber nicht.

> Welche Version ist das eigentlich? 6.9-1


> Evtl. hilft ein (temporaeres) dpkg -r libxorg-x11 ...


Du meinst, ich sollte libxorg-x11 mitsamt OO etc löschen und dann die 3
Programme wieder neu installieren ?

Klaus
Sven Hartge (21.09.2005, 22:10)
Klaus Becker <colonius> wrote:

> adobereader-enu libxorg-x11 openoffice.org-core02 openoffice.org-core04
> openoffice.org-core04u openoffice.org-core05 openoffice.org-pyuno
> openoffice.org-testtool vmwareworkstation


Wo kommen die Pakete denn her? Die sind weder in Debian Sarge noch sonst
irgendwo in Debian.

Wenn du also einfach "irgendwelche" unpassenden Pakete installierst,
dann ist es nur klar, dass das schief geht, vor allem, wenn du
anscheinend nicht genau weißt, was du eigentlich gemacht hast.

Hans-Georg Bork (21.09.2005, 23:20)
Moin,

On Wed, Sep 21, 2005 at 09:41:38PM +0200, Klaus Becker wrote:
> Le Mercredi 21 Septembre 2005 20:56, Hans-Georg Bork a écrit :
> > [...]
> > Evtl. hilft ein (temporaeres) dpkg -r libxorg-x11 ...

> Du meinst, ich sollte libxorg-x11 mitsamt OO etc löschen und dann die 3
> Programme wieder neu installieren ?


das ginge wohl auch; dpkg -r entfernt aber nur das genannte Paket, evtl.
musst Du das mit dem entsprechendem --force machen ... wenn libxorg-x11
dann weg ist sollte das urspruengliche upgrade wieder laufen.

Gruss
-- hgb
Christian Frommeyer (22.09.2005, 09:10)
Am Mittwoch 21 September 2005 21:35 schrieb Klaus Becker:
> openoffice.org-core04 openoffice.org-core04u openoffice.org-core05
> openoffice.org-pyuno openoffice.org-testtool vmwareworkstation


Wenn mich nicht alles täuscht sind das hier doch Pakete von OOo 2Beta
die eigendlich als rpm vorliegen oder nicht? Machst Du das öfter, das
Du Dir rpms ins System holst?

Gruß Chris
Klaus Becker (22.09.2005, 09:30)
Le Jeudi 22 Septembre 2005 09:07, Christian Frommeyer a écrit :
> Am Mittwoch 21 September 2005 21:35 schrieb Klaus Becker:
> > openoffice.org-core04 openoffice.org-core04u openoffice.org-core05
> > openoffice.org-pyuno openoffice.org-testtool vmwareworkstation

> Wenn mich nicht alles täuscht sind das hier doch Pakete von OOo 2Beta
> die eigendlich als rpm vorliegen oder nicht? Machst Du das öfter, das
> Du Dir rpms ins System holst?


richtig. OO2 und Vmwareworkstation habe ich mit alien und dpkg traktiert. Vor
2-- Tagen habe ich openoffice.org1.9.130 installiert, daher kommt sicher das
Problem. Bis jetzt hatte ich noch nie Schwierigkeiten damit.

Die Lösung ist also tar.gz-Pakete zu benutzen, wenn ich ein Programm brauche
und kein deb vorliegt?

Klaus
Christian Frommeyer (22.09.2005, 09:40)
Am Donnerstag 22 September 2005 09:20 schrieb Klaus Becker:
> Die Lösung ist also tar.gz-Pakete zu benutzen, wenn ich ein Programm
> brauche und kein deb vorliegt?


Das ist denke ich Geschmackssache. Man sollte halt Pakete, die nicht zur
offiziellen Distri gehören etwas genauer im Auge behalten.

Gruß Chris
Wolfgang Egger (22.09.2005, 17:10)
Servus miteinand,

ich hab gestern mein Sarge d.h. XFree aktualisiert. Seitdem kommt es mir
so vor, als seien die Fonts plötzlich "pixelig". Bilde ich mir das nur
ein, oder kann das tatsächlich sein? Haben andere das auch beobachtet?
Muss ich vielleicht irgendwo irgendwas neu konfigurieren, um die alte
Qualität wieder zu erhalten?
Mein System läuft auf nem Laptop mit ner ATI Radeon-Karte.

Thanx

Wolfgang
Klaus Becker (22.09.2005, 22:20)
Le Mercredi 21 Septembre 2005 22:55, Hans-Georg Bork a écrit :
> Moin,
> On Wed, Sep 21, 2005 at 09:41:38PM +0200, Klaus Becker wrote:
> das ginge wohl auch; dpkg -r entfernt aber nur das genannte Paket, evtl.
> musst Du das mit dem entsprechendem --force machen ... wenn libxorg-x11
> dann weg ist sollte das urspruengliche upgrade wieder laufen.


So, ich habe libxorg-x11, OO2 und vmware von der Platte runtergehauen und
versuche jetzt, die beiden Programme ohne libxorg-x11 neu zu installieren.

Diesmal nehme ich bei vmware nicht das rpm-, sondern das tar.gz-Paket, aber:

./vmware-install.pl
A previous installation of VMware software has been detected.
Failure
Execution aborted.

"dpkg -l | grep vmware" und eine Suche in synaptic oder kpackage zeigen vmware
nicht mehr an. Was muss ich da machen?

tschüs
Klaus
Klaus Becker (23.09.2005, 08:20)
Le Jeudi 22 Septembre 2005 22:15, Klaus Becker a écrit :
[..]
> Execution aborted.
> "dpkg -l | grep vmware" und eine Suche in synaptic oder kpackage zeigen
> vmware nicht mehr an. Was muss ich da machen?


Ich hab's gefunden: in "vmware-distrib/bin" befindet sich ein Skript
"vmware-uninstall.pl". Danach kann man es neu installieren.

tschüs
Klaus
Ähnliche Themen