expertenaustausch > comm.software.* > comm.software.browser.misc

Jürgen Meyer (28.05.2020, 13:53)
Ich bekomme auf einer Website keinen Ton mehr.
Der Rechner läuft unter Windows 10 Pro, 64 bit.



Es betrifft Edge (Chromium) als auch Google Chrome
Mit Firefox gibt es keine Probleme

Die Hinweise auf der Website habe ich gesehen.
Since April 2018, the Chrome browser is reluctant to play audio on WebSDR
sites.
If you use Chrome and have no audio on WebSDR sites, then update to the
newest version of Chrome. If you can't or don't want to update Chrome, use the
following workaround: switch off Chrome's new autoplay policy, by typing
chrome://flags/#autoplay-policy in the navigation bar and changing this
setting from Default to No user gesture is required (and restarting the
browser

Nun gibt es da ja unzählige Optionen.
Einen Eintrag
No user gesture is required
Finde ich allerdings nicht

Im alten IExplorer hat der Ton noch funktioniert.
(Bevor ich die Chrome-Version installiert habe).
Versuche ich es jetzt über den IExplorer, dann bekomme ich die Meldung:
Your browser does not seem to support HTML5 WebAudio

Wo ist der TricK?

Gruß
Jürgen
Herrand Petrowitsch (28.05.2020, 13:55)
Jürgen Meyer schrieb:

> Ich bekomme auf einer Website keinen Ton mehr.
> Der Rechner läuft unter Windows 10 Pro, 64 bit.
>
> Es betrifft Edge (Chromium) als auch Google Chrome


Ist JavaScript blockiert?

> [...]


Gruss Herrand
Jürgen Meyer (28.05.2020, 14:14)
On Thu, 28 May 2020 13:55:34 +0200, "Herrand Petrowitsch" posted:

>Jürgen Meyer schrieb:
>> Ich bekomme auf einer Website keinen Ton mehr.
>> Der Rechner läuft unter Windows 10 Pro, 64 bit.
>>
>> Es betrifft Edge (Chromium) als auch Google Chrome

>Ist JavaScript blockiert?

Ja, dafür ist HTLM5 aktiviert.
Das war aber schon immer so.
Java möchte ich mir nicht antun.
(Ausnahmen in Java für bestimmte Webseiten hinzufügen)

Gruß
Jürgen
Franklin Schiftan (28.05.2020, 15:02)
Jürgen Meyer schrieb am 28.05.2020 um 14:14 Uhr:

> On Thu, 28 May 2020 13:55:34 +0200, "Herrand Petrowitsch" posted:
> Ja, dafür ist HTLM5 aktiviert.
> Das war aber schon immer so.
> Java möchte ich mir nicht antun.
> (Ausnahmen in Java für bestimmte Webseiten hinzufügen)


Was hat Java mit JavaScript zu tun?
Herrand Petrowitsch (28.05.2020, 16:44)
Jürgen Meyer schrieb:
> "Herrand Petrowitsch" posted:
>> Jürgen Meyer schrieb:


>>> Ich bekomme auf einer Website keinen Ton mehr.
>>> Der Rechner läuft unter Windows 10 Pro, 64 bit.
>>>
>>> Es betrifft Edge (Chromium) als auch Google Chrome

>> Ist JavaScript blockiert?

> Ja, dafür ist HTLM5 aktiviert.


Jener Edge verfuegt con Haus aus ueber HTML5-Capability. Wie
"(de)aktivierst" du denn das in diesem Browser?

> Das war aber schon immer so.
> Java möchte ich mir nicht antun.
> (Ausnahmen in Java für bestimmte Webseiten hinzufügen)


Java != JavaScript
Siehe u.a. <https://www.java.com/en/download/faq/java_javascript.xml>.

Gruss Herrand
Herrand Petrowitsch (28.05.2020, 16:47)
Jürgen Meyer schrieb:
> "Herrand Petrowitsch" posted:
>> Jürgen Meyer schrieb:


>>> Ich bekomme auf einer Website keinen Ton mehr.
>>> Der Rechner läuft unter Windows 10 Pro, 64 bit.
>>>
>>> Es betrifft Edge (Chromium) als auch Google Chrome

>> Ist JavaScript blockiert?

> Ja, dafür ist HTLM5 aktiviert.


Besagter Browser Edge verfuegt von Haus aus ueber HTML5-Capability. Wie
"(de)aktivierst" du denn das in diesem Browser?

> Das war aber schon immer so.
> Java möchte ich mir nicht antun.
> (Ausnahmen in Java für bestimmte Webseiten hinzufügen)


Java != JavaScript
Siehe u.a. <https://www.java.com/en/download/faq/java_javascript.xml>.

Gruss Herrand
Jürgen Meyer (28.05.2020, 19:00)
On Thu, 28 May 2020 16:47:46 +0200, "Herrand Petrowitsch" posted:

>Jürgen Meyer schrieb:
>Besagter Browser Edge verfuegt von Haus aus ueber HTML5-Capability. Wie
>"(de)aktivierst" du denn das in diesem Browser?
>Java != JavaScript
>Siehe u.a. <https://www.java.com/en/download/faq/java_javascript.xml>.
>Gruss Herrand


Nicht in der Browser-Konfiguration
Auf der Website kann man wählen, ob man Java oder HTML5 benutzen will.
Wählt man Java, poppt eine Meldung auf, dass Java aus Sicherheitsgründen
blockiert wird.
Man muss dann in Java eine Ausnahme hinzufügen (Website zulassen)

Die Java Version ist 8.251

Gesagt, getan (Screenshot)


Ergebnis:
Die Seite
Meldet jetzt das angeblich kein Java installiert sei, wenn man auf Sound: Java
klickt.

Das aber nur nebenbei.
Ich will ja gar kein Java, sondern HTML5 (mit Sound).

Das merkwürdige ist ja, das es vor dem Update des IE auf Chromium funktioniert
hat.
Google Chrome hae ich erst jetzt ausprobiert
Uch da geht es auch nicht.
Beide Anwendungen basieren aber auf dem gleichen Code.
Das wäre eine Erklärung.

Im Firefox läuft es weiterhin problemlos.

Gruß
Jürgen
Herrand Petrowitsch (28.05.2020, 20:52)
Jürgen Meyer schrieb:
> "Herrand Petrowitsch" posted:
>> Jürgen Meyer schrieb:
>>> "Herrand Petrowitsch" posted:
>>>> Jürgen Meyer schrieb:


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Nochmal die obige Frage ...

> Nicht in der Browser-Konfiguration
> Auf der Website kann man wählen, ob man Java oder HTML5 benutzen will.
> Wählt man Java, poppt eine Meldung auf, dass Java aus Sicherheitsgründen
> blockiert wird.


Java ist hier(tm) nicht installiert und es wird auch keine Meldung
geworfen, "ob man Java oder HTML5 benutzen will". Es funktioniert
einfach.

> Man muss dann in Java eine Ausnahme hinzufügen (Website zulassen)
> Die Java Version ist 8.251


Warum ladest du dir Java (<https://www.java.com/de/download/manual.jsp>
auf den Rechner, wenn du wie oben

| Java möchte ich mir nicht antun

behauptest?

> Gesagt, getan (Screenshot)
>


JFTR: Bei unter x64-Voraussetzungen installierten Rechnern und
vorhandenem Java RE existiert das von dir aufgerufene
javacpl.exe sowohl in
C:\Program Files (x86)\Java\jre*\bin\ als auch in
C:\Program Files\Java\jre*\bin\.
Ziel ist dabei, das dem System entsprechende javacpl einzusetzen
(dies wird leider im Eintrag der Systemsteuerung nicht eindeutig
reflektiert, du musst schon das "richtige" javacpl "erwischen").
Nicht nur darum ist Java so unbeliebt.

> Ergebnis:
> Die Seite
> Meldet jetzt das angeblich kein Java installiert sei, wenn man auf Sound: Java
> klickt.


Siehe oben, verPISSe Java und geniesse den Sound.

> [...]


Gruss Herrand
Jürgen Meyer (28.05.2020, 21:15)
On Thu, 28 May 2020 20:52:14 +0200, "Herrand Petrowitsch" posted:

>>>>>> Ich bekomme auf einer Website keinen Ton mehr.
>>>>>> Der Rechner läuft unter Windows 10 Pro, 64 bit.
>>>>>>
>>>>>> Es betrifft Edge (Chromium) als auch Google Chrome
>>>>> Ist JavaScript blockiert?


>Java ist hier(tm) nicht installiert und es wird auch keine Meldung
>geworfen, "ob man Java oder HTML5 benutzen will". Es funktioniert
>einfach.


Das wundert mich aber.
Ich habe die Auswahlmöglichkeiten mal markiert



Java habe ich installiert, weil ich noch ein anderes Programm benutze, das
Java benötigt.



Da gibt es keine Probleme und das funktioniert auch in Edge.

Gruß
Jürgen
Arno Welzel (29.05.2020, 00:18)
Jürgen Meyer:

> Ich bekomme auf einer Website keinen Ton mehr.
> Der Rechner läuft unter Windows 10 Pro, 64 bit.
>
> Es betrifft Edge (Chromium) als auch Google Chrome
> Mit Firefox gibt es keine Probleme


Hier ebenso. Weder Edge noch Vivaldi spielen da Sound ab.

[..]
> Einen Eintrag
> No user gesture is required
> Finde ich allerdings nicht


Den gibt es bei Edge auch nicht. Ebenso bei Vivaldi nicht.

Nicht jeder Chromium-basierte Browser bietet auch alle Optionen von
Chromium an.

> Wo ist der TricK?


Es gibt keinen. Es geht einfach nicht.
Dieter Bergmann (29.05.2020, 08:11)
Arno Welzel schrieb am 29.05.2020 um 00:18:

>>

> Hier ebenso. Weder Edge noch Vivaldi spielen da Sound ab.


Also hier spielt Edge Sound ab (ein Rauschen). Angekreuzt ist 2x HTML5.

Allerdings habe ich auch gerade die Version 2004 von Win 10 aufgespielt
bekommen. Vielleicht liegt's daran.

MfG
Dieter

..
Arno Welzel (29.05.2020, 09:39)
Dieter Bergmann:

> Arno Welzel schrieb am 29.05.2020 um 00:18:
>>>

>> Hier ebenso. Weder Edge noch Vivaldi spielen da Sound ab.

> Also hier spielt Edge Sound ab (ein Rauschen). Angekreuzt ist 2x HTML5.
> Allerdings habe ich auch gerade die Version 2004 von Win 10 aufgespielt
> bekommen. Vielleicht liegt's daran.


Ja. Es geht um die Version von Edge, die auf Chromium basiert, nicht die
ursprüngliche Variante, von Windows 10.

Das Problem ist, dass Chromium Audio-Streams nicht mehr automatisch
startet. Der dort beschrieben Workaround ist, dass man in den internen
Einstellungen von Chrome eine Option ändert, dass Audio-Streams, die
automatisch starten sollen mit Rückfrage an den Benutzer zugelassen
werden. Diese Option gibt es aber nur in Chrome, nicht aber in anderen
Chromium-basierten Browsern, wie einem aktuellen Edge oder Vivaldi.
Jürgen Meyer (29.05.2020, 11:53)
On Fri, 29 May 2020 09:39:46 +0200, "Arno Welzel" posted:

>Dieter Bergmann:
>Ja. Es geht um die Version von Edge, die auf Chromium basiert, nicht die
>ursprüngliche Variante, von Windows 10.
>Das Problem ist, dass Chromium Audio-Streams nicht mehr automatisch
>startet. Der dort beschrieben Workaround ist, dass man in den internen
>Einstellungen von Chrome eine Option ändert, dass Audio-Streams, die
>automatisch starten sollen mit Rückfrage an den Benutzer zugelassen
>werden. Diese Option gibt es aber nur in Chrome, nicht aber in anderen
>Chromium-basierten Browsern, wie einem aktuellen Edge oder Vivaldi.


Danke für die Erklärungen.
Dann muss ich wohl damit leben.
Vielleicht kommt ja irgendwann mal ein Update.

Gruß
Jürgen
Jürgen Meyer (29.05.2020, 18:44)
On Fri, 29 May 2020 09:39:46 +0200, "Arno Welzel" posted:

>Dieter Bergmann:
>Ja. Es geht um die Version von Edge, die auf Chromium basiert, nicht die
>ursprüngliche Variante, von Windows 10.
>Das Problem ist, dass Chromium Audio-Streams nicht mehr automatisch
>startet. Der dort beschrieben Workaround ist, dass man in den internen
>Einstellungen von Chrome eine Option ändert, dass Audio-Streams, die
>automatisch starten sollen mit Rückfrage an den Benutzer zugelassen
>werden. Diese Option gibt es aber nur in Chrome, nicht aber in anderen
>Chromium-basierten Browsern, wie einem aktuellen Edge oder Vivaldi.


Gerade noch eine Merkwürdigkeit entdeckt:
Führe ich Edge (Chromium) als Administrator aus, habe ich auch Ton.
Rechtsklick Icon / Als Administrator ausführen.
Als Benutzer mit eingeschränkten oder erweiterten Rechten nicht.

Starte ich Google Chrome mit Administratorrechten, ändert sich nichts.
(Nach wie vor kein Ton)

Gruß
Jürgen
Herrand Petrowitsch (30.05.2020, 14:29)
Dieter Bergmann schrieb:
> Arno Welzel schrieb:


>>>

>> Hier ebenso. Weder Edge noch Vivaldi spielen da Sound ab.

> Also hier spielt Edge Sound ab (ein Rauschen). Angekreuzt ist 2x HTML5.
> Allerdings habe ich auch gerade die Version 2004 von Win 10 aufgespielt
> bekommen. Vielleicht liegt's daran.


Nein, zumal die von Juergen angesprochene, Chromium-basierte, Variante
des Browsers Edge (noch) nicht in Windows 10 20H1 enthalten ist, sondern
(nur) eine aktualisierte Version des bisher veroeffentlichten Edge (der
den Ton uebrigens ebenfalls abspielt).

BTW wird hier(tm) auch unter folgenden Voraussetzungen der Sound
durchaus wiedergegeben:

OS: MacOS High Sierra Version 10.13.6
Browser: Safari Version 13609.1.20.111.8
Opera Version 68.0.3618.125

Gruss Herrand

Ähnliche Themen