expertenaustausch > comp.sys.* > comp.sys.mac.misc

Dirk Dittert (18.11.2003, 19:42)
Hallo,

ich verwende einen Mailserver, der für die SSL-Verbindungen
selbstausgestellte Zertifikate verwendet. Wie kann ich Mail dazu
bringen, dieses Zertifikat nicht nach jedem Neustart des Programms zu
bemeckern?

Gibts in diesem Programm auch ne Möglichkeit, wie man zwei Accounts
definieren kann, wobei einer davon keine Daten für POP/IMAP eingetragen
haben soll? Der Grund dafür ist, daß ich zwar mit der E-Mail-Adresse des
Accounts E-Mails verschicke, eingehende Mails jedoch auf einen anderen
Account weitergeleitet werden. Die Daten eines anderen Accounts kann ich
nicht eintragen, weil Mail sich dann beschwert, daß es diesen Account
bereits gibt. Einfach zu kindersi^W äh benutzerfreundlich die Software
heutzutage...

Viele Grüße,

Dirk Dittert
Noses (18.11.2003, 20:43)
Dirk Dittert <dittert> wrote:
> ich verwende einen Mailserver, der für die SSL-Verbindungen
> selbstausgestellte Zertifikate verwendet. Wie kann ich Mail dazu
> bringen, dieses Zertifikat nicht nach jedem Neustart des Programms zu
> bemeckern?


Indem Du dieses Zertifikat im Schlüsselbunf (X509-Anchors) unterbringst.
Näheres steht sogar in der Hilfe zu Mail.

Noses.
Bernd Muellers (18.11.2003, 21:23)
Noses <noses.nospam> wrote:

> Indem Du dieses Zertifikat im Schlüsselbunf (X509-Anchors) unterbringst.
> Näheres steht sogar in der Hilfe zu Mail.


Zufälligerweise hing ich genau dort auch heute mittag.
In der Hilfe steht ".. und wählen Sie "X.509 Anchors" aus dem
Einblendmenü". Gibbet bei mir nicht. Das Aufklappmenü zeigt ja die
verschiedenen Schlüsselbunde.
In meinem Schlüsselbund ist das betreffende Zertifikat drin - hülft
nüscht.
Ich hab jetzt schon weitere Schlüsselbunde mit den Namen "X509-Anchors"
(laut deinem Posting) und "X.509 Anchors" (laut Apple Hilfe) angelegt
und das Zertifikat dort reingepackt - nimmt er leider auch nicht.

any hints?

burned
Noses (18.11.2003, 23:00)
Bernd Muellers <piksel> wrote:
> > Indem Du dieses Zertifikat im Schlüsselbund (X509-Anchors) unterbringst.
> > Näheres steht sogar in der Hilfe zu Mail.

> Zufälligerweise hing ich genau dort auch heute mittag.
> In der Hilfe steht ".. und wählen Sie "X.509 Anchors" aus dem
> Einblendmenü". Gibbet bei mir nicht.


Welches Betriebssystem? 10.3 _muß_ das haben. Und ansonsten: Du bist
Mitglied der Gruppe admin?

> Das Aufklappmenü zeigt ja die verschiedenen Schlüsselbunde.


Die X.509-Anker liegen auf einem anderen Schiffsfriedhof.

> In meinem Schlüsselbund ist das betreffende Zertifikat drin - hülft
> nüscht.


Stimmt. Das steht ja in der Hilfe.

> any hints?


Ja. Admin sein.

Noses.
Bernd Muellers (18.11.2003, 23:44)
Noses <noses.nospam> wrote:

> Welches Betriebssystem? 10.3 _muß_ das haben. Und ansonsten: Du bist
> Mitglied der Gruppe admin?


10.3.1. Ich bin laut Netinfo in der Gruppe admin.

> Die X.509-Anker liegen auf einem anderen Schiffsfriedhof.


Aha (ich hab mir die manpages zu racoon und/oder openssl noch nicht
näher angelesen - gehts in diese Richutung?).
Der "Anker" sollte also aber im Menü beim Zertifkat-Hinzufügen
auftauchen? Hab mich schon gewundert, was mir die Apple Hilfe da
erzählen will.

>> any hints?

> Ja. Admin sein.


s.o.

ratlos,
burned
Noses (19.11.2003, 00:01)
Bernd Muellers <piksel> wrote:
> > Die X.509-Anker liegen auf einem anderen Schiffsfriedhof.

> Aha (ich hab mir die manpages zu racoon und/oder openssl noch nicht
> näher angelesen - gehts in diese Richutung?).


Nein, mit IPsec haben die nichts zu tun - idiotischerweise bedient sich
racoon nicht im keyring. Schau mal nach /System/Library/Keychains.

> Der "Anker" sollte also aber im Menü beim Zertifkat-Hinzufügen
> auftauchen?


Ja.

> >> any hints?

> > Ja. Admin sein.


Ok. Notfalls den Schlüsselbundklimperer nehmen und
/System/Library/Keychains/X509Anchors bearbeiten.

Noses.
Dirk Dittert (19.11.2003, 02:06)
Noses <noses.nospam> wrote:

> Welches Betriebssystem? 10.3 _muß_ das haben. Und ansonsten: Du bist
> Mitglied der Gruppe admin?


Nein, gibt es nicht (10.3.1). Es gibt bei mir nur dittert und system.

> Ja. Admin sein.


Netinfo-Manager zeigt in der admin Gruppe als user root und dittert an.
Daran liegt es also auch nicht.

Viele Grüße,

Dirk Dittert
Dirk Dittert (19.11.2003, 02:06)
gNoses <noses.nospam> wrote:

> Ok. Notfalls den Schlüsselbundklimperer nehmen und
> /System/Library/Keychains/X509Anchors bearbeiten.


Du meinst:
- Schlüsselbund öffnen.
- Schlüsselbund hinzufügen wählen
- /System/Library/X509Anchors auswählen
- Importieren wählen und das vorher auf den Desktop gezogene Zertifikat
auswählen
- Kennwort eingeben
- überprüfen, daß das Zertifikat auch in der Liste ist
- Mail neu starten und ausprobieren

Das hilft bei mir auch nicht. Irgendwie muß das doch gehen...

Viele Grüße,

Dirk Dittert
Hado Hein (19.11.2003, 20:57)
Dirk Dittert <dittert> wrote:
> bereits gibt. Einfach zu kindersi^W äh benutzerfreundlich die Software
> heutzutage...


Nee, nee, können einfach nicht mehr selber denken, die User.

Du legst Deinen send-only Account an und gibst dem POP/IMAP einfach zwei
Striche. (Wenn Du mehrere davon hast allen einen eigenen Namen ! Sonst
macht Mail dich richtig fertig mit schon geöffneten Mailboxen...)

Danach auf den dritten Tab (Options) und das Kreuzchen vor "Account beim
Empfang von Mails berücksichtigen" unchecken.

Und schon sendest Du wie Du willst und empfängst nix weil Du es
ungeckeckt hast ;---)
Bernd Muellers (19.11.2003, 23:51)
Dirk Dittert <dittert> wrote:
[..]
Bernd Muellers (19.11.2003, 23:51)
Dirk Dittert <dittert> wrote:

> - Schlüsselbund öffnen.
> - Schlüsselbund hinzufügen wählen
> - /System/Library/X509Anchors auswählen
> - Importieren wählen und das vorher auf den Desktop gezogene Zertifikat
> auswählen
> - Kennwort eingeben
> - überprüfen, daß das Zertifikat auch in der Liste ist
> - Mail neu starten und ausprobieren


Genau so hats bei mir gestern abend doch noch geklappt.
Noses, vielen Dank für den Fingerzeig.

burned
Noses (20.11.2003, 00:36)
Bernd Muellers <piksel> wrote:
> Genau so hats bei mir gestern abend doch noch geklappt.


Denke daran, daß das nur eine Notmaßnahme ist - es wäre gesund,
herauszufinden, warum Keychain Manager.app Dir nicht gleich die Möglichkeit
angeboten hat, den Import an die richtige Stelle zu packen. Ich würde jetzt
anfangen, mit "openssl x509" genau hinzusehen.

Noses.
Noses (20.11.2003, 00:37)
Dirk Dittert <dittert> wrote:
> - Schlüsselbund öffnen.
> - Schlüsselbund hinzufügen wählen
> - /System/Library/X509Anchors auswählen
> - Importieren wählen und das vorher auf den Desktop gezogene Zertifikat
> auswählen
> - Kennwort eingeben
> - überprüfen, daß das Zertifikat auch in der Liste ist
> - Mail neu starten und ausprobieren


Wenn das nicht hilft solltest Du Dir das Zertifikat genau ansehen.

Noses.
Ähnliche Themen