expertenaustausch > linux.debian.user.german

Nina Eichler (21.09.2005, 15:10)
Hallo zusammen,

vielleicht könnt Ihr mir ja helfen, ich habe eigentlich nur versucht auf meinem Debiansystem den Virenscanner clamAV (stable Paket auf unstable Paket) upzudaten. Ich habe zuvor mit apt-get update und apt-get upgrade das System auf den neusten Stand gebracht hat auch alles ohne Problem funktioniert. Bei dem Befehl apt-get install -t testing clamav hab ich dann diesen Error bekommen:

This installation run will require temporarily removing the essential package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option.

Ich hab dann in der apt.conf folgende Zeile hinzugefügt: APT::Force-LoopBreak "1"

Das Paket konnte ich jedoch immernoch nicht installieren. Jetzt bekomme ich folgende Meldung:

apt-get install -t unstable clamav
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
clamav: Depends: libclamav1 (>= 0.87) but 0.85.1-2 is to be installed
initscripts: Depends: e2fsprogs (>= 1.19-1) but it is not going to be installed
libc6-dev: Depends: libc6 (= 2.3.2.ds1-22) but 2.3.5-6 is to be installed
sysvinit: Depends: e2fsprogs (>= 1.15-1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Auch ein apt-get upgrade funktioniert nicht mehr. Kann mir jemand weiterhelfen?

Viele Grüße, Nina
Martin Wodrich (21.09.2005, 15:40)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: RIPEMD160

Nina Eichler schrieb:

> vielleicht könnt Ihr mir ja helfen, ich habe eigentlich nur versucht auf meinem Debiansystem den Virenscanner clamAV
> (stable Paket auf unstable Paket) upzudaten. Ich habe zuvor mit apt-get update und apt-get upgrade das System auf den
> neusten Stand gebracht hat auch alles ohne Problem funktioniert.
> Bei dem Befehl apt-get install -t testing clamav hab ich dann diesen Error bekommen:


Wenn du einen neueren Clamav willst und ansonsten Debian Stable nutzen
willst (also derzeit sarge), dann nutze nicht den clamav aus testing,
sondern aus volitale.

Zeilen der sources.list dazu:
deb sarge/volatile main
deb-src sarge/volatile main

Volitale ist ein Repository speziell um Virenscanner und ähnlich
schnelllebige Software auf einen neuen Stand zu bringen und
gleichzeitig eben den Rest des Systems sauber auf Debian Stable zu
lassen.

Debian Stable und Testing/Unstable einfach zu mischen, ist selten eine
gute Idee.

- --
Mit freundlichen Grüssen,
Martin Wodrich
Andreas Pakulat (21.09.2005, 15:50)
On 21.09.05 15:08:55, Nina Eichler wrote:
> vielleicht könnt Ihr mir ja helfen, ich habe eigentlich nur versucht auf meinem Debiansystem den Virenscanner clamAV (stable Paket auf unstable Paket) upzudaten. Ich habe zuvor mit apt-get update und apt-get upgrade das System auf den neusten Stand gebracht hat auch alles ohne Problem funktioniert. Bei dem Befehl apt-get install -t testing clamav hab ich dann diesen Error bekommen:


Kannst du deinem Groupwise bitte beibringen nicht solche Bandwurmsätze
zu erzeugen, sondern diese bei 72 Zeichen umzubrechen. Danke.

> This installation run will require temporarily removing the essential package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option.
> Ich hab dann in der apt.conf folgende Zeile hinzugefügt: APT::Force-LoopBreak "1"


Hast du dich vorher darum gekümmert was das bedeutet und warum es
überhaupt zu dieser Schleife kommt? Man sollte als Nicht-Wissender nicht
irgendwelche Force-Optionen blind setzen. Nimm das wieder raus.

> Das Paket konnte ich jedoch immernoch nicht installieren. Jetzt bekomme ich folgende Meldung:
> apt-get install -t unstable clamav
> Reading Package Lists... Done
> Building Dependency Tree... Done
> You might want to run `apt-get -f install' to correct these:
> The following packages have unmet dependencies:
> clamav: Depends: libclamav1 (>= 0.87) but 0.85.1-2 is to be installed


Du musst auch clamav's Depends aus unstable installieren, also

apt-get install -t unstable clamav libclamav1 ...

> initscripts: Depends: e2fsprogs (>= 1.19-1) but it is not going to be installed
> libc6-dev: Depends: libc6 (= 2.3.2.ds1-22) but 2.3.5-6 is to be installed
> sysvinit: Depends: e2fsprogs (>= 1.15-1) but it is not going to be installed


Und genau da beginnt dein Problem. Das neuere Clamav braucht eine neue
libc6, was bedeutet dass du quasi dein ganzes System auf unstable hieven
musst. _Das_ willst du aber bestimmt nicht. Such dir einen Backport für
clamav für Sarge (Betreibt norbert noch backports.org?) und schmeiss die
unstable-Einträge aus deiner sources.list raus.

Andreas
Eduard Bloch (21.09.2005, 16:00)
Moin Nina!
Nina Eichler schrieb am Mittwoch, den 21. September 2005:

[..]
> sysvinit: Depends: e2fsprogs (>= 1.15-1) but it is not going to be installed
> E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
> Auch ein apt-get upgrade funktioniert nicht mehr. Kann mir jemand weiterhelfen?


Das passiert, wenn man eben nicht die offizielle Distributionen verfolgt
sondern eigenen Mix baut. apt-get (vor allem altes Apt aus Sarge oder
noch davor) hat da Probleme und die kann man nicht einfach so lösen. Was
oft hilft: die Pakete mit Conflicten im gleichen Aufruf angeben. Hier also:

apt-get install -t unstable clamav initscripts libc6-dev sysvinit e2fsprogs

Eduard.
Ähnliche Themen