expertenaustausch > microsoft.* > microsoft.german.sharepoint.windowsservices

Erik Schultheis (09.11.2008, 15:24)
Hallo,

ich habe das Whitepaper zum Troubleshooting von Problemen mit dem
Explorer-View gelesen. Trotzdem bleiben ein paar Probleme, von denen ich
hoffe dass hier jemand eine Idee dazu hat:

1. Wenn ich unter Vista auf einer Dokumentbibliothek einer Seite der Form
öffne, kein Problem. Läuft über WebDAV, wie man auch
unschwer an den Symbolen erkennen kann. Auch kann ich diese
Dokumentbibliothek erfolgreich als Netzlaufwerk verbinden.

Dokumentbibliotheken der Form allerdings
können überhaupt nicht geöffnet werden, weder im Explorer-View noch als
Verbindung unter Netzwerkumgebung. Ok, laut Whitepaper nutzt Windows für
URLs dieser Form auch nicht WebDAV sondern FPRDP - kann es sein dass dies
unter Vista überhaupt nicht unterstützt wird!?

2. Unter Windows XP kann ich Dokumente von Websites der Form
durchaus im Explorer-View öffnen und auch
als Resource unter Netzwerkumgebung hinzufügen. Ok soweit, so kann ich
aber nur aus Office-Programmen heraus direkt mit "Speichern unter" auf
Sharepoint abspeichern, was zum Beispiel sehr nervig ist wenn man Acrobat
Pro o.ä. benutzt.

Da wir nun sehr viele Teamseiten haben, aller der Form
[site] kann ich nicht alle direkt auf einen Port
legen da sich natürlich viele Webitesammlungen eine Webanwendung (und eine
DB) teilen.

Gibt es dafür eine Lösung? Und evtl. auch eine Eklärung warum man mit
Vista auf solche URLs gar nicht im Explorer-Modus zugreifen kann?

Im übrigen scheint er bei manchen XP Clients WebDav auch bei Seiten der
Form nicht zu benutzen sondern immer die schlechtere
Alternative wählt, warum auch immer.

Achja, Setting: WSS 3.0-Farm, gleiches Verhalten/Problematik bei einer
MOSS 2007-Farm.

Für jeden Input dankbar,
Erik
Stefan Weyer (maxxcomm) (10.11.2008, 13:27)
Hi Erik,

dass bei der Site bei dir WebDAV genutzt wird, wundert mich
etwas, denn eigentlich geht WebDAV ohne Umkonfiguration nur auf Port 80!
Auf allen anderen Ports wird FPRPC genutzt. Die Versionen und
Implementierungen von WebDAV und FPRPC sind grundverschieden abhängig
von Betriebssystem und Office-Version.

Zum Beispiel hast du mit Vista und Office 2007 gar kein FPRPC mehr
installiert. Hier musst du die Zusatzkomponente RoseBud (auf der
Office-CD zu finden) installieren. Wenn du Office 2003 hast, dann ist
das "eigentlich" dabei, es sei denn du hast es bei der Installation
explizit nicht installiert.

Auf Windows XP ist der Web Client Dienst bei Default gestartet, es sei
denn du installierst direkt mit SP2. Dann musst du ihn da entsprechend
aktivieren. Auf Vista müsste er aktiviert sein, bin mir aber nicht
sicher. Des weiteren verhält sich IE 7.0 (Vista) anders als IE 6.0. Du
solltest also alles entsprechend vergleichen und sehen was wann wo
genau geht. Wenn du dann mal eine Geht/geht-Nicht -Matrix postet, können
wir schauen wo das Problem sein kann.

Ach ja, Firewall ist nicht zwischen Client und WSS, oder?

HTH,

Gruß, Stefan

"Erik Schultheis" <schuerik> wrote in message
news:op.ukcsu7dnpko7n1@orion:
[..]
Erik Schultheis (12.11.2008, 01:17)
Hallo Stefan

> dass bei der Site bei dir WebDAV genutzt wird, wundert mich
> etwas, denn eigentlich geht WebDAV ohne Umkonfiguration nur auf Port 80!


geht erstaunlicherweise auch nur mit Vista und Office 2007!

> Zum Beispiel hast du mit Vista und Office 2007 gar kein FPRPC mehr
> installiert. Hier musst du die Zusatzkomponente RoseBud (auf der
> Office-CD zu finden) installieren. Wenn du Office 2003 hast, dann ist
> das "eigentlich" dabei, es sei denn du hast es bei der Installation
> explizit nicht installiert.


danke für den Hinweis, das wusste ich noch nicht.

> genau geht. Wenn du dann mal eine Geht/geht-Nicht -Matrix postet, können
> wir schauen wo das Problem sein kann. ok, so sieht es nun also aus:


Vista + Office2007 mit --> Mapping, Webdav, Speichern etc.
Vista + Office2007 mit (MOSS) --> WebDav
Vista + Office2007 mit (WSS) --> geht nicht

Folgendes gilt für MOSS und WSS
XP + Office 2003/2007 mit http:// --> WebDav
XP + Office 2003/2007 mit --> WebDav
XP + Office 2003/2007 mit http:8080/websites --> FPRPC

Das mit Vista ist nicht so tragisch da es nicht ausgerollt wurde, aber
hier mal der VOllständigkeit halber.

Da vor allem mit der WSS-Installation gearbeitet wird und dort fast alles
auf einem Port != 80 läuft, scheint mir im Moment fast die einzige Lösung
zu sein, die gesamte Webapplikation auf Port 80 zu hieven?

Bei der MOSS-Installation wird das schwierig, dort sind mehrere
Webapplikationen auf unterschiedlichen Ports, von daher, wenn es da noch
andere Wege und Möglichkeiten gäbe, um so besser!

Danke,
Erik
Ähnliche Themen