expertenaustausch > linux.debian.user.german

Frank Dietrich (20.09.2005, 16:20)
Hallo an euch,

habe heute an einem Rechner auf dem ich sonst nur remote Programme
starte lokal Gnome gestartet. Da ist irgendwas nicht ganz in Ordnung
und ich bin mittels $Suchmaschine nicht zu einer Lösung gekommen.

Sofort sichtbarer Fehler im Gnome-Menü werden keine PNG Symbole mehr
angezeigt.

Habe dann einige Programme im Terminal gestartet und da kommen
folgende Meldungen
- gnome-theme-manager:
- es wird nicht für alle Themes eine Vorschu gezeigt,
z.B. Crux, Default ohne, Glider, Gorilla mit
- Fehlermeldung
GdkPixbuf-CRITICAL **: gdk_pixbuf_get_pixels: assertion \
`pixbuf != NULL' failed

- gthumb:
- kann keine PNG Grafiken mehr anzeigen
- Fehlermeldung wie beim g-t-m und zusätzlich
CRITICAL **: gth_image_list_append_with_data: \
assertion `pixbuf != NULL' failed

- mysql-admin:
- der brincht nach dem Start gleich ganz ab
- Fehlermeldung
libglade-WARNING **: Error loading image: Couldn't recognize \
the mage file format for file '/usr/share/mysql-gui/administrator\
/options_general.png'
- 'file /usr/share/mysql-gui/administrator/options_general.png'
"PNG image data, 48 x 48, 8-bit/color RGBA, non- interlaced"

Kann mir jemand einen Tipp geben in welcher Richtung ich suchen
sollte?

Frank
Alexander Schmehl (20.09.2005, 17:50)
* Frank Dietrich <bits_n_bytes> [050920 16:14]:
[ verschiedene Probleme mit etch und png-Dateien in unterschiedlichen
Programmen ]
> Kann mir jemand einen Tipp geben in welcher Richtung ich suchen
> sollte?


Bei einer libpng?

IIRC war dazu auch gerade was auf -devel.

Yours sincerely,
Alexander
Frank Dietrich (22.09.2005, 16:50)
Hallo Andreas,

Alexander Schmehl <alexander> wrote:
> * Frank Dietrich <bits_n_bytes> [050920 16:14]:
> [ verschiedene Probleme mit etch und png-Dateien in
> unterschiedlichen Programmen ]
> > Kann mir jemand einen Tipp geben in welcher Richtung ich suchen
> > sollte?

> Bei einer libpng?


Habe alle libpng* nochmal frisch installiert leider keine Besserung.
Da dieses Problem auch in $Suchmaschine nicht auftaucht glaub ich
nicht das es ein generelles ist und der Fehler eher an meinem System
liegen muß.
Wie bekomm ich jetzt heraus ob evtl. eine andere lib beschädigt ist?
Um dann dieses Paket dann nochmal neu zu installieren.

> IIRC war dazu auch gerade was auf -devel.


Kannst Du mir dazu einen Link schicken? Habe über lists.debian.org
nur etwas zum Thema libpng3-dev gefunden, das diese durch libpng12-
dev abgelöst wird.

Frank
Tim Boneko (22.09.2005, 19:00)
Frank Dietrich schrieb:
> Hallo an euch,


Hallo an dich!

> Sofort sichtbarer Fehler im Gnome-Menü werden keine PNG Symbole mehr
> angezeigt.


Ich hatte hier neulich ein ähnliches Problem mit sarge; zufällig kam ich
drauf, dass gconf nicht installiert war. Natürlich war es das mal; wo es
hingeflogen ist, weiß ich nicht. Hauptsächlich behob die (Neu-)
Installation mehrere Gnome- Probleme auf einmal.
Hth,

timbo
Frank Dietrich (23.09.2005, 08:00)
Hallo Tim,

Tim Boneko <tim> wrote:

> Frank Dietrich schrieb:
> Ich hatte hier neulich ein ähnliches Problem mit sarge; zufällig
> kam ich drauf, dass gconf nicht installiert war. Natürlich war es
> das mal; wo es hingeflogen ist, weiß ich nicht. Hauptsächlich behob
> die (Neu-) Installation mehrere Gnome- Probleme auf einmal.


gconf ist noch installiert gewesen. Aber meine Vermutung ging,
aufgrund mangelnder ähnlicher Fälle in $Suchmschine, schon mehr in
die Richtung das es ein Problem auf meinem System sein müsste.
Leider habe ich keinen Weg gefunden heraus zu bekommen welche
Datei defekt ist (hatte an md5sum Check gedacht). Also habe ich
einfach alle installierten libgtk* Paket nochmal reinstalliert.

dpkg --get-selections libgtk* | awk '/\tinstall/ {print $1}' | \
xargs apt-get -y --reinstall install

Seit dem geht es wieder. Leider bleibt so ein Rätsel was die genaue
Ursache gewesen ist. Die Hauptsache ist, das es wieder läuft.

Frank

PS: Für die Lösung mittels md5sum ist mir eben grad ein Ansatz
eingefallen.

cat /var/lib/dpkg/info/*.md5sums | md5sum -c

War gestern wohl einfach zu sehr mit dem Problem beschäftigt
oder es war einfach schon zu spät. ;-)
Ähnliche Themen