expertenaustausch > microsoft.* > microsoft.german.windows.server.active_directory

Andy Rüegg (12.09.2005, 09:58)
Hallo hab ein kleines Problem.

Intern werden alle PC und Laptops via GPO für den IE auf einen Proxy
geleitet aus sicherheits Gründen.

Nun können die User Anhang der Richtlinien nicht an den Verbindung
Eigenschaften am IE ändern.

Wenn nun ein Mitarbeiter sein Laptop zu hause oder im Hotel ansteckt
geht nichts, weil immer noch die GPO von der Domäne Aktive ist.

Gibt es eine Möglichkeit beim erkennen von anderen fremden Netzwerken
die IE Proxy settigns auszuschalten. ?
Daniel Melanchthon [MSFT] (12.09.2005, 12:22)
Andy Rüegg schrieb:

> Gibt es eine Möglichkeit beim erkennen von anderen fremden Netzwerken
> die IE Proxy settigns auszuschalten. ?


Hallo Andy,

ich würde das Problem anders angehen. Wenn Du im internen Netzwerk WPAD zur
Autoerkennung des Proxy benutzt, dann findet er im LAN den Proxy
automatisch. Außerhalb vom LAN liefert WPAD keinen Proxy zurück und er kann
ohne Proxy surfen:



Du könntest noch einen Schritt weitergehen, und die WPAD-Datei zusätzlich
auf Deinem offiziellen Webserver ablegen. Wenn der Client dann extern ist,
kann er von Deinem Webserver die Einstellung "ohne Proxy" automatisch bekommen.

Das läßt sich dann beliebig verfeinern. Ich kenne Kunden, die die
WPAD-Datei durch ein Skript dynamisch erstellen lassen. Da kannst Du dann
noch jede Menge Bedingungen abprüfen. Zum Beispiel auch die Quell-IP des
Clients, um damit dynamisch Proxysettings verschiedenen Umgebungen, in
denen der Client sich befindet, anzupassen.
Andy Rüegg (12.09.2005, 15:11)
Daniel Melanchthon [MSFT] schrieb:
[..]
> dann noch jede Menge Bedingungen abprüfen. Zum Beispiel auch die
> Quell-IP des Clients, um damit dynamisch Proxysettings verschiedenen
> Umgebungen, in denen der Client sich befindet, anzupassen.


Das ist eine gute sache.

Ich habe nun das wpad file erstellt mit den angaben und dns, dhcp angepasst.

Ïch habe da in der Proxyeintellung die angaben fix drin.
(die gehen raus)

und in der Automatischen Browserkonfig nichts.
Daniel Melanchthon [MSFT] (12.09.2005, 18:26)
Andy Rüegg schrieb:

> Ich habe nun das wpad file erstellt mit den angaben und dns, dhcp
> angepasst.
> Ïch habe da in der Proxyeintellung die angaben fix drin.
> (die gehen raus)
> und in der Automatischen Browserkonfig nichts.


Dafür schreibst Du zuwenig von Deiner Konfiguration, um das sinnvoll
debuggen zu können.
Andy Rüegg (12.09.2005, 20:25)
Daniel Melanchthon [MSFT] schrieb:
> Andy Rüegg schrieb:
> Dafür schreibst Du zuwenig von Deiner Konfiguration, um das sinnvoll
> debuggen zu können.


Wäre das in etwa so Richtig in der GPO Police?

------------------------------------------------------------------------
Windows-Einstellungen/Internet Explorer-Wartung/Verbindung/Automatische
Browserkonfiguration

Richtlinie Einstellung
Automatische Ermittlung von Konfigurationseinstellungen Aktiviert
Automatische Browserkonfiguration Aktiviert
Intervall Nicht konfiguriert
AutoConfig-URL (INS-Datei)
AutoProxy-URL (JS-, JVS- oder PAC-Datei)
-------------------------------------------------------------------------
-------------------------------------------------------------------------
Administrative Vorlagen/Windows-Komponenten/Internet Explorer

Richtlinie Einstellung
Änderung der Einstellungen für automatische Konfiguration deaktivieren
Aktiviert
Änderung der Homepage-Einstellungen deaktivieren Aktiviert
Änderung der Proxyeinstellungen deaktivieren Aktiviert
Änderung der Verbindungseinstellungen deaktivieren Aktiviert
------------------------------------------------------------------------
Daniel Melanchthon [MSFT] (12.09.2005, 21:30)
Andy Rüegg schrieb:



Rufe mal genau das am Client mit dem IE auf. Poste auch mal den Inhalt
Deiner WPAD-Datei.
Ähnliche Themen