expertenaustausch > linux.debian.user.german

Siegfrid Brandstätter (14.03.2019, 18:30)
Hallo Liste,

mit meinem Debian-Buster kann ich die Fotos vom Handy nicht auf den PC
übertragen. Unter Stretch war das kein Problem.

Ich stecke das Handy per USB-Kabel an und danach bekomme ich sofort vier
Optionen angeboten ob ich die Daten per Digikam oder anderen Programmen
öffnen möchte. Aber leider klappt das dann nicht. Egal ob ich es mit KDE
oder Xfce versuche, genauso wenig mit Dolphin, Gwenview.

Zusätzlich teile ich dem Handy auch noch mit das ich Fotos per PTP
übertragen möchte.

Mit Dolphin erhalte ich dann dies:
"Die Datei oder der Ordner
udi=/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1c.2/0000:03:00.0/usb2/2-2/2-2.1/
existiert nicht."

etwas später kommt dann noch:

"Es wurden keine Speicher gefunden. Überprüfen Sie, ob Ihr Gerät
entsperrt ist und ob MTP in den USB-Verbindungseinstellungen
eingeschaltet ist."

Digikam öffnet sich und kann aber keine Fotos anzeigen.
"Fehler beim Verbinden mit der Kamera. Bitte überprüfen Sie, ob die
Kamera korrekt angeschlossen und eingeschaltet ist."

# lsusb
Bus 004 Device 002: ID 05e3:0612 Genesys Logic, Inc. Hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 2a47:f003
Bus 002 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub

# lsusb -vs 002:003

Bus 002 Device 003: ID 2a47:f003
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x2a47
idProduct 0xf003
bcdDevice 3.18
iManufacturer 1 bq
iProduct 2 Aquaris X Pro
iSerial 3 BL049421
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 0x0027
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
(Bus Powered)
MaxPower 500mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 3
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 255 Vendor Specific Subclass
bInterfaceProtocol 0
iInterface 6 MTP
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x01 EP 1 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x82 EP 2 IN
bmAttributes 3
Transfer Type Interrupt
Synch Type None
Usage Type Data
wMaxPacketSize 0x001c 1x 28 bytes
bInterval 6
Device Qualifier (for other device speed):
bLength 10
bDescriptorType 6
bcdUSB 2.00
bDeviceClass 0
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
bNumConfigurations 1
can't get debug descriptor: Resource temporarily unavailable
Device Status: 0x0000
(Bus Powered)

Im syslog finde ich das:

Mar 14 15:51:23 debian kernel: [ 8925.918279] usb 2-2.1: reset
high-speed USB device number 5 using xhci_hcd
Mar 14 15:51:29 debian kernel: [ 8931.406363] usb 2-2.1: device
descriptor read/64, error -110
Mar 14 15:51:44 debian kernel: [ 8947.074462] usb 2-2.1: device
descriptor read/64, error -110
Mar 14 15:51:44 debian kernel: [ 8947.262469] usb 2-2.1: reset
high-speed USB device number 5 using xhci_hcd
Mar 14 15:51:50 debian kernel: [ 8952.446502] usb 2-2.1: device
descriptor read/64, error -110
Mar 14 15:52:05 debian kernel: [ 8968.062566] usb 2-2.1: device
descriptor read/64, error -110
Mar 14 15:52:05 debian kernel: [ 8968.250616] usb 2-2.1: reset
high-speed USB device number 5 using xhci_hcd
Mar 14 15:52:07 debian kernel: [ 8969.434670] usb 2-2.1: reset
high-speed USB device number 5 using xhci_hcd
Mar 14 15:52:12 debian kernel: [ 8974.926681] usb 2-2.1: device
descriptor read/64, error -110
Mar 14 15:52:28 debian kernel: [ 8990.590849] usb 2-2.1: device
descriptor read/64, error -110
Mar 14 15:52:28 debian kernel: [ 8990.778832] usb 2-2.1: reset
high-speed USB device number 5 using xhci_hcd
Mar 14 15:52:33 debian kernel: [ 8995.966777] usb 2-2.1: device
descriptor read/64, error -110
Mar 14 15:52:49 debian kernel: [ 9011.582906] usb 2-2.1: device
descriptor read/64, error -110
Mar 14 15:52:49 debian kernel: [ 9011.778944] usb 2-2.1: reset
high-speed USB device number 5 using xhci_hcd
Mar 14 15:52:50 debian smartd[593]: Device: /dev/sdb [SAT], SMART Usage
Attribute: 190 Airflow_Temperature_Cel changed from 70 to 69
Mar 14 15:54:36 debian kernel: [ 9119.180051] usb 2-2.1: USB disconnect,
device number 5
Mar 14 15:54:37 debian kernel: [ 9119.411698] usb 2-2.1: new high-speed
USB device number 6 using xhci_hcd
Mar 14 15:54:37 debian kernel: [ 9119.516038] usb 2-2.1: New USB device
found, idVendor=2a47, idProduct=f003, bcdDevice= 3.18
Mar 14 15:54:37 debian kernel: [ 9119.516042] usb 2-2.1: New USB device
strings: Mfr=1, Product=2, SerialNumber=3
Mar 14 15:54:37 debian kernel: [ 9119.516044] usb 2-2.1: Product:
Aquaris X Pro
Mar 14 15:54:37 debian kernel: [ 9119.516046] usb 2-2.1: Manufacturer: bq
Mar 14 15:54:37 debian kernel: [ 9119.516048] usb 2-2.1: SerialNumber:
BL049421
Mar 14 15:54:37 debian colord[662]: CdMain: failed to emit DeviceAdded:
failed to register object: An object is already exported for the
interface org.freedesktop.ColorManager.Device at
/org/freedesktop/ColorManager/devices/sysfs_bq_Aquaris_X_Pro
Mar 14 15:55:01 debian kernel: [ 9143.498984] usb 2-2.1: USB disconnect,
device number 6
Mar 14 15:55:01 debian kernel: [ 9143.795876] usb 2-2.1: new high-speed
USB device number 7 using xhci_hcd
Mar 14 15:55:01 debian kernel: [ 9143.904180] usb 2-2.1: New USB device
found, idVendor=2a47, idProduct=904d, bcdDevice= 3.18
Mar 14 15:55:01 debian kernel: [ 9143.904184] usb 2-2.1: New USB device
strings: Mfr=1, Product=2, SerialNumber=3
Mar 14 15:55:01 debian kernel: [ 9143.904186] usb 2-2.1: Product:
Aquaris X Pro
Mar 14 15:55:01 debian kernel: [ 9143.904188] usb 2-2.1: Manufacturer: bq
Mar 14 15:55:01 debian kernel: [ 9143.904190] usb 2-2.1: SerialNumber:
BL049421
Mar 14 15:55:01 debian colord[662]: CdMain: failed to emit DeviceAdded:
failed to register object: An object is already exported for the
interface org.freedesktop.ColorManager.Device at
/org/freedesktop/ColorManager/devices/sysfs_bq_Aquaris_X_Pro
Mar 14 15:55:01 debian mtp-probe: checking bus 2, device 7:
"/sys/devices/pci0000:00/0000:00:1c.2/0000:03:00.0/usb2/2-2/2-2.1"
Mar 14 15:55:01 debian mtp-probe: bus: 2, device: 7 was not an MTP device

Ich kann natürlich die Fotos auf eine SD Card und von dort auf den Pc
bringen, aber einfacher wäre es schon wenn es so wie unter Deb-Stretch
auch in Buster mit USB-Kabel ginge.

Freue mich schon auf Hilfe und bedanke mich schon sehr dafür im voraus!
Helge Reimer (14.03.2019, 18:50)
Am Donnerstag, 14. März 2019, 17:24:16 CET schrieb Siegfrid Brandstätter:

> Zusätzlich teile ich dem Handy auch noch mit das ich Fotos per PTP
> übertragen möchte.


Dann teile deinem Smartphone doch mit, dass du Fotos per MTP übertragen
möchtest.
Das passt dann auch hierzu:
Siegfrid Brandstätter (14.03.2019, 20:20)
Hallo Helge,
Am 14.03.19 um 16:49 schrieb Helge Reimer:
> Am Donnerstag, 14. März 2019, 17:24:16 CET schrieb Siegfrid Brandstätter:
>> Zusätzlich teile ich dem Handy auch noch mit das ich Fotos per PTP
>> übertragen möchte.

> Dann teile deinem Smartphone doch mit, dass du Fotos per MTP übertragen
> möchtest.
> Das passt dann auch hierzu:

Das kommt im Smartphone Dialog nicht vor. Aber wenn ich unter
Digikam/Importieren schaue kann ich auswählen zwischen Usb-PTP Class
Camera und BQ-Aquaris-X5 (MTP). Wähle ich dann zweites aus kommt :

"Fehler beim Verbinden mit der Kamera. Bitte überprüfen Sie, ob die
Kamera korrekt angeschlossen und eingeschaltet ist."

Wähle ich bq-Aquaris X Pro (autodedectet) kann ich nicht wie unter (MTP)
auf "herunterladen" klicken. Hilft zwar auch nichts, aber zumindest kann
man dort dies auswählen. Immerhin ein Schritt näher am Ziel.
Helge Reimer (14.03.2019, 20:50)
Am Donnerstag, 14. März 2019, 19:17:34 CET schrieb Siegfrid Brandstätter:

> Das kommt im Smartphone Dialog nicht vor. Aber wenn ich unter
> Digikam/Importieren schaue kann ich auswählen zwischen Usb-PTP Class
> Camera und BQ-Aquaris-X5 (MTP). Wähle ich dann zweites aus kommt :


Was sagt denn bei KDE Systemeinstellungen->Wechselmedien->Digitalkamera, wenn
dein Smartphone angestöpselt ist?
Siegfrid Brandstätter (14.03.2019, 21:30)
Am 14.03.19 um 18:47 schrieb Helge Reimer:
> Am Donnerstag, 14. März 2019, 19:17:34 CET schrieb Siegfrid Brandstätter:
>> Das kommt im Smartphone Dialog nicht vor. Aber wenn ich unter
>> Digikam/Importieren schaue kann ich auswählen zwischen Usb-PTP Class
>> Camera und BQ-Aquaris-X5 (MTP). Wähle ich dann zweites aus kommt :

> Was sagt denn bei KDE Systemeinstellungen->Wechselmedien->Digitalkamera, wenn
> dein Smartphone angestöpselt ist?


USB PTP Class Camera

nach "Testen" kommt:

Fehler beim Initialisieren der Kamera. Prüfen Sie die
Anschluss-Einstellungen sowie die Verbindung zur Kamera und versuchen
Sie es dann erneut.

Details:

Zeitüberschreitung beim Lesen oder Schreiben des Ports
Helge Reimer (14.03.2019, 22:00)
Am Donnerstag, 14. März 2019, 20:26:26 CET schrieb Siegfrid Brandstätter:

> USB PTP Class Camera


Das ist ja schon mal was.
Da es ja bisher ging kann man davon ausgehen, dass 'libgphoto2' installiert
ist?

> nach "Testen" kommt:
> Fehler beim Initialisieren der Kamera. Prüfen Sie die
> Anschluss-Einstellungen sowie die Verbindung zur Kamera und versuchen
> Sie es dann erneut.
> Details:
> Zeitüberschreitung beim Lesen oder Schreiben des Ports


Verschiedene USB-Ports hast du durchprobiert? Kabel ist in Ordnung?
Gerade mit den Kabeln hatte ich hier schon diverse Probleme.

Ich kann dir sonst noch 'kdeconnect' ans Herz legen. Das hat ein paar ziemlich
gute Funktionen.
Um viele Fotos zu übertragen ist das aber eher zu langsam,
Axel Richter (14.03.2019, 22:30)
Hallo, hast du nen Hub zwischen oder direkt verbunden?
Lies mal dort, vielleicht hilft das



Helge Reimer <hrnews> schrieb am Do., 14. März 2019, 20:55:
[..]
Siegfrid Brandstätter (14.03.2019, 23:20)
Hallo Axel,
Am 14.03.19 um 20:21 schrieb Axel Richter:
Siegfrid Brandstätter (14.03.2019, 23:20)
Am 14.03.19 um 19:55 schrieb Helge Reimer:
> Am Donnerstag, 14. März 2019, 20:26:26 CET schrieb Siegfrid Brandstätter:
> Das ist ja schon mal was.
> Da es ja bisher ging kann man davon ausgehen, dass 'libgphoto2' installiert
> ist?
> Verschiedene USB-Ports hast du durchprobiert? Kabel ist in Ordnung?
> Gerade mit den Kabeln hatte ich hier schon diverse Probleme.


Die Ports habe ich gewechselt, dass Kabel muss ich noch testen. Mal
schauen ob ich eins finde.

Danach versuche ich dann untenstehendes. Danke derweil!
H.-Stefan Neumeyer (14.03.2019, 23:20)
Siegfrid Brandstätter (14.03.2019, 23:30)
Hallo Stefan,
Am 14.03.19 um 21:15 schrieb H.-Stefan Neumeyer:
> apt-cache show mtp-tools


$ apt-cache show mtp-tools
Package: mtp-tools
Source: libmtp
Version: 1.1.16-2
Installed-Size: 357

~$ aptitude show mtp-tools
Paket: mtp-tools
Version: 1.1.16-2
Neu: ja
Zustand: nicht installiert

Das installieren hat aber leider auch nicht geholfen.
Siegfrid Brandstätter (15.03.2019, 13:00)
Hallo Axel,
Am 14.03.19 um 20:21 schrieb Axel Richter:
> Ich kann dir sonst noch 'kdeconnect' ans Herz legen. Das hat ein
> paar ziemlich
> gute Funktionen.
> Um viele Fotos zu übertragen ist das aber eher zu langsam,

Danke für den Tipp mit kdeconnect. Damit geht es nun. Kabel war auch OK.
Aber die USB.3 Ports gehen nicht, nur ein USB.2 Port funktioniert. Da
das Kabel und das Smartphone USB.3 sind hatte ich auch nur diese
versucht. War wohl ein Fehler. Aber unter Stretch ging es auch von einem
USB.3 Hub mit 4 Anschlüssen ohne Netzteil.

Herzlichen Dank an alle noch mals!
Richard Kraut (15.03.2019, 20:50)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Am Donnerstag, den 14.03.2019, 16:24 +0000 schrieb Siegfrid Brandstätter:

> Zusätzlich teile ich dem Handy auch noch mit das ich Fotos per PTP 
> übertragen möchte.


Nicht PTP. Du musst MTP wählen.

>    iManufacturer           1 bq
>    iProduct                2 Aquaris X Pro


Sollte doch funktionieren. Ich selber habe das direkte Nachfolgemodell. Das
Aquaris X2 Pro.

> Ich kann natürlich die Fotos auf eine SD Card und von dort auf den Pc 
> bringen, aber einfacher wäre es schon wenn es so wie unter Deb-Stretch 
> auch in Buster mit USB-Kabel ginge.


OK. Ich bin noch auf Stretch. Ergänzt mit Paketen aus deb-multimedia sowie den
Stretch-Backports.

Der Zugriff funktioniert hier. Getestet mit Thunar, pcmanfm sowie dolphin.

Ach ja. Mein Smartphone fragt nach, was man machen möchte, sobald man das
Gerät mit einem Rechner via USB verbindet. Hier hat man dann die Wahl zwischen
"Daten austauschen" oder so ähnlich oder "Nur laden". Der Button, welcher den
Zugriff gestattet ist der richtige. Also _nicht_ den "Nur laden"-Button.

- --
Siegfrid Brandstätter (15.03.2019, 21:40)
Hallo Richard,
Am 15.03.19 um 18:46 schrieb Richard Kraut:
[..]
> Gerät mit einem Rechner via USB verbindet. Hier hat man dann die Wahl zwischen
> "Daten austauschen" oder so ähnlich oder "Nur laden". Der Button, welcher den
> Zugriff gestattet ist der richtige. Also _nicht_ den "Nur laden"-Button.

Das ist bei mir auch so. Nun geht es zum Glück ja, ich glaube dass es
nur an der falschen USB-Buchse lag.
Ähnliche Themen