expertenaustausch > comp.hardware.* > comp.hardware.misc

Kay Martinen (08.06.2019, 13:28)
Hallo,

ich glaub ich schrieb schon mal zu dem Thema (hier). Bisher war es so
das sehr selten nach dem Aufwachen aus dem Tiefen Schlafmodus ALLE USB
Ports nicht mehr gingen und nur ein neustart; per Tastatur ausgelöst;
das Problem behob. An den insgesamt 3 Ports dieses FSC LIfebook E751
hängen nur eine Optische Maus und ein USB-Soundadapter (mit externen
Boxen die ihr eigenes Netzteil haben). Eine Portüberlastung nehme ich
daher nicht an. Das ALLE USB ports deaktiviert sind merke ich daran das
auch das interne Touchpad AUS ist und weder der Soundadapter seine Grüne
ON-Led zeigt noch die Maus ihr Rotes Licht an bekommt.

Jetzt das neue. Warum ich das nicht schon versuchte weiß ich auch nicht.

Ich habe den Deckel wieder zu geklappt und ihn wieder einschlafen
lassen. Ein paar sekunden gewartet und dann erneut durch Deckel hoch
klappen geweckt. Und; siehe da; alle Ports funktionieren wieder.

Das OS ist Windows 7 SP1 Professional. Daneben liegt noch ein Ubuntu das
ich aber derzeit kaum verwende und darum nicht sagen kann ob das dort
auch auf tritt.

Ich schließe daraus das dies ein nicht-statischer Fehler ist der mit dem
Aufwachen aus dem Schlafmodus zu tun hat.

Aber wie komme ich dem auf die Spur. Vor dem Aufwachen kann ich kaum ein
Programm laufen lassen (Schlafmodus) und danach könnte eines nur
feststellen DAS die Ports aus sind. Sie manuell zu wecken versuchte ich
schon erfolglos.

Wo mit kann ich da evtl. mehr erfahren was da im USB Bereich schief
lief? Kennt jemand ein (kostenloses) Programm das hier helfen kann?

Kay
Marcel Mueller (08.06.2019, 15:06)
Am 08.06.19 um 13:28 schrieb Kay Martinen:
> Eine Portüberlastung nehme ich
> daher nicht an. Das ALLE USB ports deaktiviert sind merke ich daran das
> auch das interne Touchpad AUS ist und weder der Soundadapter seine Grüne
> ON-Led zeigt noch die Maus ihr Rotes Licht an bekommt.


> Jetzt das neue. Warum ich das nicht schon versuchte weiß ich auch nicht.
> Ich habe den Deckel wieder zu geklappt und ihn wieder einschlafen
> lassen. Ein paar sekunden gewartet und dann erneut durch Deckel hoch
> klappen geweckt. Und; siehe da; alle Ports funktionieren wieder.
> Das OS ist Windows 7 SP1 Professional.


> Wo mit kann ich da evtl. mehr erfahren was da im USB Bereich schief
> lief? Kennt jemand ein (kostenloses) Programm das hier helfen kann?


Check mal das Windows-Event-Log. USB-Fehler werden darin protokolliert.

Marcel
Kay Martinen (08.06.2019, 19:52)
Am 08.06.2019 um 15:06 schrieb Marcel Mueller:
> Am 08.06.19 um 13:28 schrieb Kay Martinen:
> Check mal das Windows-Event-Log. USB-Fehler werden darin protokolliert.
> Marcel


Wenn dir das mehr sagt, hier ist der Relevante Ausschnitt aus dem System
log. Als Zitat um lange Zeilen zu erhalten.

-snip-
[..]
> Zeit im Energiesparmodus: ?2019?-?06?-?07T18:16:21.272273000Z
> Reaktivierungszeit: ?2019?-?06?-?07T18:16:20.784245100Z
> Reaktivierungsquelle: S4-Standbymodus in Ruhezustand"


-snap-

Host system error ist alles. Reichlich unspezifisch. Meldet denn der
EHCI Controller (HW) diesen Fehler, oder ist es nicht eher ein
EHCI-Controller-treiber der den Meldet? Das seltene Vorkommen könnte
dann doch auf ein gelegentliches Mißverstehen zwischen Treiber und HW
oder vage auf einen HW-Defekt hin deuten. Andere Möglichkeiten?

Kay
Marcel Mueller (09.06.2019, 21:47)
Am 08.06.19 um 19:52 schrieb Kay Martinen:
> Wenn dir das mehr sagt, hier ist der Relevante Ausschnitt aus dem System


>> Fehler 07.06.2019 21:01:40 usbehci 1 Keine Vom EHCI-Hostcontroller wurde ein Host System Error gemeldet.


Und hier fängt der Ärger an - bzw. hört auf. EHCI ist der USB-Controller.

[...]

> Host system error ist alles. Reichlich unspezifisch. Meldet denn der
> EHCI Controller (HW) diesen Fehler, oder ist es nicht eher ein
> EHCI-Controller-treiber der den Meldet?


Naja, am Ende kann immer nur ein Treiber etwas ins Event-Log schreiben
lassen. In der Sache ist es schon der Controller-Chip, der einen Fehler
diagnostiziert hat. Mutmaßlich Bit 4 im USB Statusregister.

> Das seltene Vorkommen könnte
> dann doch auf ein gelegentliches Mißverstehen zwischen Treiber und HW
> oder vage auf einen HW-Defekt hin deuten. Andere Möglichkeiten?


So ziemlich alles ist möglich. Auch eine defektes oder nicht
spezifikationsgemäßes USB-Device.

Marcel
Ähnliche Themen