expertenaustausch > linux.debian.user.german

Andreas Tille (26.04.2020, 10:20)
Hallo,

ich habe einen Lenovo T440s unter aktuellem Testing laufen. Früher war
mir das Mikrofon egal - aber in Zeiten wo Videokonferenzen wichtig sind
wird dieses auch wichtig. Leider bekomme ich das Teil nur mit einem
externen Headset zum Laufen. Allerdings würde ich es sehr gern haben,
daß auch mehrere Leute davorsitzen können und somit das Mikrofon nutzbar
ist.

Ich arbeite typischerweise unter Xfce und habe die Einstellungen per
pavucontrol aber auch pulsemixer geprüft. Das Mikrofon ist eingeschaltet
und wird benutzt - die Gegenstelle hört aber nichts. :-(

Jetzt habe ich mal versucht, ob Gnome irgendetwas geschickter macht.
Da gibt es ja so eine Anwendung Datenschutz -> Mikrofon, wo man das
Mikrofon ausschalten kann. Diese hat einen Eintrag:

Den nachfolgenden Anwendungen Zugriff auf Ihr Mikrofon erlauben.

Da steht leider

Es hat keine Anwendung um Mikrofonzugriff gebeten

Chromium mit Jitsi läuft aber und will eigentlich auf das Mikrofon
zugreifen.

Ein weiterer Versuch war

$ amixer set Capture cap
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 65951 [101%] [on]
Front Right: Capture 65951 [101%] [on]

was laut einer Anleitung, die ich gefunden habe[1] das Mikrofon
einschaltet. Da passiert aber auch nichts.

Ich habe auch mal

arecord -f cd - | lame -b 128 - test.mp3

versucht. Im Ergebnis habe ich leises Rauschen. Derweilen
hat auch die Gnome Mikrofon Anwendung nicht wahrgenomen, daß
eine Anwendung um Mikrofinzugriff bittet (siehe oben).

Ich habe den Verdacht, daß es mit apparmor zusammenhängt. Ich habe noch
nie irgendwas an apparmor gebastelt (weil nie Bedarf war). Auf einem
frisch installierten Laptop scheint das alles voreingestellt zu sein,
aber diesen habe ich vor X Jahren mal installiert und dann immer auf
dem aktuellen Testing gehalten - kann sein, daß da irgendwelche alten
Einstellungen rumhängen. Wenn die Vermutung richtig wäre, was müßte
ich tun?

Welche anderen Ideen gibt es?

Weitere Frage: Ich mache Videokonferenzen mit Jitsi unter Chromium.
Das scheint ganz schön Resourcen zu brauchen - der Lüfter geht gar nicht
mehr aus und das ganze saugt sehr stark am Akku (dank des Zusatzakkus
des T440s lief das Teil immer schön lange). Da werden scheinbar viele
Resourcen gebraucht. Kann man an irgendwelchen Einstellungen noch
was drehen?

Viele Grüße

Andreas.

[1]
Andreas Tille (26.04.2020, 12:00)
Hi nochmal,

ich habe noch mal meinen Gedanken verfolgt, daß apparmor mir da
einen Streich spielt und das hoffentlich per

sudo /etc/init.d/apparmor stop

erfolgreich abgestellt. Leider nimmt arecord immernoch nur ein Knistern
auf. Also es ändert sich nichts. :-( Ist am Ende einfach die Hardware
kaputt? Trotzdem wundert mich, daß unter Gnome keine Anforderung des
Mikrofons festgestellt wird.

Viele Grüße

Andreas.

On Sun, Apr 26, 2020 at 10:14:59AM +0200, Andreas Tille wrote:
[..]
Andreas Tille (26.04.2020, 12:00)
Hallo Jakob,

nur zum Verständnis: *Mit* Headset get es. Ich möchte aber *ohne*
als mit dem internen Mikrofon.

Vielen Dank, Andreas.

On Sun, Apr 26, 2020 at 10:55:19AM +0200, Jakob Schürz wrote:
[..]
Christian Knoke (26.04.2020, 12:30)
Andreas Tille schrieb am 26. Apr um 10:14 Uhr:
> Hallo,


> Ich arbeite typischerweise unter Xfce und habe die Einstellungen per
> pavucontrol aber auch pulsemixer geprüft. Das Mikrofon ist eingeschaltet
> und wird benutzt - die Gegenstelle hört aber nichts. :-(


> $ amixer set Capture cap
> Simple mixer control 'Capture',0
> Capabilities: cvolume cswitch cswitch-joined
> Capture channels: Front Left - Front Right
> Limits: Capture 0 - 65536
> Front Left: Capture 65951 [101%] [on]
> Front Right: Capture 65951 [101%] [on]


da würde ich weitermachen, und zwar mit alsamixer. Da kommen (bei mir) eine
Reihe von Einstellungen zum Vorschein, zum Beispiel "Mic Boost", "Mic
Select", mute (als MM angezeigt) und unmute (00).

Gruß
Christian
Andreas Tille (26.04.2020, 13:30)
On Sun, Apr 26, 2020 at 12:28:12PM +0200, Christian Knoke wrote:
> da würde ich weitermachen, und zwar mit alsamixer. Da kommen (bei mir) eine
> Reihe von Einstellungen zum Vorschein, zum Beispiel "Mic Boost", "Mic
> Select", mute (als MM angezeigt) und unmute (00).


Wenn ich in alsamixer auf F4 drücke (Aufnahme) dann sehe ich
erstmal nur "Aufnahme". Da ist alles auf 100% (genauer 101%
wie oben). Mit F6 kann ich die Soundkarte auswählen. Da
gibt es zwei Optionen:

HDA Intel HDMI

Das hat keine Aufnahmefunktion also wähle ich

HDA Intel PCH

Jetzt sehe ich auch "Mic Boost" etc wie von Dir geschrieben.
Ich setze alles hoch auf 100% und versuche erneute arecord.
Wieder nur Rauschen. :-(

Mit F5 kommt nun noch viel mehr zum Einstellen. Es ist alles
auf 100% bzw. OK. Trotzdem wird nichts aufgenommen.

Weitere Ideen?

Viele Grüße

Andreas.
Stefan Baur (26.04.2020, 13:50)
Am 26.04.20 um 10:55 schrieb Jakob Schürz:

> Ich habe hier Fedora 31 mit Chrome sowie Firefox mit Jitsi täglich im
> Einsatz. Das ganze über ein Bluetooth-Headset.


Anmerkung hierzu: Firefox mit Jitsi ist nur was für Leute, die auch auf
öffentlichen Klos danebenkacken - nämlich unsozial.

Es reicht *ein* Teilnehmer mit einem nicht-Chromium-basierten Browser,
damit *alle* Teilnehmer einer Jitsi-Konferenz unter schlechter
Performance leiden (CPU-Last und Bandbreite gehen durch die Decke).

Chromium, Chrome und Brave sind Mittel der Wahl, so lange man Jitsi
benutzt und Mozilla noch nicht die notwendigen Changes am Firefox-Code
vorgenommen hat (Jitsi-seitig ist mittlerweile alles vorbereitet,
Mozilla ist am Zug).

[...]

> Ein Kollege mit XFCE berichtete, dass anfänglich das Micro auf den
> Monitor des Micros eingestellt ist. Sobald er es auf das Micro selbst
> umstellt, klappt die Aufnahme.


Das ist nicht nur unter XFCE so.
Netterweise merkt sich Chromium die letzte Auswahl.

Gruß
Stefan
Christian Knoke (26.04.2020, 14:40)
Andreas Tille schrieb am 26. Apr um 13:25 Uhr:
> On Sun, Apr 26, 2020 at 12:28:12PM +0200, Christian Knoke wrote:


> Mit F5 kommt nun noch viel mehr zum Einstellen. Es ist alles
> auf 100% bzw. OK. Trotzdem wird nichts aufgenommen.


Das ist immer Fummelkram.

Eben ausprobiert, beim L580

$ arecord -f S32_LE -c 2 -r 48000 | aplay

im alsamixer muss der Capture Regler auf 100, und dann den "Digital" Regler
vorsichtig anheben. Die Boost Schalter und Regler tunlichst auf Null - das
Mikro ist hochwertig.

Nur im QASmixer sehe ich den Capture *Schalter* um ihn einzuschalten; mit
Mic Mode = Capture geht dann auch die LED an.

> Weitere Ideen?


Gruß
Christian
Jakobus Schürz (27.04.2020, 11:10)
Hast du da einen Bugreport dazu? Da muss es ja etwas geben. oder?

Am 26.04.20 um 13:39 schrieb Stefan Baur:
> Chromium, Chrome und Brave sind Mittel der Wahl, so lange man Jitsi
> benutzt und Mozilla noch nicht die notwendigen Changes am Firefox-Code
> vorgenommen hat (Jitsi-seitig ist mittlerweile alles vorbereitet,
> Mozilla ist am Zug).


lg jakob
Dirk Paul Finkeldey (27.04.2020, 12:20)
Am 27.04.20 um 11:08 schrieb Jakobus Schürz:
> Hast du da einen Bugreport dazu? Da muss es ja etwas geben. oder?


Nicht direkt Bugreport, aber gute Übersicht des Problems :

>


>


Gruß

Dirk
Andreas Tille (28.04.2020, 17:00)
On Sun, Apr 26, 2020 at 02:33:07PM +0200, Christian Knoke wrote:
> > Mit F5 kommt nun noch viel mehr zum Einstellen. Es ist alles
> > auf 100% bzw. OK. Trotzdem wird nichts aufgenommen.

> Das ist immer Fummelkram.


Offensichtlich.

> Eben ausprobiert, beim L580
> $ arecord -f S32_LE -c 2 -r 48000 | aplay
> im alsamixer muss der Capture Regler auf 100, und dann den "Digital" Regler
> vorsichtig anheben. Die Boost Schalter und Regler tunlichst auf Null - das
> Mikro ist hochwertig.
> Nur im QASmixer sehe ich den Capture *Schalter* um ihn einzuschalten; mit
> Mic Mode = Capture geht dann auch die LED an.


OK, QASmixer sieht auf jeden Fall gut aus. Allerdings bekomme ich auch
damit bei arecord | aplay wirklich nur rauschen. Ich kann sehr schön
steuern, ob es links oder rechts rauscht, indem ich das linke oder rechte
Mikrofon ein oder ausschalte. Aber es rauscht halt nur.

Ich tendiere dazu, mir ein externes Mikrofon zuzulegen. :-(

Vielen Dank trotzdem für die Hilfe

Andreas.
Ähnliche Themen