expertenaustausch > linux.debian.user.german

Andreas Tille (04.04.2014, 15:00)
Hallo,

ich bin mit dem VServer, von dem aus ich meine Mails per mutt verschicke
zu einem anderen Provider umgezogen. Nun habe ich festgestellt, daß
GMail - zum Test hier an meine eigene Adresse geschickt - Mails zurückweist,
wenn ich das From-Feld in Mutt z.B. auf <tille> geändert habe.
Wenn ich es auf <andreas> lasse, dann geht die Mail durch.

Ich habe den Eindruck, daß ich noch irgendwas an meinem Mailserver
konfigurieren muß, damit die Mails sauber durchgehen.

Im übrigen bin ich auch dem Link gefolgt der in der Meldung steht und
habe versucht SPF laut[1] zu setzen (OK, für debian.org kann ich das
nicht, aber für fam-tille.de, wo das Problem identisch besteht, kann ich
das - aber es hat auch nicht geholfen.

Gibt es irgendwelche Hinweise, wie ich meine Mails sicher zustellen lassen
kann?

Viele Grüße

Andreas.

[1]

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

tillea
SMTP error from remote mail server after end of data:
host gmail-smtp-in.l.google.com [2a00:1450:4013:c00::1b]:
550-5.7.1 [2a01:4f8:d12:5c0::2 12] Our system has detected that this
550-5.7.1 message is likely unsolicited mail. To reduce the amount of spam sent
550-5.7.1 to Gmail, this message has been blocked. Please visit
550-5.7.1 for
550 5.7.1 more information. 45si12024188eeh.333 - gsmtp

------ This is a copy of the message, including all the headers. ------

Return-path: <tille>
Received: from andreas by mail.an3as.eu with local (Exim 4.80)
(envelope-from <tille>)
id 1WW2jI-0006GZ-DL
for tillea; Fri, 04 Apr 2014 13:56:16 +0200
Date: Fri, 4 Apr 2014 13:56:16 +0200
From: Andreas Tille <tille>
To: tillea
Subject: Ping
Message-ID: <20140404115616.GE23527>
References: <20140404113347.GC23527>
<20140404115503.GD23527>
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: 8bit
In-Reply-To: <20140404115503.GD23527>
User-Agent: Mutt/1.5.21 (2010-09-15)

Test
Heiko Schlittermann (04.04.2014, 15:20)
Hallo,

Andreas Tille <andreas> (Fr 04 Apr 2014 14:10:14 CEST):
> Hallo,
> ich bin mit dem VServer, von dem aus ich meine Mails per mutt verschicke
> zu einem anderen Provider umgezogen. Nun habe ich festgestellt, daß
> GMail - zum Test hier an meine eigene Adresse geschickt - Mails zurückweist,
> wenn ich das From-Feld in Mutt z.B. auf <tille> geändert habe.
> Wenn ich es auf <andreas> lasse, dann geht die Mail durch.


debian.org verwendet m.W. kein SPF. Es müssen andere Gründe sein,die
GMail zur Ablenhnung bringen.

Die Ablehnung nach DATA indiziert auch, dass es nichts mit SPF zu tun
hat, denn das könnte man vorher beim MAIL-FROM bzw. RCPT-TO schon
geklärt haben.

Möglicherweise analyisieren die dort sehr genau die Header und da taucht
an3as.eu deutlich öfter auf als fam-tille.de oder debian.org.

Versuche doch mal, den Envelope-From bei an3as.eu zu belassen, nur die
From:-Zeile auf etwas zu setzen, was Dir angenehm ist.

Möglicherweise liegt es auch an anderen inhaltlichen Dingen, denn es
steht zum Zeitpunkt der Ablehnung ja die komplette Message zur
Verfügung?

Im übrigen nimmt GMAIL mir eine Mail an Dich ab:

=== Trying gmail-smtp-in.l.google.com:25...
=== Connected to gmail-smtp-in.l.google.com.
<- 220 mx.google.com ESMTP 43si12358218eer.87 - gsmtp
-> EHLO pu.schlittermann.de
<- 250-mx.google.com at your service, [212.80.235.130]
<- 250-SIZE 35882577
<- 250-8BITMIME
<- 250-STARTTLS
<- 250-ENHANCEDSTATUSCODES
<- 250-PIPELINING
<- 250 CHUNKING
-> MAIL FROM:<tille>
<- 250 2.1.0 OK 43si12358218eer.87 - gsmtp
-> RCPT TO:<tillea>
<- 250 2.1.5 OK 43si12358218eer.87 - gsmtp
-> DATA
<- 354 Go ahead 43si12358218eer.87 - gsmtp
-> Date: Fri, 04 Apr 2014 15:16:47 +0200
-> To: tillea
-> From: tille
-> Subject: test Fri, 04 Apr 2014 15:16:47 +0200
-> X-Mailer: swaks v20120320.0 jetmore.org/john/code/swaks/
->
-> This is a test mailing
->
-> .
<- 250 2.0.0 OK 1396617408 43si12358218eer.87 - gsmtp
-> QUIT
<- 221 2.0.0 closing connection 43si12358218eer.87 - gsmtp

Best regards from Dresden/Germany
Viele Grüße aus Dresden
Heiko Schlittermann
Andreas Tille (04.04.2014, 15:40)
Hallo Heiko,

On Fri, Apr 04, 2014 at 03:18:26PM +0200, Heiko Schlittermann wrote:
> Hallo,
> Andreas Tille <andreas> (Fr 04 Apr 2014 14:10:14 CEST):
> debian.org verwendet m.W. kein SPF. Es müssen andere Gründe sein, die
> GMail zur Ablenhnung bringen.


Wahrscheinlich. Auf meinem GMail account ging auch folgendes ein:

Von: tille
An: tillea
Datum: 4. April 2014 15:16
Betreff: test Fri, 04 Apr 2014 15:16:47 +0200

.... schätze mal, das war Dein Test (und lese das auch so unten). :-)

> Die Ablehnung nach DATA indiziert auch, dass es nichts mit SPF zu tun
> hat, denn das könnte man vorher beim MAIL-FROM bzw. RCPT-TO schon
> geklärt haben.
> Möglicherweise analyisieren die dort sehr genau die Header und da taucht
> an3as.eu deutlich öfter auf als fam-tille.de oder debian.org.


Das ist richtig ... hat aber so auch von dem alten Mailhost funktioniert
(und funktioniert auch immernoch).

> Versuche doch mal, den Envelope-From bei an3as.eu zu belassen, nur die
> From:-Zeile auf etwas zu setzen, was Dir angenehm ist.


Wie genau macht man das? Ich habe in Mutt einfach

<Esc> f

eingegeben und dann den Absender verändert. Ansonsten habe ich noch
sowas in der .muttrc probiert:

send-hook '~t tillea$' 'my_hdr From: Andreas Tille <tille>'

Das Ergebnis ist identisch.

[..]
> <- 250 2.0.0 OK 1396617408 43si12358218eer.87 - gsmtp
> -> QUIT
> <- 221 2.0.0 closing connection 43si12358218eer.87 - gsmtp


Offensichtlich (siehe oben).

Wie kriege ich die Logfiles so ausführlich ... oder hast Du das in
telnet eingetippt?

Viele Grüße

Andreas.
Manfred Schmitt (04.04.2014, 16:30)
Andreas Tille schrieb:
> Gibt es irgendwelche Hinweise, wie ich meine Mails sicher zustellen lassen
> kann?
> SMTP error from remote mail server after end of data:
> host gmail-smtp-in.l.google.com [2a00:1450:4013:c00::1b]:
> 550-5.7.1 [2a01:4f8:d12:5c0::2 12] Our system has detected that this

Die IP 2a01:4f8:d12:5c0::2 hat keinen Reverse-DNS Eintrag.
Und die als Reverse-DNS angegebene Domain der IPv4-IP hat wiederum
keinen A-Record und passt somit auch nicht zum hostname mit dem sich
der smtpd meldet. Das ist hier aber vermutlich eher nicht das Problem
da der connect ja ueber IPv6 stattfindet.
Insgesamt ist die Meldung von gmail ja ziemlich unspezifisch ;-/
Z.B. freenet mag einen fehlenden Reverse-DNS aber auch nicht, das hatte
ich gerade letztens auch bei IPv6. Da war die Rueckmeldung aber hilfreich.

Und wech,
Manne
Heiko Schlittermann (04.04.2014, 16:50)
Andreas Tille <andreas> (Fr 04 Apr 2014 15:37:54 CEST):
> On Fri, Apr 04, 2014 at 03:18:26PM +0200, Heiko Schlittermann wrote:

?
> ... schätze mal, das war Dein Test (und lese das auch so unten). :-)
> Das ist richtig ... hat aber so auch von dem alten Mailhost funktioniert
> (und funktioniert auch immernoch).


Das in einer anderen Mail erwähnte Reverse-DNS-Problem könnte aber
eigentlich auch schon beim MAIL-FROM, RCPT-TO zur Ablehnung führen. Nun
kenne ich deren Mechanismen nicht genau, ob einfach alles erst nach
einem Inhaltscheck in die große Waage geworfen wird und da kommt dann
die Ablehnung, oder auch nicht. (Und man kann ja auch unterstellen, das
man dort sogar am Spam interessiert ist, weil der ja wieder die Filter
anlernen kann, wenn ich vermeintlichen Spam wegen irgendwelcher
Kleinigkeiten beim RCPT-To ablehne, kann ich ihn nicht analysieren.)

> Wie genau macht man das? Ich habe in Mutt einfach
> <Esc> f
> eingegeben und dann den Absender verändert. Ansonsten habe ich noch
> sowas in der .muttrc probiert:
> send-hook '~t tillea$' 'my_hdr From: Andreas Tille <tille>'


Dein Mutt wird an irgend einen MTA übergeben (submitten). Wenn das ein
Exim ist, erlaubt der sich, den Absender (nicht die From:-Zeile) zu
korrigieren, je nachdem, wie er konfiguriert ist und wie sicher er sich
ist, daß er den Absender wirklich identifizieren kann. Bei einer PIPE
ist das der Fall, und bei SMTP-Auth geht er auch davon aus, dass er das
kann.

> > Im übrigen nimmt GMAIL mir eine Mail an Dich ab:
> > === Trying gmail-smtp-in.l.google.com:25...
> > === Connected to gmail-smtp-in.l.google.com.

?
> Wie kriege ich die Logfiles so ausführlich ... oder hast Du das in
> telnet eingetippt?


Nee, ich habe ?swaks ?? eingetippt. Das Schweizer Offiziersmesser für
SMTP :)

Best regards from Dresden/Germany
Viele Grüße aus Dresden
Heiko Schlittermann
Andreas Tille (06.04.2014, 09:10)
Hi Manfred,

On Fri, Apr 04, 2014 at 04:08:35PM +0200, Manfred Schmitt wrote:
> Andreas Tille schrieb:
> Die IP 2a01:4f8:d12:5c0::2 hat keinen Reverse-DNS Eintrag.


Wie kann ich den setzen? Das Problem hat sich nämlich insofern
verschärft, daß ich die Domain nun auch zum neuen Provider umgezogen
habe und nun von gar keiner Adressen mehr an gmail posten kann.

> Und die als Reverse-DNS angegebene Domain der IPv4-IP hat wiederum
> keinen A-Record und passt somit auch nicht zum hostname mit dem sich
> der smtpd meldet. Das ist hier aber vermutlich eher nicht das Problem
> da der connect ja ueber IPv6 stattfindet.


Aber lösen würde ich das ganze trotzdem - wer weiß, wo das sonst noch
Probleme aufwirft.

> Insgesamt ist die Meldung von gmail ja ziemlich unspezifisch ;-/
> Z.B. freenet mag einen fehlenden Reverse-DNS aber auch nicht, das hatte
> ich gerade letztens auch bei IPv6. Da war die Rueckmeldung aber hilfreich.


Ich kann mir guit vorstellen, daß es an dem reverse DNS liegt - was muß
ich also tun, um das zu korrigieren?

Viele Grüße

Andreas.
Ulf Volmer (06.04.2014, 10:50)
On Sun, Apr 06, 2014 at 09:09:05AM +0200, Andreas Tille wrote:
> On Fri, Apr 04, 2014 at 04:08:35PM +0200, Manfred Schmitt wrote:


> > Die IP 2a01:4f8:d12:5c0::2 hat keinen Reverse-DNS Eintrag.

> Wie kann ich den setzen? Das Problem hat sich nämlich insofern
> verschärft, daß ich die Domain nun auch zum neuen Provider umgezogen
> habe und nun von gar keiner Adressen mehr an gmail posten kann.


Bei Hetzner geht das wie folgt:

-> IPs -> Subnetze -> neuen
Reverse- DNS- Eintrag anlegen.

Gruß
Ulf
Andreas Tille (06.04.2014, 18:10)
Hallo Ulf,

On Sun, Apr 06, 2014 at 10:41:13AM +0200, Ulf Volmer wrote:
> On Sun, Apr 06, 2014 at 09:09:05AM +0200, Andreas Tille wrote:
> Bei Hetzner geht das wie folgt:
> -> IPs -> Subnetze -> neuen
> Reverse- DNS- Eintrag anlegen.


OK, habe ich gemacht. Es sieht so aus, als könne ich nur für IPv6
Adressen einen Reverse-DNS-Eintrag anlegen und dann auch nur für eine
Domain. Wie kann ich denn prüfen, ob das funktioniert hat?

Weitere Frage, was mich nachdenklich stimmt:

$ ping an3as.eu
PING an3as.eu (78.47.240.169) 56(84) bytes of data.
64 bytes from cosmodrom.andreas-tille.eu (78.47.240.169): icmp_seq=1 ttl=51 time=121 ms
64 bytes from cosmodrom.andreas-tille.eu (78.47.240.169): icmp_seq=2 ttl=51 time=91.8 ms
^C
--- an3as.eu ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 91.871/106.537/121.203/14.666 ms
andreas@energija:~ $ ping6 an3as.eu
unknown host

Im Zone file steht auch nur

@ IN A 78.47.240.169
localhost IN A 127.0.0.1
mail IN A 78.47.240.169
www IN A 78.47.110.122

drin. Wie spezifiziert man zusätzlich die IPv6 Adressen?

Viele Grüße

Andreas.
Sven Hartge (06.04.2014, 18:20)
Andreas Tille <andreas> wrote:

> Im Zone file steht auch nur


> @ IN A 78.47.240.169
> localhost IN A 127.0.0.1
> mail IN A 78.47.240.169
> www IN A 78.47.110.122


> drin. Wie spezifiziert man zusätzlich die IPv6 Adressen?


Google?

www IN AAAA 2001:dead:beef::affe

Heiko Schlittermann (06.04.2014, 23:20)
Andreas Tille <andreas> (So 06 Apr 2014 18:08:30 CEST):
[..]
> mail IN A 78.47.240.169
> www IN A 78.47.110.122
> drin. Wie spezifiziert man zusätzlich die IPv6 Adressen?


Was würde das mit einem PTR-Eintrag zu tun haben? Wenn ich Dich richtig
verstanden habe, möchtest Du einen reverse Eintrag für 78.47.240.169
und 2a01:4f8:d12:5c0::2 machen.

Beide sind schon existent und sind PTR nach an3as.eu
Und ja, zum PTR von 2a01:4f8:d12:5c0::2 solltest Du noch einen AAAA
Record anlegen.
Andreas Tille (07.04.2014, 08:30)
Moin Heiko,

On Sun, Apr 06, 2014 at 11:10:36PM +0200, Heiko Schlittermann wrote:
> Was würde das mit einem PTR-Eintrag zu tun haben? Wenn ich Dich richtig
> verstanden habe, möchtest Du einen reverse Eintrag für 78.47.240.169
> und 2a01:4f8:d12:5c0::2 machen.


Ich denke mal, daß das Fehlen eine der möglichen Ursachen sein könnte,
daß Google meine Mails (immernoch :-() abweist.

> Beide sind schon existent und sind PTR nach an3as.eu
> Und ja, zum PTR von 2a01:4f8:d12:5c0::2 solltest Du noch einen AAAA
> Record anlegen.


Das sieht jetzt so aus:

@ IN A 78.47.240.169
localhost IN A 127.0.0.1
mail IN A 78.47.240.169
@ IN AAAA 2a01:4f8:d12:5c0::2
mail IN AAAA 2a01:4f8:d12:5c0::2

Leider werden wie gesagt die Mails immernoch abgewiesen. Ob es generell
an IPv6 liegt? Auf dem alten Rechner war IPv6 nicht aktiviert und dort
funktioniert es nach wie vor.

Viele Grüße

Andreas.
Manfred Schmitt (07.04.2014, 16:20)
Andreas Tille schrieb:

> > > andreas@energija:~ $ ping6 an3as.eu
> > > unknown host

Klappt:
# ping6 an3as.eu
PING an3as.eu(an3as.eu) 56 data bytes
64 bytes from an3as.eu: icmp_seq=1 ttl=58 time=1.73 ms
64 bytes from an3as.eu: icmp_seq=2 ttl=58 time=0.551 ms
^C
--- an3as.eu ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms

Und das ist gleich nebenan ;-)
Hast Du es von einem Rechner probiert der keine IPv6-Anbindung hat?
> Leider werden wie gesagt die Mails immernoch abgewiesen. Ob es generell
> an IPv6 liegt? Auf dem alten Rechner war IPv6 nicht aktiviert und dort
> funktioniert es nach wie vor.

Keine Ahnung wie streng google ist:
Dein mailserver meldet sich ja als mail.an3as.eu
Aber:
$ host mail.an3as.eu
mail.an3as.eu has address 78.47.240.169
mail.an3as.eu has IPv6 address 2a01:4f8:d12:5c0::2
$ host 2a01:4f8:d12:5c0::2
2.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.c.5.0.2.1.d.0.8. f.4.0.1.0.a.2.ip6.arpa domain name pointer an3as.eu.

Warum nutzt Du eine eigene domain mail.an3as.eu wenn das gar kein
eigener Rechner bzw. IP ist sondern letztlich dann doch an3as.eu?
Fuer http:// kann man wild (sub)domains mit der selben IP einrichten,
bei mail ist das aber imo nicht unbedingt sinnvoll.

Welchen MTA nutzt Du?
Z.B. in postfix kann man IPv6 auch abschalten bzw. erst IPv4 probieren
wenn man unbedingt will:


Letztlich waere das aber ja auch nur ein workaround und ob Gmail die mail
dann annimmt steht ja auch in den Sternen. Einen Versuch, um das Problem
einzugrenzen, waere es aber vielleicht wert.
Aeh, sehe gerade bei Dir laeuft Exim.
Da geht das bestimmt auch rate ich mal.

Nochmal zurueck zum Anfang: Zumindest im ersten Post war es ja so das Du
mit envelope-from <tille> gesendest hast, dann liest es sich
eigentlich doch eher als ob Gmail das mit Regeln bzgl. "mail forwarding"
(die keiner ausserhalb google genau kennt) abarbeitet?


Deswegen hattest Du ja vermutlich SPF-Records gesetzt.
Wenn man SPF nutzt will man aber auch SRS:


Hm, mittlerweile hast Du SPF aber ja auch wieder geloescht.

Uebrigens meint mxtoolbox das Dein server (aktuell?) lahm ist:


Zumindest bei der google-Suche ist die Antwortzeit ja ein Ranking-Kriterium...

So, genug spekuliert,
und wech,
Manne
Andreas Tille (07.04.2014, 21:50)
Hi Manfred,

On Mon, Apr 07, 2014 at 03:56:04PM +0200, Manfred Schmitt wrote:
> Andreas Tille schrieb:
> Klappt:
> # ping6 an3as.eu
> PING an3as.eu(an3as.eu) 56 data bytes
> 64 bytes from an3as.eu: icmp_seq=1 ttl=58 time=1.73 ms
> 64 bytes from an3as.eu: icmp_seq=2 ttl=58 time=0.551 ms
> ^C
> --- an3as.eu ping statistics ---
> 2 packets transmitted, 2 received, 0% packet loss, time 1001ms
> Und das ist gleich nebenan ;-)


:-)

> Hast Du es von einem Rechner probiert der keine IPv6-Anbindung hat?


Ich habe den Rechner von Gandi, wo nur IP konfiguriert war, zu Hetzner
umgezogen, wo IPv6 konfiguriert ist. Ich hatte bisher keinen Grund,
das zu ändern - allerdings habe ich den Verdacht, daß es daran liegen
könnte.

> Keine Ahnung wie streng google ist:
> Dein mailserver meldet sich ja als mail.an3as.eu
> Aber:
> $ host mail.an3as.eu
> mail.an3as.eu has address 78.47.240.169
> mail.an3as.eu has IPv6 address 2a01:4f8:d12:5c0::2
> $ host 2a01:4f8:d12:5c0::2
> 2.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.c.5.0.2.1.d.0.8. f.4.0.1.0.a.2.ip6.arpa domain name pointer an3as.eu.
> Warum nutzt Du eine eigene domain mail.an3as.eu wenn das gar kein
> eigener Rechner bzw. IP ist sondern letztlich dann doch an3as.eu?


Ich hatte diese Domain mal angelegt, um von hier aus Mails zu senden.
Ein Web-Auftritt hat sich historisch nicht ergeben.

> Fuer http:// kann man wild (sub)domains mit der selben IP einrichten,
> bei mail ist das aber imo nicht unbedingt sinnvoll.


mail.an3as.eu soll je keine Subdomain sein - es doch nur der Hostname,
der die Mail ausliefert. Oder ist das Blödsinn?

> Welchen MTA nutzt Du?


Exim4 - so wie bei Wheezy die default-Installation.

> Z.B. in postfix kann man IPv6 auch abschalten bzw. erst IPv4 probieren
> wenn man unbedingt will:
>


Ich bin bezüglich des MTA vollkommen leidenschaftslos. Bisher hat exim4
immer klaglos funktioniert und ich hatte keinen Anlaß da irgendwas zu
ändern.

> Letztlich waere das aber ja auch nur ein workaround und ob Gmail die mail
> dann annimmt steht ja auch in den Sternen. Einen Versuch, um das Problem
> einzugrenzen, waere es aber vielleicht wert.
> Aeh, sehe gerade bei Dir laeuft Exim.
> Da geht das bestimmt auch rate ich mal.


Vermutlich. Ich könnte auch gleich das IPv6 Interface stillegen - dann
sollte ja automatisch IP genutzt werden. Das fände ich allerdings
"feige".

> Nochmal zurueck zum Anfang: Zumindest im ersten Post war es ja so das Du
> mit envelope-from <tille> gesendest hast, dann liest es sich
> eigentlich doch eher als ob Gmail das mit Regeln bzgl. "mail forwarding"
> (die keiner ausserhalb google genau kennt) abarbeitet?
>


Das hat sich nunmehr geändert, seit ich die Domain zu Hetzner komplett
umgezogen habe. Jetzt ist das Problem vollkommen unabhängig von dem per
Mutt eingestellten Absender.

> Deswegen hattest Du ja vermutlich SPF-Records gesetzt.
> Wenn man SPF nutzt will man aber auch SRS:
>


Ja, das hat gar nichts gebracht.

> Hm, mittlerweile hast Du SPF aber ja auch wieder geloescht.


Weil es nichts brachte und weil debian.org auch keine SPF gesetzt hat
(laut Heiko) und es damit einwandfrei funktioniert. Ich habe ja
mittlerweile auch festgestellt, daß der alte Rechner, der noch bei
Gandi läuft, nach wie vor problemlos alle Mails mit welchem Absender
auch immer verschicken kann - vollkommen unabhängig von SPF.

> Uebrigens meint mxtoolbox das Dein server (aktuell?) lahm ist:
>


Das ist ja eine coole Seite. Mal abgesehen von dem aktuellen
Problem, muß ich mir wohl mal

Warning - Does not support TLS.

ansehen.

Mit "lahm" meinst Du wohl die beiden Warnungen hinsichtlich Connection /
Transaction time? Ist das relevant? Für drei Leute, die darüber ihre
Mail abwickeln wohl eher nicht, denke ich mal.

> Zumindest bei der google-Suche ist die Antwortzeit ja ein Ranking-Kriterium...


Ich habe diese Adresse im wesentlichen, um hierüber meine
Mailinglistenaktivitäten von anderen Mails zu trennen. Bisher war
das immer schnell genug und ich brauche keine Ranking-Wettbewerbe
zu gewinnen.

> So, genug spekuliert,


Danke für die hilfreichen Anregungen

Andreas.
Andreas Tille (08.04.2014, 14:50)
Hi,

On Mon, Apr 07, 2014 at 09:40:23PM +0200, Andreas Tille wrote:
> Vermutlich. Ich könnte auch gleich das IPv6 Interface stillegen - dann
> sollte ja automatisch IP genutzt werden. Das fände ich allerdings
> "feige".


weil ich nun endlich wieder normals Mails senden möchte, auch an GMail
Adressen, war ich nun doch feige und habe per

$ cat /etc/sysctl.d/90-no-ipv6.conf
# Disable IPv6
net.ipv6.conf.all.disable_ipv6 = 1

IPv6 global abgeschaltet (der Rechner soll eh nur Mails senden). Zwar
gibt es laut Exim-Handbuch auch die Option 'disable_ipv6 = true' aber
irgendwie habe ich das nicht richig in die configs geschrieben -
jedenfalls produzierte update-exim.conf immer Fehler.

Jetzt kann ich wieder so wie immer Mails an gmail Adressen schicken,
habe aber offensichtlich keinen Fortschritt für IPv6 erreicht.

Kann jemand die Erkenntnis verifizieren, daß GMail Mails die mit
IPv6 verschickt werden, einfach abweist?

Viele Grüße

Andreas.
Florian Schaal (08.04.2014, 17:00)
> Kann jemand die Erkenntnis verifizieren, daß GMail Mails die mit
> IPv6 verschickt werden, einfach abweist?


Jein. Das passiert insbesondere dann, wenn dein PTR-Record nicht stimmt.
Wenn Du nciht selbst setzen kannst oder dein Anbieter das nicht machen
will, kannst Du auch nur für google IPv4 nehmen und für andere
Mailserver IPv6 und IPv4

Gruß
Florian

Ähnliche Themen