expertenaustausch > linux.debian.user.german

Andreas Tille (10.03.2020, 22:40)
Hallo,

ich habe einen IdeaPad S340 AMD Ryzen 5 und

02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

frisch mit Debian 10 aufgesetzt. Mit firmware-atheros auf einem Stick
bei der Installation ging das gut. Ich hatte mich (aus guten Gründen)
für LXDE entschieden. Da ist als Netzwerkmanager wicd standardmäßig
dabei (keine Ahnung warum ich glaube der hat (wie immer) nicht
funktioniert.) Ich habe ihn sofort durch network-manager ersetzt -
aber der zeigte auch kein einziges der hier in der Gegend verfügbaren
WLANs an. :-(

Mit Hand kann ich das WLAN konfigurieren, sprich in eine Datei
/etc/network/interfaces.d/wlp2s0 angelegt und dort

allow-hotplug wlp2s0
auto wlp2s0
iface wlp2s0 inet dhcp
wpa-ssid netzwerk
wpa-psk passwort

reingeschrieben. Dann

ifdown wlp2s0

(das muß ich vorher machen, wenn ich gleich ifup sage, kommt

ifup: interface wlp2s0 already configured

und

ifup wlp2s0

Danach wird per DHCPDISCOVER per DHCP eine IP-Adresse zugewiesen.

Zu bemerken ist auch beim Hochfahren, daß es bei der Initialisierung der
Netzwerks irgendwie nicht vorangeht und etwa eine knappe Minute die
Netzwerkinitialisierung versucht wird.

Wo kann ich nachsehen, an welcher Stelle hier die Säge klemmt. Probleme
mit dem WLAN gehörten seit network-manager immer der Vergangenheit an.

Viele Grüße

Andreas.
Christoph Schmees (10.03.2020, 23:10)
Hi Andreas,

auf meinem guten (!) alten (!) X220 mit Mint 19 hatte ich ein ähnliches Problem.
Sporadisch zeigte der NetworkManager an, das WLAN-Gerät sei nicht betriebsbereit - was nicht stimmt.
Erst dachte ich, es sit die HW, aber auch mit einem gepatchten BIOS (damites alle WLAN-Karten annimmt ...) und einer neuen WLAN-Karte hatte ich immer wieder diese Störungen.
Nach etlicher Recherche kam ich schließlich auf die Möglichkeit,dass AppArmor dazwischen hauen könnte.
Dann habe ich, einem Tipp folgend, etwas an der Konfiguration von AppArmorgeändert, und seitdem läuft es rund!
Was ich gemacht habe, weiß ich leider nicht mehr. Auch den Link kann ich gerade nicht finden. Aber wenn du die Suchmaschine deines geringsten Misstrauens (also duckduckgo oder startpage) damit fütterst, findest du bestimmt etwas.

hth, Christoph
Ähnliche Themen