expertenaustausch > comp.hardware.* > comp.hardware.netzwerke.wireless

Andreas Kohlbach (11.03.2020, 13:54)
On Tue, 10 Mar 2020 17:37:46 +0100, Jörg Tewes wrote:
> Andreas Kohlbach schrieb:
> Da bekomme ich keine Verbindung zu irgendeiner Seite.


47.241.34.233:8080 funktioniert für mich gerade. Aber es ist ein
Glücksspiel, ob die auch in ein paar Minuten noch funktionieren wird.
Kay Martinen (12.03.2020, 11:42)
Am 07.03.20 um 20:25 schrieb Gerald E:scher:
> Ulf Volmer schrieb am 7/3/2020 19:19:
> -77 dBm Leistungspegel bei nur 5 m Entfernung sind ziemlich schwach.
> Um die -60 dBm könnte man erwarten, vielleicht auch mehr.


Ich hab jetzt einen Externen Adapter. Mit dem erreiche ich hier das:

[..]
> Retry short limit:7 RTS thr:off Fragment thr:off
> Encryption key:off
> Power Management:off


Der untere ist intern und aus. Witzig dabei. Die WLAN-Taste am Laptop
muß an bleiben, sonst funktioniert der externe Adapter auch nicht.

Das ist jetzt mit der Rundstrahlantenne. Die mitbestellte Richtantenne
bringt kaum bessere Werte. Und, ich muß sie immer wieder nachführen wenn
ich das Gerät bewege.

Die Antwortzeiten von Webseiten sind aber jetzt auch besser geworden.

Und, Gestern hatte ich; bei ähnlich guter Verbindung; trotzdem 1-2 mal
einen Rauswurf, mit anschließendem Neustart des Interfaces.

Daraus schließe ich: Das Rauswerfen muß (auch?) andere Gründe haben?

Ich werd mal journalctl nebenher laufen lassen.

Weiß jemand ob es irgendwo (NM, Kernel, ???) einen Trigger/Event gibt
bei Verbindungsabbruch? Dann könnte ich mich da evtl. ein klinken und
journalctl, iwconfig und evtl. syslog parallel beobachten um es dann
nach fehlern zu durchsuchen.

Kay
Gerald E:scher (12.03.2020, 16:00)
Kay Martinen schrieb am 12/3/2020 10:42:

> Am 07.03.20 um 20:25 schrieb Gerald E:scher:
> Ich hab jetzt einen Externen Adapter. Mit dem erreiche ich hier das:


Der Leistungspegel wird leider nicht wie beim internen WLAN-Modul in
dBm sondern als Relativwert angegeben. Keine Ahnung, wie die
vergleichbar sind, "man ifconfig" schreibt nicht viel dazu.

> Der untere ist intern und aus. Witzig dabei. Die WLAN-Taste am Laptop
> muß an bleiben, sonst funktioniert der externe Adapter auch nicht.


Die WLAN-Taste triggert bei Ubuntu einfach ein Skript, das WLAN ein-
und ausschaltet, jedenfalls war das zu Zeiten meines EeePC so. Das
Script behandelt anscheinend interne und exerne Adapter gleich.

> Das ist jetzt mit der Rundstrahlantenne. Die mitbestellte Richtantenne
> bringt kaum bessere Werte. Und, ich muß sie immer wieder nachführen wenn
> ich das Gerät bewege.


Die Richtantenne taugt nicht viel, wenn es keine Verbesserung im
Vergleich zur Rundstrahlantenne gibt.

> Die Antwortzeiten von Webseiten sind aber jetzt auch besser geworden.


Dass der USB-Adapter mit seiner einfachen Antenne eine höhere
Übertrageunsrate liefert, ist eigenartig. Da würde ich beim internen
Atheros einen Hardwaredefekt oder einen Bug im Kernelmodul vermuten.
Mit der AR9287 hatten schon andere Leute Probleme:
<https://www.startpage.com/do/dsearch?query=AR9287+ubuntu&cat=web&pl=opensearch& language=deutsch>
Peter Koerber (13.03.2020, 21:16)
Am 12.03.2020 um 04:00 schrieb Gerald E:scher:
> Dass der USB-Adapter mit seiner einfachen Antenne eine höhere
> Übertrageunsrate liefert, ist eigenartig. Da würde ich beim internen


Da ist nichts eigenartig. Eine schlechte Antenne oder eine nicht gut
angepasste Antenne reduziert schnell die Sende- und
Empfangseigenschaften um Potenzen - speziell in den ganz kurzwelligen
Frequenzen VHF, SHF und noch kürzere Wellenlängen, bzw. höhere
Frequenzen. Eine auf die verwendete Sende- und Empfangsfrequenz richtig
dimensionierte Antenne - auch wenn es sich um ein Billigprodukt handelt
- zeigt wesentlich bessere Eigenschaften als ein bloss hingeworfener
Antennendraht oder eine nicht angepasste oder nur behelfsmässig oder
schlecht elektronisch angepasste Antenne. Dies gilt übrigens auch für
die Zuleitungen von Sender/Empfänger zur Antenne. Je höher die Frequenz,
desto höhere Qualität an Zuleitungskabeln (und Verbindungssteckern) ist
gefragt.
Peter
Gerald E:scher (14.03.2020, 18:05)
Peter Koerber schrieb am 13/3/2020 20:16:

> Am 12.03.2020 um 04:00 schrieb Gerald E:scher:
>> Dass der USB-Adapter mit seiner einfachen Antenne eine höhere
>> Übertrageunsrate liefert, ist eigenartig. Da würde ich beim internen

> Da ist nichts eigenartig. Eine schlechte Antenne oder eine nicht gut
> angepasste Antenne reduziert schnell die Sende- und
> Empfangseigenschaften um Potenzen


Aha. Du meinst also, die in Kays Laptop eingebauten Antennen
(üblicherweise 2 Stück zwecks MIMO) wären schlecht angepasst?
Kay Martinen (14.03.2020, 19:16)
Am 14.03.20 um 17:05 schrieb Gerald E:scher:
> Peter Koerber schrieb am 13/3/2020 20:16:
> Aha. Du meinst also, die in Kays Laptop eingebauten Antennen
> (üblicherweise 2 Stück zwecks MIMO) wären schlecht angepasst?


Vielleicht weißt du ja mehr zu einem FSC Lifebook E791 mit Atheros
AR9287 Chip. Ich kann dir nur sagen das der bei mir zuhause meist am
LAN-Kabel hängt, so gut wie nie das WLAN aktiv ist und selbst wenn doch
der AP keine 5m entfernt ist. Hier, mit offenen WLAN, weit entferntem AP
und vielen Clients ist es das erste mal denn diesen Usecase hatte ich
noch nie. Dazu kann ich nur sagen das ich nie in den Schacht mit dem
WLAN Modul schaute und hier nicht das Werkzeug habe das zu tun. Kann
also sein das eine Antennenleitung nicht gut verbunden ist und das Gerät
ist auch gebraucht gekauft und das kann schon länger so sein.

Mit dem Externen geht es nun und das ist alles was für mich zählt.

Kay
Peter Koerber (14.03.2020, 20:37)
Am 14.03.2020 um 06:05 schrieb Gerald E:scher:
> Aha. Du meinst also, die in Kays Laptop eingebauten Antennen
> (üblicherweise 2 Stück zwecks MIMO) wären schlecht angepasst?


Ich habe bereits hier im Thread aufgelistet, wo im WLAN-Bereich
(Hardware) Probleme auftreten könnten. Da ja der OP jetzt bestätigt hat,
dass es mit dem (externen) USB-Modul besser geht und somit anzunehmen
ist, dass im Bereich Antenne oder Sende-/Empfangsmodul etwas nicht
stimmt. Dass der Chip eine Macke hat kommt nur sehr selten vor - er
müsste sich schon selber wegen einer falsch angepassten Antenne verheizt
haben - und somit ist das Problem eher im Antennenbereich zu suchen und
zu lösen. Locker sitzende oder gar herausgefallene Antennensteckerchen
an der Platine sind übrigens gar keine Seltenheit. Bei Laptops ist aber
nicht immer ein leichter Zugang zur entsprechenden Platine
gewährleistet. Muss z.B. zuerst das ganze Keyboard entfernt werden um
überhaupt Zugang zum MB zu erhalten, dann hört natürlich alle Freude
auf, überhaupt etwas zu tun um ein Problem zu lösen. Da ist es einfacher
sich ein USB-Modul zu besorgen und feddich ist mit Problem.
Somit wäre auch Deine Frage beantwortet: Es muss nicht unbedingt eine
schlecht angepasste Antenne im Laptop sein. Es könnte eventuell...
Peter

Ähnliche Themen