expertenaustausch > comp.sys.* > comp.sys.mac.misc

Wolfgang Mederle (26.07.2006, 11:21)
Hallo,

seit einigen Tagen funktioniert die Paßwortabfrage nach
Bildschirmschoner oder Aufwecken des Rechners mit meinem Account nicht
mehr. Ein Neustart ändert daran nichts, ebensowenig das wiederholte
Setzen der Option "Require password to wake this computer from sleep or
screen saver" oder das Auswählen eines anderen Bildschirmschoners
(normalerweise "Blank Screen"). Die Funktion "Lock Screen" des
Menuitems von Keychain Access schwärzt zwar den Bildschirm, zeigt ihn
aber bei Tastatur- oder Mauseingaben sofort ohne Paßworteingabe wieder
an.

Mein momentaner Workaround ist, über Fast User Switching das Login
Window anzuzeigen, aber das ist doof. Mit einem anderen Account
funktioniert das Sperren ganz normal.

Was kann man da machen?

OS: 10.4.7
Hardware: Macbook
Gerhard Torges (26.07.2006, 12:11)
Wolfgang Mederle schrieb:

> seit einigen Tagen funktioniert die Paßwortabfrage nach
> Bildschirmschoner oder Aufwecken des Rechners mit meinem Account nicht
> mehr. Ein Neustart ändert daran nichts, ebensowenig das wiederholte
> Setzen der Option "Require password to wake this computer from sleep or
> screen saver" oder das Auswählen eines anderen Bildschirmschoners
> (normalerweise "Blank Screen").


Hmm.
Die zugehörige Preferences-Datei ist
~/Library/Preferences/ByHost/com.apple.screensaver.<Zahlensalat>.plist

Sowas findet man raus, indem man den Preferences-Ordner öffnet, nach
Änderungszeitpunkt sortieren läßt und dann die Einstellungen mal hin-
und herändert.

Hast Du die mal gelöscht oder deren Zugriffsrechte angesehen?

> Die Funktion "Lock Screen" des
> Menuitems von Keychain Access schwärzt zwar den Bildschirm, zeigt ihn
> aber bei Tastatur- oder Mauseingaben sofort ohne Paßworteingabe wieder
> an.


Das wiederum sollte von der anderen Einstellung unabhängig sein.
Seltsam ...

Gerhard
Wolfgang Mederle (26.07.2006, 17:12)
Es schrieb Gerhard Torges:

> Die zugehörige Preferences-Datei ist
> ~/Library/Preferences/ByHost/com.apple.screensaver.<Zahlensalat>.plist


Danke sehr, das Verschieben der Dateien plus Aus- und Einloggen hat
geholfen. Danach Einstellungen neu gesetzt, geht wieder, inklusive "Lock
Screen" von Keychain Access (das ich nicht brauche, Screensaver mit
heißer Ecke ist praktischer). Ich hatte das "ByHost"-Verzeichnis
übersehen ...

Interessanterweise stand in zwei Bildschirmschoner-Plists
"askForPassword" auf "1", in den beiden anderen gab es den Wert nicht.
Die Rechte waren korrekt. In der offensichtlich kaputten Plist für
"Blank Screen" waren im Vergleich zu der, die jetzt funktioniert, zwei
zusätzliche Werte vorhanden: idleTime (0) und lastPictureDirectoryChosen
(sehr komisch, das braucht ein Schoner, der nur schwarz macht, wohl
kaum).

>> Die Funktion "Lock Screen" des Menuitems von Keychain Access schwärzt
>> zwar den Bildschirm, zeigt ihn aber bei Tastatur- oder Mauseingaben
>> sofort ohne Paßworteingabe wieder an.

> Das wiederum sollte von der anderen Einstellung unabhängig sein.
> Seltsam ...


Das hängt wohl doch mit dem Bildschirmschoner zusammen.
Wolfgang Mederle (31.07.2006, 14:57)
Es schrieb Wolfgang Mederle:

> Danke sehr, das Verschieben der Dateien plus Aus- und Einloggen hat
> geholfen. Danach Einstellungen neu gesetzt, geht wieder, inklusive
> "Lock Screen" von Keychain Access (das ich nicht brauche, Screensaver
> mit heißer Ecke ist praktischer). Ich hatte das "ByHost"-Verzeichnis
> übersehen ...


Zu früh gefreut, das Problem tritt schon wieder auf. Da auch die
automatische Bildschirmerkennung regelmäßig spinnt (sprich: den externen
Monitor ignoriert, bis ich neustarte), frage ich mich, ob die Ursache
für das Problem nicht woanders liegt. Bin ich der einzige, bei dem
Bildschirmsperren und Monitorerkennung regelmäßig nicht klappen?
Gerhard Torges (31.07.2006, 15:13)
Wolfgang Mederle <walthervondervogelweide> wrote:

> Zu früh gefreut, das Problem tritt schon wieder auf. Da auch die
> automatische Bildschirmerkennung regelmäßig spinnt (sprich: den externen
> Monitor ignoriert, bis ich neustarte), frage ich mich, ob die Ursache
> für das Problem nicht woanders liegt. Bin ich der einzige, bei dem
> Bildschirmsperren und Monitorerkennung regelmäßig nicht klappen?


Ich habe gerade auch ein Problem mit dem Fast User Switching:
<news:1hjchzn.1dj7x31lopjyqN%deaf_null>

Vielleicht hängt das zusammen.

Gerhard
Wolfgang Mederle (31.07.2006, 17:47)
Es schrieb Gerhard Torges:

> Ich habe gerade auch ein Problem mit dem Fast User Switching:
> <news:1hjchzn.1dj7x31lopjyqN%deaf_null>


Per diesem Hint:
<URL:http://www.macosxhints.com/article.php?story=20060724153822700>
habe ich erst mal das PRAM zurückgesetzt und ein bißchen Hühnerblut
verspritzt -- erfolglos (falsches Huhn?). Danach AppleJack installiert
und die Caches löschen lassen. Jetzt geht's wieder, mal schauen, ob
diesmal dauerhaft.
Ähnliche Themen