expertenaustausch > comp.hardware.* > comp.hardware.netzwerke.wireless

Kay Martinen (26.10.2018, 13:57)
Hallo

ich habe hier einen rpi1b+ mit dem aktuellen (18.6?) openwrt installiert
und das problem das ich den realtek mini usb wlan adapter dort nicht
finde. Im Systemlog taucht er als usb-1.1.3 auf und wird demnach
erkannt. Ein realtek firmware paket habe ich schon installiert und neu
gestartet. Aber jedes mal wenn ich unter network mit "add" ein neues
Device hinzufügen will kann ich unten nur LAN auswählen oder "other
device" mit eingabefeld - was dann aber auch auf LAN zurück fällt.

Lt. deren Userguide soll man offenbar auch zwischen router, gateway u.a.
modi wählen können. Das taucht nirgends auf und ich vermute es liegt an
dem einzigen LAN Port, da WLAN noch nicht mit spielt.

Hat jemand dazu eine Hilfreiche Idee?

Kay
Andreas Kohlbach (26.10.2018, 20:56)
On Fri, 26 Oct 2018 13:57:25 +0200, Kay Martinen wrote:
> ich habe hier einen rpi1b+ mit dem aktuellen (18.6?) openwrt installiert
> und das problem das ich den realtek mini usb wlan adapter dort nicht
> finde. Im Systemlog taucht er als usb-1.1.3 auf und wird demnach
> erkannt. Ein realtek firmware paket habe ich schon installiert und neu
> gestartet. Aber jedes mal wenn ich unter network mit "add" ein neues
> Device hinzufügen will kann ich unten nur LAN auswählen oder "other
> device" mit eingabefeld - was dann aber auch auf LAN zurück fällt.
> Lt. deren Userguide soll man offenbar auch zwischen router, gateway u.a.
> modi wählen können. Das taucht nirgends auf und ich vermute es liegt an
> dem einzigen LAN Port, da WLAN noch nicht mit spielt.


Zeigt

ifconfig -a

(als Root) ihn auch an? Das System selbst scheint ihn ja zu kennen.
Kay Martinen (26.10.2018, 23:07)
Am 26.10.2018 um 20:56 schrieb Andreas Kohlbach:
> On Fri, 26 Oct 2018 13:57:25 +0200, Kay Martinen wrote:
> Zeigt
> ifconfig -a
> (als Root) ihn auch an? Das System selbst scheint ihn ja zu kennen.


Nein, leider nicht. Da kommt nur lo und eth0.

Es scheint da zwar auch jede menge pakete zu geben, aber offenbar alles
sehr kleinteilig (lsblk und lscpu sind getrennt, asterisk z.B. ca. 20
Pakete oder mehr) nur fand ich weder lsusb noch anderes das mir mehr
infos liefert. Ich sehe also nicht mal wie ich an mehr infos kommen sollte.

Ich bin wohl auch von falschen Voraussetzungen aus gegangen, das man
dies weitgehend über die WebUI einrichten könnte auch bei zusätzlichen
Paketen/Modulen. Anscheinend nicht richtig! Prinzipiell soll man wohl
interfaces hinzufügen können, aber wenn nur LAN sichtbar ist nützt das
alles nichts.

Da gibt es offenbar viel, aber nicht unbedingt alles oder was ich suche
finde ich nicht (wlan, clientside) darum lade ich momentan raspian
stretch lite runter. Da werde ich wohl deutlich eher alles finden was
ich suche und HowTo's u.a. lassen sich auch eher von debian/ubuntu
übertragen.

N.B. Ein D-Link Stick (Ralink-chip) klappt auch nicht. Dagegen lief der
Realtek Stick unter LibreElec (auf dem gleichen Rpi!) problemlos und der
D-Link mit IP-Fire (alter Laptop) auch. Die Funktionieren also!

Muß ich eben alles zu fuß und von Hand zurecht klöppeln. :-/

Was ich nicht verstehe, da gibt es ein paket 'lua-full-admin' o.ä. wo
man denken könnte das würde die WebUI aufrüsten (LuCi, IMHO lua-basiert)
und z.b. eine Art Expert-Modus bringen oder mehr/tiefer Optionen. Aber
selbst nach Reboot... Nix! Ich frag mich da: KANN OpenWRT nicht oder
WILL es nicht - auf einem Raspberry Pi 1b+?

Funktioniert das auf anderen (HW) Routern besser, mit mehr Optionen?

Die WebUI ist hier auch x-mal stecken geblieben, hat änderungen nicht
übernehmen können wollte rollback machen oder war zeitweilig überhaupt
nicht ansprechbar. Ist das Bananensoftware?

Kay
Andreas Kohlbach (27.10.2018, 21:39)
On Fri, 26 Oct 2018 23:07:27 +0200, Kay Martinen wrote:
> Am 26.10.2018 um 20:56 schrieb Andreas Kohlbach:
> Nein, leider nicht. Da kommt nur lo und eth0.


Also wenn das System ihn erkannt hat, sollte ifconfig -a ihn auch listen.

> Es scheint da zwar auch jede menge pakete zu geben, aber offenbar alles
> sehr kleinteilig (lsblk und lscpu sind getrennt, asterisk z.B. ca. 20
> Pakete oder mehr) nur fand ich weder lsusb noch anderes das mir mehr
> infos liefert. Ich sehe also nicht mal wie ich an mehr infos kommen sollte.


lsusb gehört zu den usbutils. Würde das an Deiner Stelle installieren.

> Ich bin wohl auch von falschen Voraussetzungen aus gegangen, das man
> dies weitgehend über die WebUI einrichten könnte auch bei zusätzlichen
> Paketen/Modulen. Anscheinend nicht richtig! Prinzipiell soll man wohl
> interfaces hinzufügen können, aber wenn nur LAN sichtbar ist nützt das
> alles nichts.


Wenn etwas von Kernel nicht erkannt wird, nutzt das Webinterface nichts.

[...]

> N.B. Ein D-Link Stick (Ralink-chip) klappt auch nicht. Dagegen lief der
> Realtek Stick unter LibreElec (auf dem gleichen Rpi!) problemlos und der
> D-Link mit IP-Fire (alter Laptop) auch. Die Funktionieren also!


Das hört sich nach einem Treiberproblem an. Es gibt keinen oder der
Falsche ist geladen.

> Muß ich eben alles zu fuß und von Hand zurecht klöppeln. :-/


Das ist doch gerade der Spaß bei Linux. :-D

Liefert lsmod Aufschlussreiches?

[...]
Ähnliche Themen