expertenaustausch > comm.software.* > comm.software.mozilla.browser

Ralph Haase (25.03.2020, 15:58)
Hallo,

Wie kann man beim SM den Zugriff auf Kamera/Mikrofon ermöglichen?
Wenn ich bei der jeweiligen Webseite den Zugriff ermögliche (über die
Seiteninformation --> Berechtigungen), wird zwar beim nächsten Besuch
der Seite angezeigt, daß der Zugriff darauf erlaubt ist, aber die Webseite
erkennt das nicht- zumindest wird die Meldung angezeigt, daß keine
Kamera und kein Mikro erkannt wird.
Leider kann ich den Link nicht posten- ist nicht öffentlich, aber welche
Möglichkeiten habe ich, heraus zu finden, woran es liegt?

Viele Grüße

R.Haase
Manuel Reimer (25.03.2020, 16:37)
On 25.03.20 14:58, Ralph Haase wrote:
> Wie kann man beim SM den Zugriff auf Kamera/Mikrofon ermöglichen?
> Wenn ich bei der jeweiligen Webseite den Zugriff ermögliche (über die
> Seiteninformation --> Berechtigungen), wird zwar beim nächsten Besuch
> der Seite angezeigt, daß der Zugriff darauf erlaubt ist, aber die Webseite
> erkennt das nicht- zumindest wird die Meldung angezeigt, daß keine
> Kamera und kein Mikro erkannt wird.
> Leider kann ich den Link nicht posten- ist nicht öffentlich, aber welche
> Möglichkeiten habe ich, heraus zu finden, woran es liegt?


Ich würde mal vorschlagen: Zum Vergleich zu allererst mal mit Firefox
testen um zu sehen ob es da auch nicht geht?

Gruß

Manuel
Hans-Otto Kurz (25.03.2020, 19:53)
> Wie kann man beim SM den Zugriff auf Kamera/Mikrofon ermöglichen?

Geht wohl nicht. Egal, welche "Testseite" man aufruft, z. B.


kommen sowohl mit SM oder MS IE oder MS Edge unterschiedliche Meldungen,
dass diese Browser diese Kamerafunktionen nicht unterstützen.

Die Meldung, in der um Erlaubnis gefragt wird, kommt in SM dagegen nie.

Mit FF (oder Google Chrome) ist das dagegen kein Problem.

In Corona-Zeiten ist das tatsächlich interessant, da viele Ärzte
mittlerweile Videosprechstunden anbieten (über zertifizierte Anbieter,
die daher auch nur Firefox und GC unterstützen).

ciao
h-o
Ralph Haase (26.03.2020, 12:36)
Hans-Otto Kurz schrieb:

> Die Meldung, in der um Erlaubnis gefragt wird, kommt in SM dagegen nie.
> Mit FF (oder Google Chrome) ist das dagegen kein Problem.


Danke für den Link- habe ich mir mal gespeichert und ja, mit SM
klappt das nicht, mit dem FF schon (habe mal den portablen herunter
geladen und getestet).

Viele Grüße

R.Haase
Hartmut Figge (26.03.2020, 14:21)
Ralph Haase:

>Danke für den Link- habe ich mir mal gespeichert und ja, mit SM
>klappt das nicht, mit dem FF schon (habe mal den portablen herunter
>geladen und getestet).


Hast Du es mal mit einem Fake-UA versucht? Einem, bei dem SM behauptet,
ein zeitgemäßer FF zu sein?

Hartmut
Hans-Otto Kurz (26.03.2020, 18:42)
Hartmut Figge schrieb:
> Hast Du es mal mit einem Fake-UA versucht? Einem, bei dem SM behauptet,
> ein zeitgemäßer FF zu sein?


Das wäre ja wirklich zu schön, um wahr zu sein :-)

Aber sowohl mit "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0)
Gecko/20100101 Firefox/68.0" als auch etwa mit v74.0 kommt bei SM auf
open.hpi.de die gleiche Meldung "Sorry, the browser you are using
doesn't support getUserMedia".

Ähnlich auch bei anderen Testseiten, die sich im Netz tummeln, wenn man
nach "kamera browser testen" etc. sucht.

Und wenn man sich etwa auf clickdoc.elvi.de mit einem Zugangscode des
Arztes einloggt, wird mit SM einfach nur eine leere weiße Seite angezeigt.

Hilft alles nix - die Engine muss passen...

ciao
h-o
Arno Welzel (26.03.2020, 19:39)
Hans-Otto Kurz:

[..]
> Und wenn man sich etwa auf clickdoc.elvi.de mit einem Zugangscode des
> Arztes einloggt, wird mit SM einfach nur eine leere weiße Seite angezeigt.
> Hilft alles nix - die Engine muss passen...


Das hier ist eine ganz simple Testseite, die getUserMedia() nutzt, um
ein Live-Bild der Webcam im Browser anzuzeigen, keine User-Agent-Abfrage
o.Ä.:

<https://arnowelzel.de/lib/tool/webcam/>
Ähnliche Themen