expertenaustausch > comp.sys.* > comp.sys.mac.misc

Swen R. (25.03.2020, 09:38)
Hallo
mithilfe von "sudo nvram SystemAudioVolume=%00" läßt sich im Terminal
der Startton abstellen.
Ist mir einige Systemversionen früher schonmal gelungen.
Gebe ich das jetzt im Terminalfenster ein wird Password verlangt.
Bei Eingabe vom Admin-PW kommt
"xxx is not in the sudoers file. This incident will be reported."

Was mache ich falsch?
Gruß
Başar Alabay (25.03.2020, 10:28)
Swen R. schrieb:

> Hallo
> mithilfe von "sudo nvram SystemAudioVolume=%00" läßt sich im Terminal
> der Startton abstellen.
> Ist mir einige Systemversionen früher schonmal gelungen.


Ich habe praktisch fast immer den Ton auf 0, das bleibt dann auch beim
Start so.

> Gebe ich das jetzt im Terminalfenster ein wird Password verlangt.
> Bei Eingabe vom Admin-PW kommt
> "xxx is not in the sudoers file. This incident will be reported."
> Was mache ich falsch?


Rein der Meldung nach zu urteilen, scheinst Du mit einem normalen User
einen sudo-Befehl absetzen zu wollen. Du müßtest zuerst einen Adminuser
aufrufen.

normalo -> su scheff (PW von Scheff) -> sudo irgendwas (evtl. PW von
Scheff) -> exit (wieder zurück zu Normalo).

B. Alabay
Andreas Karrer (25.03.2020, 14:20)
* Swen R. <kein.spam>:

> mithilfe von "sudo nvram SystemAudioVolume=%00" läßt sich im Terminal
> der Startton abstellen.
> Ist mir einige Systemversionen früher schonmal gelungen.


Mit dem selben Benutzer wie jetzt?

> Gebe ich das jetzt im Terminalfenster ein wird Password verlangt.
> Bei Eingabe vom Admin-PW kommt
> "xxx is not in the sudoers file. This incident will be reported."


Das Problem hat wohl nix mit dem nvram-Befehl zu tun, sondern mit sudo.

'xxx' ist vermutlich kein "admin"-Benutzer, sondern ein normaler
Standardbenutzer ("admin"-Benutzer haben bei Systemeinstellungen >
"Benutzer und Gruppen" das Häkchen bei "Der Benutzer darf diesen
Computer verwalten" gesetzt).

Typischerweise ist sudo auf MacOS so aufgesetzt, dass nur
"admin"-Benutzer Befehle via sudo mit root-Rechten ausführen können.
Dazu müssen sie aber nicht irgendein Admin-Passwort eingeben, sondern
ihr eigenes.

Wenn ein "admin"-Benutzer ein Terminalfenster aufmacht, har er darin
keineswegs root-Rechte. Aber er kann mit sudo Befehle als root absetzen
oder mit "sudo -s" eine root-Shell starten.

- Andi
Steffen Bendix (25.03.2020, 17:07)
Swen R. <kein.spam> wrote:

> "xxx is not in the sudoers file. This incident will be reported."


Suche im Netz mal genau nach dieser Meldung und Du wirst viele Anleitungen
finden, wie Du Dich in diese besagte Datei eintragen kannst. Dann hast Du
bis zum nächsten großen Update Ruhe.

Steffen
Swen R. (26.03.2020, 10:49)
Ba?ar Alabay <alabay> wrote:
> Ich habe praktisch fast immer den Ton auf 0, das bleibt dann auch beim
> Start so.


Ich habe ihn auf 3 = leise, der Startton kommt trotzdem.
> Rein der Meldung nach zu urteilen, scheinst Du mit einem normalen User
> einen sudo-Befehl absetzen zu wollen. Du müßtest zuerst einen Adminuser
> aufrufen.


Das wars. Danke.
Swen R. (26.03.2020, 10:49)
Andreas Karrer <ak-0a> wrote:
> Mit dem selben Benutzer wie jetzt?


Ja, aber das war kein Admin. Geändert = jetzt klappts.

Danke.
Swen R. (26.03.2020, 10:49)
Steffen Bendix <unbeliebte2000-post> wrote:
> Suche im Netz mal genau nach dieser Meldung und Du wirst viele Anleitungen
> finden, wie Du Dich in diese besagte Datei eintragen kannst. Dann hast Du
> bis zum nächsten großen Update Ruhe.
> Steffen


Gemacht, bin noch am Lesen.

Danke,
Steffen Bendix (27.03.2020, 13:47)
Swen R. <kein.spam> wrote:

> Gemacht, bin noch am Lesen.


Nimm einfach die:



Steffen
Swen R. (29.03.2020, 15:02)
Steffen Bendix <unbeliebte2000-post> wrote:
> Nimm einfach die:
> Super, danke.


Swen
Swen R. (26.04.2020, 09:35)
Swen R. <kein.spam> wrote:
> Ja, aber das war kein Admin. Geändert = jetzt klappts.
> Danke.


Seit diesem letzten posting war der Startton still.

Heute tönt er wieder. Zwischendrin wurde nichts verstellt, es gab keinen
crash o.ä.

Wodurch wird sowas verursacht?

Einen schönen Sonntag,
Başar Alabay (26.04.2020, 18:05)
Swen R. schrieb:

>> Ja, aber das war kein Admin. Geändert = jetzt klappts.
>> Danke.

> Seit diesem letzten posting war der Startton still.
> Heute tönt er wieder. Zwischendrin wurde nichts verstellt, es gab keinen
> crash o.ä.
> Wodurch wird sowas verursacht?


Ton zwischendurch mal an? Tonausgabe umgestellt? User gewechselt?

B. Alabay
Ähnliche Themen