expertenaustausch > linux.debian.user.german

Rupert Kolb (04.05.2020, 16:50)
Hallo,

hab einen Rechner, auf dem stretch läuft.

Wollte opera aktualisieren.
Meldung:
  dpkg: Abhängigkeitsprobleme verhindern Konfiguration von opera-stable:
  opera-stable hängt ab von libgbm1 (>= 17.1.0~rc2); aber:
  Version von libgbm1:amd64 auf dem System ist 13.0.6-1+b2.

in oldstable-backports (= stretch-backports) wäre jedoch die Version
  libgbm1 (18.2.8-2~bpo9+1)
drin.

in meinem
  /etc/apt/sources.list.d/local.list
steht
  deb file:/xyz/debian/ stretch-backports main contrib non-free
(ja, die Dateien stehen dort! ... und speziell
/xyz/debian/main/m/mesa/libgbm1_18.2.8-2~bpo9+1_amd64.deb ist da.)

Ein "apt-get upgrade" ignoriert die Aktualisierung auf den Backport. Und
synaptic findet auch nichts.

Kann mir jemand helfen?

Rupert
Rupert Kolb (04.05.2020, 17:00)
.... und
  apt-get install -t stretch-backports libgbm1
liefert:
  Paketlisten werden gelesen... Fertig
  E: Der Wert »stretch-backports« ist für APT::Default-Release
ungültig, da solch eine Veröffentlichung in den Paketquellen nicht
verfügbar ist.

Ich hab keine Idee, wo ich weitersuchen soll....

Am 04.05.2020 um 16:37 schrieb Rupert Kolb:
[..]
Sven (04.05.2020, 18:00)
> ... und
> apt-get install -t stretch-backports libgbm1
> liefert:
> Paketlisten werden gelesen... Fertig
> E: Der Wert »stretch-backports« ist für APT::Default-Release
> ungültig, da solch eine Veröffentlichung in den Paketquellen nicht
> verfügbar ist.
> Ich hab keine Idee, wo ich weitersuchen soll....


Versuch es mal mit aptitude. Dann kannst du einfacher alle verfügbaren
Paketversionen sehen und geziehlt auswählen.
Elimar Riesebieter (04.05.2020, 20:30)
* Rupert Kolb <rupert.kolb> [2020-05-04 16:37 +0200]:

> Hallo,
> hab einen Rechner, auf dem stretch läuft.


Warum?

Elimar
Richard Kraut (04.05.2020, 21:20)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Am Montag, den 04.05.2020, 16:59 +0200 schrieb Rupert Kolb:

> apt-get install -t stretch-backports libgbm1
> liefert:
> Paketlisten werden gelesen... Fertig
> E: Der Wert »stretch-backports« ist für APT::Default-Release
> ungültig, da solch eine Veröffentlichung in den Paketquellen nicht
> verfügbar ist.


Ein 'apt update' bzw. 'apt-get update' hattest Du davor gemacht, oder?

> Ich hab keine Idee, wo ich weitersuchen soll....


Zeigt ein 'apt show -a libbgm1' das gesuchte Paket in der gewünschten Version
an?

- --
Rupert Kolb (05.05.2020, 11:20)
Am 04.05.2020 um 21:11 schrieb Richard Kraut:
> apt show -a libbgm1 apt show -a libgbm1 zeigt mir nur die alte Version an:


Package: libgbm1
Version: 13.0.6-1+b2
Rupert Kolb (05.05.2020, 11:30)
Am 04.05.2020 um 17:51 schrieb Sven:
> Versuch es mal mit aptitude. Dann kannst du einfacher alle verfügbaren
> Paketversionen sehen und geziehlt auswählen.

offensichtlich wird das Repo nicht benutzt.
(Ich hab's genauso eingebunden wie die andern Repos)

Das empfohlene "... -t stretch-backports ..."  (s.o.) macht mich etwas
stutzig.

Gibt's einen Trick um die backports-Repos einzubinden?
Bzw. wie kann ich vorgehen ... ?
Sven (05.05.2020, 20:20)
> Gibt's einen Trick um die backports-Repos einzubinden?
> Bzw. wie kann ich vorgehen ... ?


Ich wollte ursprünglich nur darauf verweisen:


... aber ich sehe gerade, dass du ein lokales Repo verwendest!?

Dann versuch es mal mit:

deb [ trusted=yes ] file:/xyz/debian/ stretch-backports main contrib non-free
Richard Kraut (06.05.2020, 20:50)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Am Dienstag, den 05.05.2020, 11:14 +0200 schrieb Rupert Kolb:

> apt show -a libgbm1 zeigt mir nur die alte Version an:
> Package: libgbm1
> Version: 13.0.6-1+b2


Wie Du bereits selbst gemerkt hast, bestätigt diese Ausgabe, dass Dein lokales
Repo ignoriert wird.

Hier solltest Du dann mal den Tipp von Sven versuchen.

- --
Ähnliche Themen