expertenaustausch > microsoft.* > microsoft.excel

Sven Olbrecht (17.01.2008, 17:20)
Hallo NG Craks

Ich bekamm das letzte mal super hilfe von euch deshalb probier ich es
nochmals:
Leider hat das probieren nur teils was gebracht.

Habe zwei Spalten: In Spalte A das Datum (01.01.08) und in Spalte B die
Summe:

Nun will ich das mir Excel die Summe rechnet wenn das Datum zwischen dem
01.01.08 bis 31.01.08 liegt. (Zelle als Datum formatiert)
Formelanfang? =SUMMEWENN(A10:A1000;............;B10:B1000)

Ebenfalls will ich in einem anderen Feld Anstelle der Summe die ANZAHL der
Datensätze.

Muss ich da das Datum spez. formatieren?

Bin wieder Dankbar für alle Hinweise
Freundliche Grüsse Sven
Alexander Wolff (17.01.2008, 17:30)
> Nun will ich das mir Excel die Summe rechnet wenn das Datum zwischen dem
> 01.01.08 bis 31.01.08 liegt. (Zelle als Datum formatiert)
> Formelanfang? =SUMMEWENN(A10:A1000;............;B10:B1000)


=SUMMEWENN(A10:A1000;"<=31.01.2008";B10:B1000)
-SUMMEWENN(A10:A1000;"<=31.12.2007";B10:B1000)

> Ebenfalls will ich in einem anderen Feld Anstelle der Summe die ANZAHL der
> Datensätze.


=ZÄHLENWENN(A10:A1000;"<=31.01.2008")
-ZÄHLENWENN(A10:A1000;"<=31.12.2007")
Alexander Wolff (17.01.2008, 17:53)
oder kürzer:

>> Nun will ich das mir Excel die Summe rechnet wenn das Datum zwischen dem
>> 01.01.08 bis 31.01.08 liegt. (Zelle als Datum formatiert)
>> Formelanfang? =SUMMEWENN(A10:A1000;............;B10:B1000)

> =SUMMEWENN(A10:A1000;"<=31.01.2008";B10:B1000)
> -SUMMEWENN(A10:A1000;"<=31.12.2007";B10:B1000)


=SUMMENPRODUKT((ABS(A10:A1000-"16.1.2008")<16)*B10:B1000)

>> Ebenfalls will ich in einem anderen Feld Anstelle der Summe die ANZAHL
>> der
>> Datensätze.

> =ZÄHLENWENN(A10:A1000;"<=31.01.2008")
> -ZÄHLENWENN(A10:A1000;"<=31.12.2007")


=SUMMENPRODUKT(--(ABS(A10:A1000-"16.1.2008")<16))

.... wenn gesichert ist, dass die Zeiten 0:00 Uhr sind.
Sven Olbrecht (17.01.2008, 17:53)
Dank VIELEMALLS Alexander

Das werde ich jetzt so bis zum Dezember weitermachen.
Das ist dann eine Riesenzeitersparniss

:-D

"Alexander Wolff" <ooops> schrieb im Newsbeitrag
news:l001
[..]
Alexander Wolff (17.01.2008, 18:18)
=SUMMENPRODUKT((TEXT(A10:A1000;"MM.JJ")="01.08")*B 10:B1000) und
=SUMMENPRODUKT((TEXT(A10:A1000;"MM.JJ")="01.08")*1 )

sind da doch sicherer.
Sven Olbrecht (18.01.2008, 08:09)
Morgen Alexander
Da hast du dir aber sehr viel mühe gegeben dafür möchte ich mich nochmals
ganz herzlich bedanken---alleine hätte ich da keine Chance:
Habe nun deine Formel so übernommen:

=SUMMENPRODUKT((TEXT(Offerten!A5:A1000;"MM.JJ")="0 1.08")*Offerten!F5:F1000)

Funktioniert super :-o

Ich versuche nun noch irgendwie die 08 wegzulassen so das ich die Tabelle
jedes Jahr wieder neu und jungfreulich benutzen kann und nicht alle Jahre
die Formeln von 08 auf 09 anpassen muss (Da alle Jahre wieder eine neue
Tabelle erstellt wird)

Nun versuche ich noch die Anzahl Felder zu ermitteln dazu muss Excel jedoch
auch in
die Spalte B gehen und dort zählen, und nicht in der Spalte A zählen (Da es
nach der Spalte B noch C und D Spalten gibt und der Eintrag jeweils in B,C,
oder D erfolgt )

Wollte Summenprodukt durch ZÄHLENWENN oder ANZAHL ersetzen geht jedoch
beides nicht. Vielleicht hast du ja da auch noch ne Lösung.
Habe aber wirklich langsam ein schlechtes Gewissen deine Zeit so zu
beanspruchen.
Nochmals ALLERBESTEN DANK

Gruss S. Olbrecht aus Rapperswil

"Alexander Wolff" <ooops> schrieb im Newsbeitrag
news:a031
[..]
Sven Olbrecht (18.01.2008, 08:15)
Nur schnell falls es jemand mitverfolgt:
Es geht wenn man nur nach dem Monat filtert: Man kann jedoch in der A Spalte
das ganze
Datum zb. 01.02.2008 eingeben.

=SUMMENPRODUKT((TEXT(Offerten!A5:A1000;"MM")="01") *Offerten!F5:F1000)

"Sven Olbrecht" <sven.olbrecht> schrieb im Newsbeitrag
news:6140
[..]
Alexander Wolff (18.01.2008, 11:15)
> Ich versuche nun noch irgendwie die 08 wegzulassen so das ich die Tabelle

=SUMMENPRODUKT((TEXT(Offerten!A5:A1000;"M")=1)*Off erten!F5:F1000)

> Wollte Summenprodukt durch ZÄHLENWENN oder ANZAHL ersetzen geht jedoch


=SUMMENPRODUKT((TEXT(Offerten!A5:A1000;"M")=1)*1)
(hatte ich aber immer schon beigefügt; hast Du es nicht ausprobiert?)
Sven Olbrecht (18.01.2008, 11:58)
> =SUMMENPRODUKT((TEXT(Offerten!A5:A1000;"M")=1)*1)
> (hatte ich aber immer schon beigefügt; hast Du es nicht ausprobiert?)


Doch das hab ich schon.
Aber Excel muss ua. in der Spalte B die Anzahl zählen nachdem es in Spalte A
geschaut hat ob das Datum zb. im Monat Januar ist:

Tabelle sieht so aus:

A...................................B............. .................C........
.....................usw.
01.01.2008...................Fr. 300.-
02.02.2008........................................ ............Fr. 200.-
02.02.2008...................Fr. 100.-
03.02.2008........................................ ............Fr. 400.-
04.02.2008....................Fr. 600.-

Gewünschte Lösung:

..............................Betrag B....................Anzahl B
Januar...................Fr. 300.-....................1
Februar.................Fr. 700.-....................2

..............................Betrag C........................Anzahl C
Januar............................................ .................
Februar.................Fr..600.-........................2
März.................usw.
Alexander Wolff (18.01.2008, 12:02)
> Doch das hab ich schon.
> Aber Excel muss ua. in der Spalte B die Anzahl zählen nachdem es in Spalte
> A
> geschaut hat ob das Datum zb. im Monat Januar ist:


Wie unterscheiden sich SUMMEWENN und ZÄHLENWENN? (Antwort: B10:B1000 j/n)

Es gibt kein Anzahl B, sondern nur eine Anzahl Sätze. Bei ZÄHLENWENN oder
dem entspr. SUMMENPRODUKT brauchst Du keine Summanden, sondern nur die
Zellen, die die Bedingung bestimmen.
Sven Olbrecht (18.01.2008, 12:25)
> Wie unterscheiden sich SUMMEWENN und ZÄHLENWENN? (Antwort: B10:B1000 j/n)
> Es gibt kein Anzahl B, sondern nur eine Anzahl Sätze.


Das habe ich so gemeint........

Bei ZÄHLENWENN oder
> dem entspr. SUMMENPRODUKT brauchst Du keine Summanden, sondern nur die
> Zellen, die die Bedingung bestimmen.


Ja, brauch die Anzahl Zellen die einen Eintrag haben so dass ich sagen kann,

Im Januar haben wir 1 Auftrag B im Wert von 300.- bekommen
Im Februar haben wir 2 Aufträge B im Wert von 700.- bekommen....

Im Februar haben wir 2 Aufträge C im Wert von 600.- bekommen.....
(Bezieht sich auf Tabelle im Vorposting)
Sven Olbrecht (18.01.2008, 12:49)
Glaube das ist die Lösung:

=SUMMENPRODUKT((TEXT(Offerten!A5:A1000;"M")="1")*( Offerten!G5:G1000<>""))

So geht Excel in Spalte A schaut nach dem Datum, wenn das Datum im Januar
ist geht es in Spalte G und schaut ob dort ein Eintrag ist. Wenn ja zählt es
die Anzahl der ausgefüllten Felder in der Spalte G

Probiere das nun aus.
Gruss Sven

"Alexander Wolff" <ooops> schrieb im Newsbeitrag
news:d011
[..]
Alexander Wolff (18.01.2008, 12:50)
> Ja, brauch die Anzahl Zellen die einen Eintrag haben so dass ich sagen
> kann,
> Im Januar haben wir 1 Auftrag B im Wert von 300.- bekommen
> Im Februar haben wir 2 Aufträge B im Wert von 700.- bekommen....
> Im Februar haben wir 2 Aufträge C im Wert von 600.- bekommen.....
> (Bezieht sich auf Tabelle im Vorposting)


Hatte ich nicht genau genug gelesen, sorry!

ZÄHLENWENN: =SUMMENPRODUKT((TEXT(Offerten!A5:A1000;"M")=1)*(B5 :B1000<>""))

"SUMMEWENN" schaffst Du nun sicher selbst.
Sven Olbrecht (18.01.2008, 13:04)
Ja, genau das ist die Lösung
Hab ich mir dank deiner SUPERHILFE auch zusammengeklemmpnert....
Ich danke dir nochmals GANZ HERZLICH, denke das ist wirklich nicht
selbstverständlich..

Freundliche Grüsse und EN GUETE
sven

"Alexander Wolff" <ooops> schrieb im Newsbeitrag
news:8001
[..]
andre.schult91 (28.04.2019, 20:25)
> =SUMMEWENN(A10:A1000;"<=31.01.2008";B10:B1000)
> -SUMMEWENN(A10:A1000;"<=31.12.2007";B10:B1000)


Hallo,

kann man das angegebene Datum auch mit einem Zellenbezug lösen? Somit könnte ich den Datumswert beliebig ändern.

Leider ist das Ergebnis bei mir dann immer 0....

Könntet Ihr mir hier auch nochmal helfen?

Gruß

Andre

Ähnliche Themen