expertenaustausch > comp.* > comp.office-pakete.staroffice.misc

Eberhard Siebel (13.02.2019, 17:58)
Hallo,

wie kann ich aus einem Calc-Dokument eine Tabelle mit Diagramm in ein
neues Calc-Dokument verschieben oder kopieren ohne daß der Bezug zu den
Daten in der gleichen Tabelle verloren gehen?

Die zu verschiebende Tabelle enthält Daten und Diagramm. An der neuen
Stelle ist das auch noch so. Nur ist dann das Diagramm nicht mehr in
Bezug auf die vorhanden Daten sondern es wurde eine eigene Datentabelle
gebildet.

Ab und zu geht dieser Bezug nicht verloren - aber ich kann nicht sagen,
was ich da anders gemacht habe.

Gruß
Eberhard
Siegfried Höfner (13.02.2019, 18:49)
Am 13.02.2019 um 16:58 schrieb Eberhard Siebel:
> Hallo,
> wie kann ich aus einem Calc-Dokument eine Tabelle mit Diagramm in ein
> neues Calc-Dokument verschieben oder kopieren ohne daß der Bezug zu den
> Daten in der gleichen Tabelle verloren gehen?
> Die zu verschiebende Tabelle enthält Daten und Diagramm. An der neuen
> Stelle ist das auch noch so. Nur ist dann das Diagramm nicht mehr in
> Bezug auf die vorhanden Daten sondern es wurde eine eigene Datentabelle
> gebildet.
> Ab und zu geht dieser Bezug nicht verloren - aber ich kann nicht sagen,
> was ich da anders gemacht habe.


Hallo Eberhard, ich habe deine Beschreibung wahrscheinlich nicht richtig
verstanden : Hier mal das, was ich der Beschreibung entnehme:
Calc-Dokument1 hat eine Tabelle1 mit Daten und ein Diagramm, welches
sich auf diese Daten bezieht. Du kopierst die Tabelle und fügst sie in
Calc-Dokument2 wieder ein? Und was ist nun falsch?

Gruß Siegfried
Siegfried Höfner (22.02.2019, 17:06)
Am 22.02.2019 um 15:16 schrieb Eberhard Siebel:
> Am 13.02.2019 um 17:49 schrieb Siegfried Höfner:
>> Am 13.02.2019 um 16:58 schrieb Eberhard Siebel:

[...]
Hallo Eberhard,
ich habe hier unter W7 und LO 6.0.7.3 (was hast du?) nochmals mehrere
Tests gemacht (ganzes Tabellenblatt kopieren, nur Daten mit Diagramm
markiert und kopiert) aber immer ist alles richtig. Ich habe sogar
einmal dem Tabellenblatt im Zieldokument einen neuen Namen verpaßt, aber
auch das wird richtig angepasst. Änderung der Daten im Zieldokument
wirken sich sofort auf das Diagramm aus.

Vielleicht gibst du nochmal deine Umgebung an und das genaue Vorgehen.
Bei der Bezeichnung "Tabelle" bitte genau angeben ob das Tabellenblatt
oder die Datentabelle gemeint ist.
Gibt es evtl. ein Testdokument?

Gruß Siegfried
Eberhard Siebel (22.02.2019, 20:34)
Am 22.02.2019 um 16:06 schrieb Siegfried Höfner:
> Am 22.02.2019 um 15:16 schrieb Eberhard Siebel:
>> Am 13.02.2019 um 17:49 schrieb Siegfried Höfner:
>>> Am 13.02.2019 um 16:58 schrieb Eberhard Siebel:

> [...] Hallo Siegfried,
> Hallo Eberhard,
> ich habe hier unter W7 und LO 6.0.7.3 (was hast du?)


habe die gleichen Programme.

> nochmals mehrere Tests gemacht
> (ganzes Tabellenblatt kopieren, nur Daten mit Diagramm
> markiert und kopiert) aber immer ist alles richtig.


hab ich auch - mal ganzes Tabellenblatt - mal alles markiert und
kopiert. Immer gleicher Fehler

> Ich habe sogar einmal dem Tabellenblatt
> im Zieldokument einen neuen Namen verpaßt, aber
> auch das wird richtig angepasst. Änderung der Daten im Zieldokument
> wirken sich sofort auf das Diagramm aus.

da, wo es einmal funktioniert hat, kann man auch ohne Probleme den Namen
ändern.

> Vielleicht gibst du nochmal deine Umgebung an und das genaue Vorgehen.
> Bei der Bezeichnung "Tabelle" bitte genau angeben ob das Tabellenblatt
> oder die Datentabelle gemeint ist.


s.o.

> Gibt es evtl. ein Testdokument?

da bin ich dran. Es dauert etwas länger, da ich festgestellt habe, bei
einem einfachen Dokument mit einem Tabellenblatt funktioniert es wie du
gesagt hast. Ich melde mich.

Gruß
Eberhard
Eberhard Siebel (23.02.2019, 09:44)
Am 22.02.2019 um 19:34 schrieb Eberhard Siebel:
[..]
> da bin ich dran. Es dauert etwas länger, da ich festgestellt habe, bei
> einem einfachen Dokument mit einem Tabellenblatt funktioniert es wie du
> gesagt hast. Ich melde mich.

Hallo Siegfried,
ich wollte natürlich wissen, wo der Fehler lag...
Im Ursprungsdokument hatte ich eine Kopie eines Tabellenblattes in die
gleiche Datei gemacht und von dieser Kopie eine Kopie in ein neues
Dokument gemacht. Ich brauche das Format an beiden Stellen.
Das Problem war nun, daß das originale und kopierte Tabellenblatt
irgendwie voneinander abhängig waren. Sie funktionierten nur gemeinsam.
Wenn ich nun eins von beiden alleine kopiert habe, ging es nicht mehr.

Problem erkannt - danke für deine Mühe!

Gruß
Eberhard
Siegfried Höfner (23.02.2019, 11:13)
Am 23.02.2019 um 08:44 schrieb Eberhard Siebel:
> Am 22.02.2019 um 19:34 schrieb Eberhard Siebel:


> Hallo Siegfried,
> ich wollte natürlich wissen, wo der Fehler lag...
> Im Ursprungsdokument hatte ich eine Kopie eines Tabellenblattes in die
> gleiche Datei gemacht und von dieser Kopie eine Kopie in ein neues
> Dokument gemacht. Ich brauche das Format an beiden Stellen.
> Das Problem war nun, daß das originale und  kopierte  Tabellenblatt
> irgendwie voneinander abhängig waren. Sie funktionierten nur gemeinsam.
> Wenn ich nun eins von beiden alleine kopiert habe, ging es nicht mehr.
> Problem erkannt - danke für deine Mühe!


Hallo Eberhard, ich habe nach diesen neuen Informationen (Kopie von
Kopie) auch kurz getestet. Nach meinen Erkenntnissen geht die Kopie von
der Originaltabelle in ein neues Dokument weiterhin ok, nur die Kopie
der Kopietabelle geht schief. Es wird kein Datenbereich angelegt sondern
nur eine Datentabelle. Außerdem ist bei mir das Format der x-Reihe von
Zahl auf Datum (Stunden) gewechselt. Ich habe im Moment keine Zeit, das
weiter zu untersuchen. Vielleicht liest Eike mit und kann es erklären.

Gruß Siegfried
Eberhard Siebel (23.02.2019, 22:03)
Am 23.02.2019 um 10:13 schrieb Siegfried Höfner:
> Am 23.02.2019 um 08:44 schrieb Eberhard Siebel:
> Hallo Eberhard, ich habe nach diesen neuen Informationen (Kopie von
> Kopie) auch kurz getestet. Nach meinen Erkenntnissen geht die Kopie von
> der Originaltabelle in ein neues Dokument weiterhin ok, nur die Kopie
> der Kopietabelle geht schief. Es wird kein Datenbereich angelegt sondern
> nur eine Datentabelle. Außerdem ist bei mir das Format der x-Reihe von
> Zahl auf Datum (Stunden) gewechselt. Ich habe im Moment keine Zeit, das
> weiter zu untersuchen. Vielleicht liest Eike mit und kann es erklären.
> Gruß Siegfried

Hallo Siegfried,
so ist das bei mir auch, nur daß x-Reihe von Anfang Datum war und auch
bleibt.
Kopie von Kopie muß auch nicht sein, man kann ja 2x vom Original kopieren.
Wenn ich nächste Woche Zeit habe, werde ich mal die Abhängigkeit von
Original und Kopie im gleichen Dokument untersuchen.

Gruß
Eberhard
Eike Rathke (24.02.2019, 00:44)
* Siegfried Höfner, 2019-02-23 09:13 UTC:
> Nach meinen Erkenntnissen geht die Kopie von
> der Originaltabelle in ein neues Dokument weiterhin ok, nur die Kopie
> der Kopietabelle geht schief. Es wird kein Datenbereich angelegt sondern
> nur eine Datentabelle. Außerdem ist bei mir das Format der x-Reihe von
> Zahl auf Datum (Stunden) gewechselt. Ich habe im Moment keine Zeit, das
> weiter zu untersuchen. Vielleicht liest Eike mit und kann es erklären.


Ich lese zwar gelegentlich mit, aber ohne das Originaldokument und die
genaue Verfahrensweise kann ich gar nichts erklaeren.

Eike
Siegfried Höfner (24.02.2019, 10:03)
Am 23.02.2019 um 23:44 schrieb Eike Rathke:
> * Siegfried Höfner, 2019-02-23 09:13 UTC:
> Ich lese zwar gelegentlich mit, aber ohne das Originaldokument und die
> genaue Verfahrensweise kann ich gar nichts erklaeren.
> Eike

Hallo Eike, ich bin zwar nicht der OP aber da ich deinen Namen ins Spiel
gebracht habe, möchte ich auch antworten. Man kann das auch ohne
Originaldokument darstellen, sowie ich es für den Test gemacht habe.
Calc-Dokument1 / Tabelle1: A1:A10=Zahlen 1-10; B1:B10= 101-110.
Aus A1:B10 ein Diagramm erstellt (in Tabelle1),1.Spalte u.1.Zeile=Namen.
Nun die gesamte Tabelle1 kopiert und in Tabelle2 des gleichen Dokuments
eingefügt. Nun kommt der Knackpunkt: der OP kopiert die Tabelle2 und
fügt sie in ein neues Calc-Dokument2 in Tabelle1 ein. Jetzt ist diese
neue Tabelle aber nicht mehr identisch mit der Tabelle2 aus Dokument1.
Bei mir habe ich festgestellt, daß die Formatierung der x-Reihe
gewechselt hat auf "Datum"; es gibt keinen Datenbereich mehr sondern nur
eine Datenreihe. Eine Änderung der Daten wirkt sich nicht auf das
Diagramm aus.
Wenn ich den OP richtig verstanden habe, könnte er seine Vorgehensweise
auch ändern.

Gruß Siegfried
Eike Rathke (25.02.2019, 01:18)
* Siegfried Höfner, 2019-02-24 08:03 UTC:
> Aus A1:B10 ein Diagramm erstellt (in Tabelle1),1.Spalte u.1.Zeile=Namen.
> Nun die gesamte Tabelle1 kopiert und in Tabelle2 des gleichen Dokuments
> eingefügt. Nun kommt der Knackpunkt: der OP kopiert die Tabelle2 und
> fügt sie in ein neues Calc-Dokument2 in Tabelle1 ein. Jetzt ist diese
> neue Tabelle aber nicht mehr identisch mit der Tabelle2 aus Dokument1.


Kann ich mit 6.0.7 ueber Clipboard Copy&Paste reproduzieren aber nicht
mit 6.1.5. Dort haben alle Diagramme Bezuege auf die jeweils
mitkopierten Daten. Sowohl ueber Tabelle kopieren als auch Clipboard
Copy&Paste. In 6.0.7 funktioniert es wenn die Tabelle per Kontextmenue
auf dem Tabellenreiter in neues Dokument kopiert wird.

> Bei mir habe ich festgestellt, daß die Formatierung der x-Reihe
> gewechselt hat auf "Datum";


In 6.0.7 per Clipboard wenn es bei einem XY-Diagramm eine
Diagramm-interne Datentabelle wird, ja. Ist anscheinend das
Default-Format

Eike
Siegfried Höfner (25.02.2019, 10:35)
Am 25.02.2019 um 00:18 schrieb Eike Rathke:
> * Siegfried Höfner, 2019-02-24 08:03 UTC:
> Kann ich mit 6.0.7 ueber Clipboard Copy&Paste reproduzieren aber nicht
> mit 6.1.5. Dort haben alle Diagramme Bezuege auf die jeweils
> mitkopierten Daten. Sowohl ueber Tabelle kopieren als auch Clipboard
> Copy&Paste. In 6.0.7 funktioniert es wenn die Tabelle per Kontextmenue
> auf dem Tabellenreiter in neues Dokument kopiert wird.
> In 6.0.7 per Clipboard wenn es bei einem XY-Diagramm eine
> Diagramm-interne Datentabelle wird, ja. Ist anscheinend das
> Default-Format
> Eike

Hallo Eike, danke für deine Antwort. Das heißt im Klartext:aufrüsten!
Der OP wird sicher mitlesen und mit einer neueren Version Testen.

Gruß Siegfried
Eberhard Siebel (26.02.2019, 18:37)
Am 25.02.2019 um 09:35 schrieb Siegfried Höfner:
> Am 25.02.2019 um 00:18 schrieb Eike Rathke:
> Hallo Eike, danke für deine Antwort. Das heißt im Klartext:aufrüsten!
> Der OP wird sicher mitlesen und mit einer neueren Version Testen.
> Gruß Siegfried Hallo beide,


habe nochmal getestet. Die Bezugsdaten des Diagramms waren nicht sauber
im gleichen Tabellenblatt. Daher konnte auch die kopierte Tabelle im
neuen Dokument nicht ok sein.
Ich habe nun beide Kopien gelöscht und nochmal neu kopiert und auch
Kopie von Kopie gemacht.
Es hat also bei der allerersten Kopie einen Fehler gegeben, den ich
nicht mehr nachvollziehen kann. Klar ist aber jetzt, daß kopieren eines
Tabellenblattes mit Diagramm und Kopie von Kopie mit dem bei mir
vorhandenen Programm 6.0.7.3 funktioniert.

Danke und Entschuldigung für die viele Mühe!
Eberhard
Siegfried Höfner (27.02.2019, 10:39)
Am 26.02.2019 um 17:37 schrieb Eberhard Siebel:
> Am 25.02.2019 um 09:35 schrieb Siegfried Höfner: [..]
> Es hat also bei der allerersten Kopie einen Fehler gegeben, den ich
> nicht mehr nachvollziehen kann. Klar ist aber jetzt, daß kopieren eines
> Tabellenblattes mit Diagramm und Kopie von Kopie mit dem bei mir
> vorhandenen Programm 6.0.7.3 funktioniert.


Was ich schwer bezweifele. Irgendetwas hast du jetzt anders gemacht aber
hier verschwiegen. Ich kann den Fehler (siehe meine Testbeschreibung)
jederzeit reproduzieren, was mir vom Entwickler(Eike Rathke) auch
bestätigt wurde. An wundersame Heilung glaube ich nicht!

GRuß Siegfried
Eberhard Siebel (28.02.2019, 12:08)
Am 27.02.2019 um 09:39 schrieb Siegfried Höfner:
> Am 26.02.2019 um 17:37 schrieb Eberhard Siebel:
> [..]
> Was ich schwer bezweifele. Irgendetwas hast du jetzt anders gemacht aber
> hier verschwiegen. Ich kann den Fehler (siehe meine Testbeschreibung)
> jederzeit reproduzieren, was mir vom Entwickler(Eike Rathke) auch
> bestätigt wurde. An wundersame Heilung glaube ich nicht!
> GRuß Siegfried Siegfried, was sollte ich verschweigen? Du schreibst:
> Kann ich mit 6.0.7 ueber Clipboard Copy&Paste reproduzieren<

was ist Clipboard? Zwischenablage?
Ich kannte als Oldie den Ausdruck nicht.
Wenn du also folgendes meinst:
Tabellenblatt mit Diagramm markieren, in Zwischenablage kopieren, neues
Tabellenblatt oder neues Calc-Dokument öffnen, aus Zwischenablage hinein
kopieren, dann entsteht ein Diagramm mit Datentabelle und ohne Bezug auf
die Daten im Blatt.
Das ist aber nicht mein ursprünglicher Fehler. Ich wills also nochmal
erklären:
Ursprung war ein Dokument mit mehreren Tabellenblättern. Ein Blatt war
eine Kopie von einem der anderen Blätter. Diese beiden Blätter waren
über den Datenbereich irgendwie miteinander verbunden. In beiden
Blättern konnte ich den Datenbereich ändern. Diese Verbindung der beiden
Blätter kann ich nicht mehr nachvollziehen, da ich sie gelöscht habe.

Wenn ich nun diese fehlerhafte Kopie mit "Tabelle verschieben/kopieren"
in ein neues Dokument kopiert habe, war das neue Diagramm dort nicht
mehr von den Daten des Blattes, sondern von einer Datentabelle abhängig.

Was mit 6.0.7.3 funktioniert ist folgendes:
Ein Blatt mit "Tabelle verschieben/kopieren" ins gleiche Dokument
verschieben. In der Kopie ist dann das Diagramm von den Daten im
gleichen (eigenem) Blatt abhängig. Ebenso bei verschieben in neues Dokument.

Was also geht ist "Tabelle verschieben/kopieren".
Was nicht geht ist "Verschieben über Zwischenablage"

Jetzt habe ich mehr geschrieben als in einem normalen Thread üblich,
aber ich konnte es nicht kürzer ausdrücken.

Gruß
Eberhard
Siegfried Höfner (28.02.2019, 13:56)
Am 28.02.2019 um 11:08 schrieb Eberhard Siebel:
> Am 27.02.2019 um 09:39 schrieb Siegfried Höfner:


> Siegfried, was sollte ich verschweigen? Du schreibst:
> > Kann ich mit 6.0.7 ueber Clipboard Copy&Paste reproduzieren<

> was ist Clipboard? Zwischenablage?


Ja; aber den Begriff habe nicht ich ins Spiel gebracht sondern Eike.
[...]
> Was also geht ist "Tabelle verschieben/kopieren".
> Was nicht geht ist "Verschieben über Zwischenablage"


Jetzt hast du es erkannt! Während wir bei "Kopieren" die Funktion
"Bearbeiten/Kopieren" gemeint haben, hast du von der Funktion im
Tabellenkontextmenue gesprochen, also aneinander vorbei.
Dein anderer Fehler mit den "verknüpften Tabellendaten" kann eigentlich
nur passieren wenn man das Diagramm allein kopiert, dann zeigen beide
Diagramme auf den gleichen Datenbereich.

Gruß Siegfried

Ähnliche Themen