expertenaustausch > comp.* > comp.office-pakete.staroffice.misc

Albrecht Mehl (07.10.2011, 11:55)
Wie bildet man in der Spalte B die Teilsummen der Beträge in Spalte A?
Das Ergebnis soll beispielsweise so aussehen:

10 10
3 13
20 33
17 50
4 54

Im voraus dankbar

A. Mehl
mandri vator (07.10.2011, 12:10)
Am 07.10.2011 11:55, schrieb Albrecht Mehl:
> Wie bildet man in der Spalte B die Teilsummen der Beträge in Spalte A?
> Das Ergebnis soll beispielsweise so aussehen:
> 10 10
> 3 13
> 20 33
> 17 50
> 4 54
> Im voraus dankbar
> A. Mehl


Mit einer Formel, die den Wert aus der selben Spalte (Position -1) mit
dem wert aus der Zelle der vorherigen Spalte gleicher Zeile addiert.

A B
1 10 =$A1
2 3 =$B1+$A2
3 20 =$B2+$A3
etc.
Dirk Weber (07.10.2011, 20:39)
Op 07-10-11 12:10, mandri vator schreef:
> Am 07.10.2011 11:55, schrieb Albrecht Mehl:
> Mit einer Formel, die den Wert aus der selben Spalte (Position -1) mit
> dem wert aus der Zelle der vorherigen Spalte gleicher Zeile addiert.
> A B
> 1 10 =$A1
> 2 3 =$B1+$A2
> 3 20 =$B2+$A3
> etc.

Durch einfaches Copy/Paste kannst Du dann die relativen Referenzen in
die nächste Zeile übernehmen.

Wenn Du in einer Formel gewährleisten willst, dass der Wert einer
bestimmten, absolut positionierten Zelle ausgewertet wird, dann musst Du
diese Zelle benennen und den Namen als Referenz in die Formel setzen.

Im Ergebnis dann sowas wie "=HauDenLukas + $B4" oder so.

Groetjes uit Arft,

Dirk
Wilhelm C. Schütze (09.10.2011, 13:34)
Am 07.10.2011 schrieb Albrecht Mehl:

> Wie bildet man in der Spalte B die Teilsummen der Beträge in Spalte A?
> Das Ergebnis soll beispielsweise so aussehen:
> 10 10
> 3 13
> 20 33
> 17 50
> 4 54
> Im voraus dankbar
> A. Mehl


Sie setzen in das Feld mit der 13 den Ausdruck

=B[Zeilennummer der 10]+A[Zeilennummer der 3].

Dann markieren Sie den Term und kopieren ihn in Spalte B von der ersten
bis zur letzten Zeile. Voraussetzung ist, dass über der ersten Zeile
eine Leerzeile ist, dann passt die Formel auch für die erste Zeile. Die
Leerzeile hat nämlich nur Felder mit Nullwerten.

Wenn Sie das $-Zeichen für die absolute Adressierung verwenden, müssen
Sie jede Zeile editieren - völlig unnötig, weil Calc dann die fixe
Feldadressierung beim Kopieren nicht anpassen darf.

Grüße - Wilhelm
Albrecht Mehl (19.10.2011, 10:05)
Am 07.10.2011 12:10, schrieb mandri vator:
> Am 07.10.2011 11:55, schrieb Albrecht Mehl:
> Mit einer Formel, die den Wert aus der selben Spalte (Position -1) mit
> dem wert aus der Zelle der vorherigen Spalte gleicher Zeile addiert.
> A B
> 1 10 =$A1
> 2 3 =$B1+$A2
> 3 20 =$B2+$A3
> etc.


Dies war die gesuchte Lösung.

Dankbar

A. Mehl
Siegfried Höfner (19.10.2011, 11:53)
"Albrecht Mehl" <invalid>
> Dies war die gesuchte Lösung.

Gegen die Lösung ist nichts einzuwenden aber *lesbarer* ist eine Lösung
mit den Funktionen "Summe" oder "Teilergebnis". Wenn man nur Ergebnisse
haben möchte wenn in Spalte A ein Wert steht, dann kombiniert man das mit
der Funktion "WENN". Als Beispiele (in B1):

=WENN(A1;SUMME($A$1:A1);"") oder
=WENN(A1;TEILERGEBNIS(9;$A$1:A1);"")

und diese Formel in Spalte B nach unten gezogen.

Gruß Siegfried
Ähnliche Themen