expertenaustausch > microsoft.* > microsoft.excel

Gebhard von Busse (13.01.2019, 19:18)
Hi!
Da habe ich eine Liste mit 12 Monatswerten eines Jahres. Daraus hätte ich
gerne heute die Summe von Jan bis Jun und morgen von Jan bis Aug und
irgendwann die Summe von Jan bis Feb.
Steuern möchte ich das über eine Zelle, in die ich mal eine 6 schreibe,
wenn ich gerne die Summe bis Juni hätte und eine 12 für das ganze Jahr,
also den Monat.
Kann mir jemand wohl die Formel sagen, die mir dann die Summe liefert?

Danke und Gruss
GvB
Gebhard von Busse (13.01.2019, 19:35)
Hi Claus,
Danke, aber so konsequent ist meine Tabelle nicht :-(

Von c3 bis n3 Spaltenüberschriften Jan bis Dez (Text).
Darunter c4 bis n4 Umsätze der Monate, darunter c5 bis n5 Kosten und in
Zeilen 6 bis 8 weiter Erlöse und Kosten.
In A1 steht die Monatssteuerzahl (1 bis 12) und in b4 bis b8 soll die
Summenformel stehen, die die Summe der Monate eins bis Steuerzahl
ermittelt.
[..]
Claus Busch (15.01.2019, 14:00)
Hallo Gebhard,

Am Sun, 13 Jan 2019 18:18:00 +0100 schrieb Gebhard von Busse:

> Da habe ich eine Liste mit 12 Monatswerten eines Jahres. Daraus hätte ich
> gerne heute die Summe von Jan bis Jun und morgen von Jan bis Aug und
> irgendwann die Summe von Jan bis Feb.
> Steuern möchte ich das über eine Zelle, in die ich mal eine 6 schreibe,
> wenn ich gerne die Summe bis Juni hätte und eine 12 für das ganze Jahr,
> also den Monat.
> Kann mir jemand wohl die Formel sagen, die mir dann die Summe liefert?


die Datumswerte in A2 abwärts, die entsprechenden Werte ab B2 und die
Monatszahl in E1. Dann probiere mal:
=SUMMENPRODUKT(--(A2:A400>=DATUM(2019;1;1));--(A2:A400<=DATUM(2019;E1+1;0));B2:B400)

Mit freundlichen Grüßen
Claus
Claus Busch (15.01.2019, 14:06)
Hallo nochmals,

Am Tue, 15 Jan 2019 13:00:37 +0100 schrieb Claus Busch:

> =SUMMENPRODUKT(--(A2:A400>=DATUM(2019;1;1));--(A2:A400<=DATUM(2019;E1+1;0));B2:B400)


oder:
=SUMMENPRODUKT(--(A2:A400>=A2);--(A2:A400<=MONATSENDE(A2;E1-1));B2:B400)

Mit freundlichen Grüßen
Claus
Claus Busch (15.01.2019, 14:54)
Hallo Gebhard,

Am Tue, 15 Jan 2019 13:06:55 +0100 schrieb Claus Busch:

>> =SUMMENPRODUKT(--(A2:A400>=DATUM(2019;1;1));--(A2:A400<=DATUM(2019;E1+1;0));B2:B400)

> oder:
> =SUMMENPRODUKT(--(A2:A400>=A2);--(A2:A400<=MONATSENDE(A2;E1-1));B2:B400)


wenn du nur Daten aus dem aktuellen Jahr hast, kannst du den Teil mit >=
in der Formel auch weglassen:
=SUMMENPRODUKT(--(A2:A400<=DATUM(2019;E1+1;0));B2:B400)
oder
=SUMMENPRODUKT(--(A2:A400<=MONATSENDE(A2;E1-1));B2:B400)

Mit freundlichen Grüßen
Claus
Claus Busch (15.01.2019, 17:05)
Hallo Gebhard,

Am Sun, 13 Jan 2019 18:35:00 +0100 schrieb Gebhard von Busse:

> Von c3 bis n3 Spaltenüberschriften Jan bis Dez (Text).
> Darunter c4 bis n4 Umsätze der Monate, darunter c5 bis n5 Kosten und in
> Zeilen 6 bis 8 weiter Erlöse und Kosten.
> In A1 steht die Monatssteuerzahl (1 bis 12) und in b4 bis b8 soll die
> Summenformel stehen, die die Summe der Monate eins bis Steuerzahl
> ermittelt.


dann probiere es in B4 mit:
=SUMME(BEREICH.VERSCHIEBEN(C4;;;;$A$1))
und herunterziehen.

Mit freundlichen Grüßen
Claus
Gebhard von Busse (15.01.2019, 17:34)
Danke Claus, das war genau das, was ich suchte!
[..]
Ähnliche Themen