expertenaustausch > microsoft.* > microsoft.virtualpc

Axel Pötzinger (29.04.2011, 17:22)
Hallo NG,

ich hab mich jetzt mal dazu durchgerungen Virtual PC auf meinem
W7-Rechner zu installieren.
Ich hab dann XP-SP3 dort installiert, und das Ganze läuft soweit auch
sehr gut.
Zunächst ergeben sich für mich 2 Fragen:
1) Als Grafikkarte weist mir der Gerätemanager "Virtual PC Integration
Components S3 Trio 32/64"aus. Physikalisch habe ich eine ATI-Radeon
9600-er. Wenn ich das richtig verstanden habe, dann installiert Virtual
PC einen Standard-Treiber. Das hat hier den Effekt, dass ich nur 800x600
habe und 16 Bit. Wie kann ich das ändern?
2) Im Gerätemanager habe ich ein Fragezeichen vor "Andere Geräte" und in
dem Zweig 3x den Eintrag "Virtual PC Integration Device". Was muss ich
mir dazu vorstellen? Sind das Geräte, die Virtual PC nicht erkennen
kann? Oder wie kann ich das auflösen?

Danke schon mal.

Gruß
Axel
Artur Kawa (29.04.2011, 19:05)
Hallo,

installier die Virtual PC Tools. Schau die Menüleiste der
laufenden VM durch. Dort ist so ein Menüpunkt drin.

Dann kannst Du auch andere Auflösungen einstellen und
das andere dürfte sich auch erledigt haben.

Gruss
Artur
Axel Pötzinger (30.04.2011, 14:26)
Am 29.04.2011 19:05, schrieb Artur Kawa:
> Hallo,
> installier die Virtual PC Tools. Schau die Menüleiste der
> laufenden VM durch. Dort ist so ein Menüpunkt drin.
> Dann kannst Du auch andere Auflösungen einstellen und
> das andere dürfte sich auch erledigt haben.


Diesen Menüpunkt gibt es bei mir nicht.
Kann das daran liegen, dass ich "Windows Virtual PC" und nicht "Virtual
PC" habe?
Was ich noch festgestellt habe, ist, dass wenn ich das Fenster, in dem
die VM läuft, von der Größe her verändere, dann sich auch die Auflösung
verändert. Allerdings kann ich nach wie vor nur 16-Bit auswählen (was
anderes gibts da nicht), und eine feste Auflösung besteht schon gar
nicht, so wie ich das von Windows gewohnt bin.
Ich hab schon ergoogelt, ich solle doch die sog. Integrationsfeatures
deaktivieren, dann die Auflösung so einstellen wie gewünscht (da hab ich
dann auch 32 Bit), und dann die Integrationsfeatures wieder aktivieren.
Funktioniert soweit auch, nur hab ich dann zwar die gewünschte
Auflösung, aber die verändert sich wieder, wenn ich die Fenstergröße
ändere, und zudem gibt es fix wieder nur 16 Bit nachdem ich die IF
wieder aktiviert habe.
Sagt dir das noch was?

Gruß
Axel
Artur Kawa (01.05.2011, 03:31)
"Axel Pötzinger" <a.poet> schrieb ...
> Am 29.04.2011 19:05, schrieb Artur Kawa:
> Diesen Menüpunkt gibt es bei mir nicht.


Schau doch nochmals nach. In der Virtuellen Maschine selbst.
Der Menüpukt "Aktion" und der Untermenüpunkt "Virtual Machine
Additions installieren / aktualisieren..."

Schau mal hier. Das Bild ist in Englisch, aber der Menüpunkt
an gleicher Position:

<http://www.linglom.com/images/virtualization/VirtualPC/PartV/3.png>

Ist der Menüpunkt wirklich bei Dir nicht da?

> Kann das daran liegen, dass ich "Windows Virtual PC" und nicht "Virtual
> PC" habe?


Nein, das ist das gleiche.

> Was ich noch festgestellt habe, ist, dass wenn ich das Fenster, in dem die
> VM läuft, von der Größe her verändere, dann sich auch die Auflösung
> verändert. Allerdings kann ich nach wie vor nur 16-Bit auswählen (was
> anderes gibts da nicht), und eine feste Auflösung besteht schon gar nicht,
> so wie ich das von Windows gewohnt bin.


Das habe ich nie ausprobiert, bevor ich die Additions installiert habe,
daher kann ich nichts dazu sagen.

> Ich hab schon ergoogelt, ich solle doch die sog. Integrationsfeatures
> deaktivieren, dann die Auflösung so einstellen wie gewünscht (da hab ich
> dann auch 32 Bit), und dann die Integrationsfeatures wieder aktivieren.
> Funktioniert soweit auch, nur hab ich dann zwar die gewünschte Auflösung,
> aber die verändert sich wieder, wenn ich die Fenstergröße ändere, und
> zudem gibt es fix wieder nur 16 Bit nachdem ich die IF wieder aktiviert
> habe.
> Sagt dir das noch was?


Das sagt mir auch nichts.

Also ich habe Windows 7 x64 und Windows Server 2008 R2 x64
als Host-Betriebssystem laufen - jeweils mit SP1.

Installiert habe ich die Microsoft Windows Virtual PC x64 mit SP1.
Das 32-Bit Virtual PC ist aber ehe von aussen sichtbar das gleiche,
also gleiche Menüs, etc.

Als Gast-Betriebssystem habe ich das Windows XP installiert.

Aber auch unter Vista als Host-Betriebssystem und Virtual PC 2007
war der Menüpunkt vorhanden.

Schau Dir bitte das Bild an und sag mir, ob Du den Menüpunkt
wirklich bei Dir nicht vorfindest.

Gruss
Artur
Axel Pötzinger (03.05.2011, 13:34)
Am 01.05.2011 03:31, schrieb Artur Kawa:

> Schau doch nochmals nach. In der Virtuellen Maschine selbst.
> Der Menüpukt "Aktion" und der Untermenüpunkt "Virtual Machine
> Additions installieren / aktualisieren..."


Nein, diesen Menüpunkt hab ich bei mir nicht.
Mir fällt halt wieder auf, dass dein Screenshot von VirtualPC-2007
spricht, was ich ja nicht habe.
Das andere ist, dass ich Windows Virtual PC nicht nackt starten kann,
nur die darin installierte VM.
Vielleicht habe ich ja was falsch verstanden, und Windows Virtual PC
läuft eigentlich nicht unter W7-HP.
Jedenfalls gibt es besagten Menüpunkt bei mir gar nicht.
Wenn ich versuch Windows Virtual PC einfach so zu starten, dann kriege
ich nur einen Art Explorer-Ordner, in dem die vorhanden VMs aufgelistet
sind. Also so einen leeren WVPC krieg ich gar nicht.
Irgendwie hab ich den Eindruck wir beide reden von Äpfel und Birnen.
Ich kann mich erinnern, dass ich zu XP-Zeiten mal Virtual PC installiert
hatte, und da sah das so aus, dass man Virtual PC startete, und da das
"Programm" vor sich hatte und dann erst die VM startete. Hier läuft das
anders.

Gruß
Axel
Ralf Beudel (03.05.2011, 16:04)
Axel Pötzinger schrieb:
> Am 01.05.2011 03:31, schrieb Artur Kawa:
> Nein, diesen Menüpunkt hab ich bei mir nicht.
> Mir fällt halt wieder auf, dass dein Screenshot von VirtualPC-2007
> spricht, was ich ja nicht habe.
> Das andere ist, dass ich Windows Virtual PC nicht nackt starten kann,
> nur die darin installierte VM.
> Vielleicht habe ich ja was falsch verstanden, und Windows Virtual PC
> läuft eigentlich nicht unter W7-HP.
> Jedenfalls gibt es besagten Menüpunkt bei mir gar nicht.


Hallo,

> Wenn ich versuch Windows Virtual PC einfach so zu starten, dann kriege
> ich nur einen Art Explorer-Ordner, in dem die vorhanden VMs aufgelistet
> sind. Also so einen leeren WVPC krieg ich gar nicht.


steht da nicht oben in der Leiste "neuen virtuellen Computer erstellen" ?
Gruß,
Ralf
[..]
Axel Pötzinger (03.05.2011, 17:54)
Am 03.05.2011 16:04, schrieb Ralf Beudel:

> steht da nicht oben in der Leiste "neuen virtuellen Computer erstellen" ?


Ja doch, steht da schon. Da kann ich dem neuen virtuellen Computer dann
einen Namen geben, den der vmcx-Datei, Arbeitsspeicher zuweisen und den
Speicherort bestimmten. Mehr aber auch nicht.

Gruß
Axel
Ähnliche Themen