expertenaustausch > comp.os.* > comp.os.unix.linux.hardware

Georg Schwarz (16.03.2020, 23:06)
Ich habe hier einen alten MSI GX600 (MS-163A) Laptop. Er hat eine
eingebaute Webcam. Mit lsusb wird da allerdings nichts angezeigt.
Der Laptop hat eine Dedizierte "Webcam-Taste". Laut Handbuch
() kann man damit die
Webcam ein- und ausschalten (ähnlich wie die "Funk-Taste", die WLAN und
Bluetooth ein und ausschaltet, was unter Linux funktioniert; wenn es
ausgeschaltet ist, wird mit lsusb auch kein Bluetoothmodul ausgegeben).

Bei anderen MSI-Modellen ist das wohl FN-F6, das dort auch eintsprechend
beschriftet ist.

Gibt es eine Möglichkeirt, auf diesem Modell unter Linux die Webcam zu
nutzen? bzw. zunächst mal überhaupt nur sichtbar zu machen? Ich vermute
mal dass die Webcam über USB angeschlossen ist und daher nach
Aktivierung mit lsusb aufgelistet werden sollte.
Tim Ritberg (16.03.2020, 23:32)
Am 16.03.20 um 22:06 schrieb Georg Schwarz:
[..]
> nutzen? bzw. zunächst mal überhaupt nur sichtbar zu machen? Ich vermute
> mal dass die Webcam über USB angeschlossen ist und daher nach
> Aktivierung mit lsusb aufgelistet werden sollte.


Hast du das im Kernel? CONFIG_MSI_LAPTOP bzw MSI_WMI?

Say Y here if you want to support WMI-based hotkeys on MSI laptops.

Tim
Georg Schwarz (17.03.2020, 23:33)
Tim Ritberg <tim> wrote:

> Hast du das im Kernel? CONFIG_MSI_LAPTOP bzw MSI_WMI?
> Say Y here if you want to support WMI-based hotkeys on MSI laptops.


ich verwende den Standard Kernel von Xubuntu LTS, Linux 5.3.0.
Im Fall von modprobe msi-wmi kommt die Fehlermeldung "could not insert
'msi_wmi': No such device" und im Log "msi_wmi: This machine does not
have neither MSI-hotkeys nor backlight through WMI."
Müsste ich zunächst manuell ein bestimmtes Device anlegen?

Wenn ich mir

ansehe (sind das die korrekten aktuellen Quellen?), dann finde ich dort:

/* These keys work without WMI. Ignore them to avoid double keycodes */

....
{ KE_IGNORE, WIND_KEY_CAMERA, {KEY_CAMERA} },
....

scheint also für die Webcam Taste nichts zu bringen. Aber vielleicht
gilt das nur für andere Modelle, bei denen FN+F6 verwendet wird, keine
dedizierte physische Webcam-Taste?
So zumindest legt die Bemerkung im Quelltext es nahe:

WIND_KEY_CAMERA, /* Fn+F6 webcam toggle */

modprobe msi-laptop geht ohne Fehlermeldung durch.
Es wird auch sparse-keymap geladen.
lsmod zeigt danach msi_laptop bei sparse_keymap und video.

Die Webcam Taste scheint dennoch weiterhin keinen Unterschied zu machen,
weder findet cheese eine Kamera noch wird mit lsusb eine angezeigt.

Zumindest nach den Dokus/Quellen, die ich finden konnte, ist msi_laptop
nur (?) für den MSI S270 Laptop. Dabei handelt es sich offenbar um ein
noch älteres Modell, das auch keine eingebaute Webcam hatte.

Gibt es eine andere Möglichkeit, die Webcam zu aktivieren?
Tim Ritberg (17.03.2020, 23:52)
Am 17.03.20 um 22:33 schrieb Georg Schwarz:

> Gibt es eine andere Möglichkeit, die Webcam zu aktivieren?


Georg Schwarz (18.03.2020, 01:19)
Tim Ritberg <tim> wrote:

> Am 17.03.20 um 22:33 schrieb Georg Schwarz:
> > Gibt es eine andere Möglichkeit, die Webcam zu aktivieren?

>
> n-event


danke für en Hinweis.
cat /proc/bus/input/devices zeigt leider nichts, was nach Kamera
aussieht.
wenn ich evtest llaufen lasse und AT translated set 2 keyboard als
Quelle auswähle, erhalte ich beim Druck auf die Webcam-Taste zweimal
(das ist aber anscheinend bei allen Tasten der Fall) EV_MSC, MSC_SCAN
und EV_KEY, KEY_SEARCH.

Die Taste wird also als Suchtaste erkannt.
Georg Schwarz (18.03.2020, 22:25)
Georg Schwarz <georg.schwarz> wrote:

> danke für en Hinweis.
> cat /proc/bus/input/devices zeigt leider nichts, was nach Kamera
> aussieht.
> wenn ich evtest llaufen lasse und AT translated set 2 keyboard als
> Quelle auswähle, erhalte ich beim Druck auf die Webcam-Taste zweimal
> (das ist aber anscheinend bei allen Tasten der Fall) EV_MSC, MSC_SCAN
> und EV_KEY, KEY_SEARCH.
> Die Taste wird also als Suchtaste erkannt.


das scheint schon früher jemand erkannt zu haben, aber eine Ursache oder
Lösung findet man nicht:

Georg Schwarz (18.03.2020, 22:42)
Georg Schwarz <georg.schwarz> wrote:

> das scheint schon früher jemand erkannt zu haben, aber eine Ursache oder
> Lösung findet man nicht:
>


hier hat jemand eine Lösung beschrieben:



kann jemand rauslesen, was die darunterliegende Ursache ist und wie man
das Problem ohne Voodoo beseitigt?
Ähnliche Themen