expertenaustausch > linux.debian.user.german

Thomas Letzner (20.09.2005, 23:40)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hallo

da mir WEP mittlerweile echt zu unsicher geworden ist habe ich
überlegt und bin dabei auf WPA gestoßen, zunächst einmal möchte ich
darstellen wie ich den Router eingerichtet habe. Da ich die Karte
nicht passend konfiguriert bekomme.
Die Firmwaere auf dem WRT ist die von Sveasoft, unter
Wireless/Security habe folgendes eingestellt:
Security Mode: WPA Pre-Shared Key
WPA Algorithms: TKIP+AES
WPA Shared Key: ***Passwort im plaintext***
Group Key Renewal: 3600 Seconds

Auf dem Notebook habe ich folgende wpa_supplicant.conf:

ctrl_interface=/var/run/wpa_supplicant
network={
ssid="dweeb"
#psk="***Passwort im plaintext***"
psk=***Passwort im hexformat***
}

Zum testen habe ich wpa_supplicant nicht daemon gestartet und zwar mit
diesem Befehl:
wpa_supplicant -w -i eth1 -c /etc/wpa_supplicant.conf -Dipw -d -t

Das Ergebnis ist folgendes:
root@mobil:/home/thomas # wpa_supplicant -w -i eth1 -c
/etc/wpa_supplicant.conf -Dipw -d -t
Sep 20 23:22:21.270436: Initializing interface 'eth1' conf
'/etc/wpa_supplicant.conf' driver 'ipw'
Sep 20 23:22:21.270603: Configuration file '/etc/wpa_supplicant.conf'
- -> '/etc/wpa_supplicant.conf'
Sep 20 23:22:21.270636: Reading configuration file
'/etc/wpa_supplicant.conf'
Sep 20 23:22:21.270691: ctrl_interface='/var/run/wpa_supplicant'
Sep 20 23:22:21.270741: Priority group 0
Sep 20 23:22:21.270766: id=0 ssid='dweeb'
Sep 20 23:22:21.270790: Initializing interface (2) 'eth1'
Sep 20 23:22:21.280006: EAPOL: SUPP_PAE entering state DISCONNECTED
Sep 20 23:22:21.280107: EAPOL: KEY_RX entering state NO_KEY_RECEIVE
Sep 20 23:22:21.280182: EAPOL: SUPP_BE entering state INITIALIZE
Sep 20 23:22:21.280258: EAP: EAP entering state DISABLED
Sep 20 23:22:21.280386: EAPOL: External notification - portEnabled=0
Sep 20 23:22:21.280485: EAPOL: External notification - portValid=0
Sep 20 23:22:21.280593: wpa_driver_ipw_init is called
Sep 20 23:22:21.304586: Own MAC address: 00:09:43:f9:22:54
Sep 20 23:22:21.304703: wpa_driver_ipw_set_wpa: enabled=1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Sep 20 23:22:21.304930: wpa_driver_ipw_set_key: alg=none key_idx=0
set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Sep 20 23:22:21.305095: Failed to set encryption.
Sep 20 23:22:21.305165: wpa_driver_ipw_set_key: alg=none key_idx=1
set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Sep 20 23:22:21.305326: Failed to set encryption.
Sep 20 23:22:21.305395: wpa_driver_ipw_set_key: alg=none key_idx=2
set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Sep 20 23:22:21.305555: Failed to set encryption.
Sep 20 23:22:21.305637: wpa_driver_ipw_set_key: alg=none key_idx=3
set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Sep 20 23:22:21.326082: Failed to set encryption.
Sep 20 23:22:21.326169: wpa_driver_ipw_set_countermeasures: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Sep 20 23:22:21.326325: wpa_driver_ipw_set_drop_unencrypted: enabled=1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Sep 20 23:22:21.326504: Setting scan request: 0 sec 100000 usec
Sep 20 23:22:21.326794: Wireless event: cmd=0x8b06 len=8
Sep 20 23:22:21.326894: RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
Sep 20 23:22:21.326987: RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
Sep 20 23:22:21.427716: Starting AP scan (broadcast SSID)
Sep 20 23:22:24.441113: Scan timeout - try to get results
Sep 20 23:22:24.441867: Received 293 bytes of scan results (2 BSSes)
Sep 20 23:22:24.441901: Scan results: 2
Sep 20 23:22:24.441924: Selecting BSS from priority group 0
Sep 20 23:22:24.442105: 0: 00:11:6b:b0:26:74 ssid='network2'
wpa_ie_len=0 rsn_ie_len=0
Sep 20 23:22:24.442144: skip - no WPA/RSN IE
Sep 20 23:22:24.442167: 1: 00:12:17:d4:28:8e ssid='dweeb' wpa_ie_len=0
rsn_ie_len=0
Sep 20 23:22:24.442202: skip - no WPA/RSN IE
Sep 20 23:22:24.442226: No suitable AP found.

Ich schließe daraus, dass das Netzwerk dweeb offensichtlich gefunden
wird dieses aber entgegen der Einstellungen im Router nicht mit WPA
arbeitet oder?
Kann mir jemand daraus sagen wo es hakt?
Friedrich Dimmling (21.09.2005, 09:10)
Hallo Thomas

Am Dienstag, den 20.09.2005, 23:40 +0200 schrieb Thomas Letzner:

[..]
> #psk="***Passwort im plaintext***"
> psk=***Passwort im hexformat***
> }


Bei mir sieht die Konfigurationsdatei folgendermaßen aus:

fd@acer:~$ cat /etc/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ap_scan=2
network={
ssid="bergm68"
scan_ssid=1
group=TKIP
pairwise=TKIP
#psk="*******"
psk="Hex Key "
key_mgmt=WPA-PSK
proto=WPA
}

Es mag durchaus sein, daß einige Angaben nicht notwendig sind, aber mit
den Minimalangaben wie in Deiner Datei ging's bei mir nicht.

> Zum testen habe ich wpa_supplicant nicht daemon gestartet und zwar mit
> diesem Befehl:
> wpa_supplicant -w -i eth1 -c /etc/wpa_supplicant.conf -Dipw -d -t
> Das Ergebnis ist folgendes:
> root@mobil:/home/thomas # wpa_supplicant -w -i eth1 -c
> /etc/wpa_supplicant.conf -Dipw -d -t


Was macht die Option -t, kann ich bei mir in man wpa_supplicant nicht
finden.

Friedrich
Thomas Kosch (21.09.2005, 09:40)
On Day 44 of Bureaucracy 3171, Thomas Letzner wrote:

[...]

> Zum testen habe ich wpa_supplicant nicht daemon gestartet und zwar mit
> diesem Befehl:
> wpa_supplicant -w -i eth1 -c /etc/wpa_supplicant.conf -Dipw -d -t
> Das Ergebnis ist folgendes:
> root@mobil:/home/thomas # wpa_supplicant -w -i eth1 -c
> /etc/wpa_supplicant.conf -Dipw -d -t


[...]

[..]
> Sep 20 23:22:21.326169: wpa_driver_ipw_set_countermeasures: enabled=0
> ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
> Sep 20 23:22:21.326325: wpa_driver_ipw_set_drop_unencrypted: enabled=1


[...]

Welcher Kernel, welcher Treiber, wie gebaut, welches wpasupplicant?

ttyl8er, t.k.
Thomas Wegner (21.09.2005, 11:30)
Am Dienstag, den 20.09.2005, 23:29 +0200 schrieb Thomas Letzner:
Hi Thomas!

Ein etwas merkwürdiges Verhalten mit WPA habe ich auch schon
festgestellt.
Folgende Hardware:
1) WRT54G-Router mit WPA und TKIP und Sveasoft (Alchemy 3.37.6.8)
2) Netgear WG511 PCMCIA arbeitet nicht mit WPA-Einstellung (nur unter
Windows getestet)
3) Netgear WG311 PCI arbietet mit Linuxant-Treiber und WPA
4) Squeezebox2 (Audio Streaming Client), keine Ahnung welcher Chip drauf
ist, arbeitet nicht mit WPA. Ich habe aber gehört, dass andere diesen
Client mit WPA betreiben.

Sieht für mich so aus, als ob sich da nicht alle nach dem Standard
halten. :-((
Georg Lohrer (21.09.2005, 12:40)
Am Dienstag, 20. September 2005 23:29 schrieb Thomas Letzner:
> Hallo
> da mir WEP mittlerweile echt zu unsicher geworden ist habe ich
> überlegt und bin dabei auf WPA gestoßen, zunächst einmal möchte ich
> darstellen wie ich den Router eingerichtet habe. Da ich die Karte
> nicht passend konfiguriert bekomme.
> Die Firmwaere auf dem WRT ist die von Sveasoft, unter
> Wireless/Security habe folgendes eingestellt:
> Security Mode: WPA Pre-Shared Key
> WPA Algorithms: TKIP+AES
> WPA Shared Key: ***Passwort im plaintext***


Für die Wireless-Security habe ich folgende Einstellungen:

Security Mode: WPA Pre-Shared Key
WPA Algorithm: TKIP
WPA Shared Key: d36a8cef0.......e697c2911
Group Key Renewal: 3600

Also kein plain-text im shared-key!

> Group Key Renewal: 3600 Seconds
> Auf dem Notebook habe ich folgende wpa_supplicant.conf:
> ctrl_interface=/var/run/wpa_supplicant
> network={
> ssid="dweeb"
> #psk="***Passwort im plaintext***"
> psk=***Passwort im hexformat***
> } Okay, da der key bei mir ebenfalls im hexformat drin.


> Zum testen habe ich wpa_supplicant nicht daemon gestartet und zwar mit
> diesem Befehl:
> wpa_supplicant -w -i eth1 -c /etc/wpa_supplicant.conf -Dipw -d -t


Ach, Du verwendest auch den Centrino, dann kannst du mit:

echo 0x3ff >/sys/bus/pci/drivers/ipw2100/debug_level
cat /sys/bus/pci/drivers/ipw2100/debug_level 0x000003FF
tail -f /var/log/debug

ein bißchen mehr sehen, was tatsächlich vor sich geht.

> ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
> Sep 20 23:22:21.305326: Failed to set encryption.
> Sep 20 23:22:21.305395: wpa_driver_ipw_set_key: alg=none key_idx=2
> set_tx=0 seq_len=0 key_len=0
> ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported


Diese ioctl-Fehler rühren daher, daß der wpa_supplicant den ipw-Treibermit
ioctl-calls aufruft, die dieser nicht kennt.
Ich hatte das gleiche Problem und konnte es erste beheben, als ich den
wpa_supplicant und den ipw-Treiber selbst übersetzt hatte.

Ciao, Georg
Jan Luehr (21.09.2005, 17:00)
ja hallo erstma,...

Am Dienstag, 20. September 2005 23:29 schrieb Thomas Letzner:
[..]
> #psk="***Passwort im plaintext***"
> psk=***Passwort im hexformat***
> }


Ok, bei mir steht dort:
network={
ssid="jan_luehr"
psk="Kennwort_im_Klartext"
priority=5
}

> Zum testen habe ich wpa_supplicant nicht daemon gestartet und zwar mit
> diesem Befehl:
> wpa_supplicant -w -i eth1 -c /etc/wpa_supplicant.conf -Dipw -d -t


ich schreib zwar immer -D ipw, aber auch egal. Du hast einen Centrino?

[..]
> Sep 20 23:22:21.280386: EAPOL: External notification - portEnabled=0
> Sep 20 23:22:21.280485: EAPOL: External notification - portValid=0
> Sep 20 23:22:21.280593: wpa_driver_ipw_init is called


Das sieht für mich nach einem WPA-Radius aus... da bin ich mir aber gerade
nicht so sicher.

> Sep 20 23:22:21.304586: Own MAC address: 00:09:43:f9:22:54
> Sep 20 23:22:21.304703: wpa_driver_ipw_set_wpa: enabled=1
> ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
> Sep 20 23:22:21.304930: wpa_driver_ipw_set_key: alg=none key_idx=0
> set_tx=0 seq_len=0 key_len=0
> ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
> Sep 20 23:22:21.305095: Failed to set encryption.


Treiber richtig gebaut? Welche Version?

> Ich schließe daraus, dass das Netzwerk dweeb offensichtlich gefunden
> wird dieses aber entgegen der Einstellungen im Router nicht mit WPA
> arbeitet oder?
> Kann mir jemand daraus sagen wo es hakt?


Wie gut ist der Empfang? Klappt eine Verbindung mit Windows oder anderen
Rechner?

Keep smiling
yanosu
Thomas Letzner (21.09.2005, 18:50)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Nabend

Jan Luehr schrieb:

> Ok, bei mir steht dort: network={ ssid="jan_luehr"
> psk="Kennwort_im_Klartext" priority=5 }


Also hab ich nun auch so geschrieben.

>> Zum testen habe ich wpa_supplicant nicht daemon gestartet und
>> zwar mit diesem Befehl: wpa_supplicant -w -i eth1 -c
>> /etc/wpa_supplicant.conf -Dipw -d -t

> ich schreib zwar immer -D ipw, aber auch egal. Du hast einen
> Centrino?


Nein, ich habe eine Cisco Aironet 350 Series, keinen Centrino.
Ich gehe nun fast davon aus das der falsche Treiber im Spiel ist.
Leider weiß ich nicht welcher der richtige Treiber für die Cisco ist.

> Treiber richtig gebaut? Welche Version?


Treiber hab ich nicht gebaut, wer wohl in der Standardinstallation
schon drin.

>> Ich schließe daraus, dass das Netzwerk dweeb offensichtlich
>> gefunden wird dieses aber entgegen der Einstellungen im Router
>> nicht mit WPA arbeitet oder? Kann mir jemand daraus sagen wo es
>> hakt?

> Wie gut ist der Empfang? Klappt eine Verbindung mit Windows oder
> anderen Rechner?


Die Verbindung ist kein Problem, habe zum Testen den AP unmittelbar
neben dem Laptop stehen.

> Keep smiling yanosu


Mfg Thomas
Andreas Pakulat (21.09.2005, 19:10)
On 21.09.05 18:43:28, Thomas Letzner wrote:
> Nein, ich habe eine Cisco Aironet 350 Series, keinen Centrino.
> Ich gehe nun fast davon aus das der falsche Treiber im Spiel ist.
> Leider weiß ich nicht welcher der richtige Treiber für die Cisco ist.


Dann solltest du erstmal rauskriegen welches der richtige Treiber ist.
Die geladenen Module kannst du dir mit lsmod anzeigen lassen.

Andreas
Jan Luehr (21.09.2005, 19:30)
ja hallo erstmal,...

Am Mittwoch, 21. September 2005 18:43 schrieb Thomas Letzner:
> Nabend
> Jan Luehr schrieb:
> Also hab ich nun auch so geschrieben.
> Nein, ich habe eine Cisco Aironet 350 Series, keinen Centrino.
> Ich gehe nun fast davon aus das der falsche Treiber im Spiel ist.
> Leider weiß ich nicht welcher der richtige Treiber für die Cisco ist.


Dann liegt hier der Hund begraben. Schau mal mit lsmod nach, welcher Treiber
geladen ist. Dann sage dies wpa_supplicant.
hostap = Host AP driver (Intersil Prism2/2.5/3)
prism54 = Prism54.org driver (Intersil Prism GT/Duette/Indigo)
madwifi = MADWIFI 802.11 support (Atheros, etc.)
atmel = ATMEL AT76C5XXx (USB, PCMCIA)
wext = Linux wireless extensions (generic)
ndiswrapper = Linux ndiswrapper
ipw = Intel ipw2100/2200 driver

Ich tippe mal, dass wext bei dir das richtige ist.

Keep smiling
yanosz
Ähnliche Themen