expertenaustausch > microsoft.* > microsoft.excel

Tobias K (01.07.2004, 22:50)
Hallo !

Zunächst mal vielen Dank für die schnellen Antworten auf meine letzten
Postings ! Coole NG

Die ganzen Infos brauche ich, um Samples (zum Musikmachen) zu sortieren.
Jetzt bräuchte ich eine Möglichkeit, ein bestimmtes Zeichen zu kopieren.

Ein Dateiname:
GIS0C212.WAV

Das 5.Zeichen von links gibt die Tonart an - in dem Fall C.

Jetzt will ich folgende Spalten anlegen.
Name Tonart
GIS0C212 C

Und das C soll "formelgesteuert" gefunden werden.

Jemand eine Idee ?

Gruß

Tobias
Herbert Taferner (01.07.2004, 22:57)
Hallo Tobias,

wenn Dateiname in Spalte A steht

in B1 =RECHTS(LINKS(A1;5);1)

mfg Herbert
Dimo Tabken (01.07.2004, 23:07)
Tobias K schrieb am 01.07.2004 um 22:50:53 Uhr:

> Ein Dateiname:
> GIS0C212.WAV
> Das 5.Zeichen von links gibt die Tonart an - in dem Fall C.
> Jetzt will ich folgende Spalten anlegen.
> Name Tonart
> GIS0C212 C


Hi Tobias,

=WENN(A1="";"";RECHTS(LINKS(A1;5);1))

prüft, ob in A1 überhaupt was drinsteht und schreibt dann das fünfte
Zeichen von Links in die Zielzelle.

Vielleicht hilfts Dir ja ;-)

Schönen Abend
Jean Ruch (01.07.2004, 23:11)
"Tobias K" <tommek76NOSPAM> schrieb im Newsbeitrag
news:u071
[..]
> Jemand eine Idee ?
> Gruß
> Tobias


Hallo Tobias,

ergänzend / alternativ
wenn der Dateiname in A1 steht:
in irgendeiner Zelle
Für den Namen: = LINKS(A1;8)
Für die Tonart: = TEIL(A1;5;1)

mit freundlichem Gruß

Jean
Dimo Tabken (01.07.2004, 23:23)
Jean Ruch schrieb am 01.07.2004 um 23:11:30 Uhr:

> Für die Tonart: = TEIL(A1;5;1)


Hi Jean,

*diese* Funktion hab ich doch wirklich bisher übersehen ;-(
Vielen Dank für diesen Tipp!
Ähnliche Themen