expertenaustausch > microsoft.* > microsoft.excel

MrArtifex (20.12.2007, 13:12)
Hi @all:

ich habe eine Frage: Ich will eine Zelle so formatieren, dass wenn ich einen
Wert manuell eintippe die Formel weg ist und der manuelle Wert genommen
wird. Die Formel sonst bezieht sich auf zwei andere Zellen. Das heißt wenn
beispielsweise Zelle A1 und B1 ausgefüllt sind, dann soll in Zelle C1 die
Zellen A1 und B1 miteinander multipliziert werden. Wenn A1 oder B1 nicht
ausgefüllt sind, dann will ich C1 manuell eingeben können. Die Formel soll
aber zukünftig in der Zelle drin bleiben fürs nächste mal.

Weiß da jemand ne Lösung
Gruß
Arti
Klaus \Perry\ Pago (20.12.2007, 13:31)
Hallo Arti,

"MrArtifex" <billgates> schrieb im Newsbeitrag
news:fda3
> Hi @all:
> ich habe eine Frage: Ich will eine Zelle so formatieren, dass wenn ich
> einen Wert manuell eintippe die Formel weg ist und der manuelle Wert
> genommen wird. Die Formel sonst bezieht sich auf zwei andere Zellen. Das
> heißt wenn beispielsweise Zelle A1 und B1 ausgefüllt sind, dann soll in
> Zelle C1 die Zellen A1 und B1 miteinander multipliziert werden. Wenn A1
> oder B1 nicht ausgefüllt sind, dann will ich C1 manuell eingeben können.
> Die Formel soll aber zukünftig in der Zelle drin bleiben fürs nächste mal.


als Formellösung sehe ich nur den Weg über eine Hilfszelle zB D1, welche die
manuelle Eingabe übernimmt, damit eine Formel in C1 nicht überschrieben
wird.

C1: =WENN(ODER(A1="";B1="");D1;A1*B1)

wenn A1 UND B1 jeweils einen Wert enthalten, wird das Produkt gebildet,
ansonsten wird dein manueller Eingabewert aus D1 übernommen

Gruß
Klaus
MrArtifex (20.12.2007, 14:31)
Hi Klaus,

danke dir! Soweit fast perfekt. Nur noch eine Kleinigkeit. Gibt es ne
Möglichkeit sagen wir Zelle A1 automatisch zu leeren, sobald ich jetzt was
in Zelle C1 eintippe? Dann wäre es perfekt.

danke dir
Gruß
Arti

"Klaus "Perry" Pago" <perry> schrieb im Newsbeitrag
news:5524
[..]
Klaus \Perry\ Pago (20.12.2007, 14:58)
Hallo Arti,

"MrArtifex" <billgates> schrieb im Newsbeitrag
news:8ab6
> Hi Klaus,
> danke dir! Soweit fast perfekt. Nur noch eine Kleinigkeit. Gibt es ne
> Möglichkeit sagen wir Zelle A1 automatisch zu leeren, sobald ich jetzt was
> in Zelle C1 eintippe? Dann wäre es perfekt.


das sprengt IMO Excels Formelmöglichkeiten. Mit Hilfe von VBA könnte ich mir
eine Lösung vorstellen. Vielleicht liest ja einer der VBA-Experten hier mit.

Gruß
Klaus
Alexander Wolff (20.12.2007, 17:58)
> ich habe eine Frage: Ich will eine Zelle so formatieren, dass wenn
> ich einen Wert manuell eintippe die Formel weg ist und der manuelle
> Wert genommen wird. Die Formel sonst bezieht sich auf zwei andere
> Zellen. Das heißt wenn beispielsweise Zelle A1 und B1 ausgefüllt
> sind, dann soll in Zelle C1 die Zellen A1 und B1 miteinander
> multipliziert werden. Wenn A1 oder B1 nicht ausgefüllt sind, dann
> will ich C1 manuell eingeben können. Die Formel soll aber zukünftig
> in der Zelle drin bleiben fürs nächste mal.


Das geht mit dem Worksheet_Change-Ereignis. Google mal danach.

Stellt dieses im Target eine leere Zelle fest, setzt es an deren Stelle eine
Formel. Wenn nicht, bleibt es so wie es ist.
Ähnliche Themen