expertenaustausch > microsoft.* > microsoft.excel

duduadam80 (02.04.2019, 15:13)
Ich habe einen sehr großen Datensatz, welcher in Spalte B immer einen von 20 möglichen Strings(Text) hat. Des Weiteren habe ich in den Zellen G1 bis G20 alle diese 20 möglichen Strings(Text) und in den Zellen H1 bis H20 jeweils einen Wert, der sich auf auf seinen jeweiligen Zellennachbarn G bezieht.

Ich muss es nun schaffen, dass ich in der Spalte C folgende Funktion habe.

Vergleiche den String in Spalte B in der gleichen Zeile mit den Strings in Zellen G1 bis G20. Wenn eine Zelle von G1 bis G20 mit dem String in Spalte B übereinstimmt, übernimm den Wert Wert der Spalte H, welcher derZeilennummer des übereinstimmenden Wertes aus Spalte G entspricht.

Ziel für Spalte C soll es somit sein seinen Nachbarn in B mit der Spalte G zu Vergleichen und den passenden Wert zu G aus H in Spalte C einzutragen.

Eigentlich komme ich mit IF Anweisung gut klar, jedoch weis ich nicht, wie ich es hinbekomme den Wert aus Zeile H einzufügen, sobald er weis welche Zeile in G den gleichen Wert hat, wie in Spalte B.

Ich hoffe sehr auf Hilfe! Vielen Dank schon einmal für Eure Gedanken zu meinem Problem!
Claus Busch (02.04.2019, 16:36)
Hallo,

Am Tue, 2 Apr 2019 06:13:44 -0700 (PDT) schrieb duduadam80:

> Ich habe einen sehr großen Datensatz, welcher in Spalte B immer einen von 20 möglichen Strings(Text) hat. Des Weiteren habe ich in den Zellen G1 bis G20 alle diese 20 möglichen Strings(Text) und in den Zellen H1 bis H20 jeweils einen Wert, der sich auf auf seinen jeweiligen Zellennachbarn G bezieht.
> Ich muss es nun schaffen, dass ich in der Spalte C folgende Funktion habe.
> Vergleiche den String in Spalte B in der gleichen Zeile mit den Strings in Zellen G1 bis G20. Wenn eine Zelle von G1 bis G20 mit dem String in Spalte B übereinstimmt, übernimm den Wert Wert der Spalte H, welcher der Zeilennummer des übereinstimmenden Wertes aus Spalte G entspricht.
> Ziel für Spalte C soll es somit sein seinen Nachbarn in B mit der Spalte G zu Vergleichen und den passenden Wert zu G aus H in Spalte C einzutragen.


probiere:
=SVERWEIS(B1;$G$1:$H$20;2;0)

Mit freundlichen Grüßen
Claus
Ähnliche Themen